Jump to content

Supplier / Manufacturer ajax error: parsererror, tried everything in the forum


Recommended Posts

I'm running last stable version of prestashop (clean install) and I'm getting the "Supplier ajax error: parsererror / Manufacturer ajax error: parsererror" in my store located at audiopartes.com. It wans't present at the beggining, it appeared out from nowhere with the store installed and fully working.


I've searched the forum and tried all solutions proposed and none of them worked. I tried:

  • Editing ajax.php: My ajax.php is already modified with trim fuction added. Also I restored it from backups and from new downloads of prestashop... didn't helped
  • Adding new manufacturers and suppliers
  • Contacting host company to check the server, they checked the logs and accessed the back office as admin and it works from their side. They succesfully edited an item.
  • Tried different browsers and computers: same behavior in all of them

I installed a local copy (wamp server) using the same database and code that is giving me problems in production server and it worked fine, no errors at all. But after a few hours... same problem appeared locally!!!! It shown up when I accessed from another computer in the network and had to modify the domain name in preferences->seo&urls from "localhost" to "" to make the bo accessible from the lan.


As I solved it locally re-installation seemed a solution, but now it reappeared it's making me crazy, as I can not edit any product in the store.


Also, I observed:

  • Categories doesn't load when adding or editing a new one, or when editing a product.
  • It seems the css style is not working or loading correctly in the backoffice when I access the catalog, as font is bigger than before and items in tables now doesn't fit completely in each row. I don't know if it is related and if it can help

Can anyone help me? I see in the forum that it is a recurring problem and I don't know where else to look for help or a solution

Edited by aferreiro (see edit history)
Link to comment
Share on other sites

  • 2 months later...

I've found that it might be caused by the encoding of the file in the server, forcing the server to throw an error 500 in files called using ajax, so it's not visible to you in the interface.


Try copying back-office files from a previous working backup copy, or if you don't have one, copy the backoffice from a working enviroment over your prodution one.


No need to say, always make a backup first.


iam also facing the same problem when adding products from back end

Edited by aferreiro (see edit history)
Link to comment
Share on other sites

  • 1 month later...

Temporal Solution. It's work for me...


Go to





Delete the Line: 2158


alert(\'Manufacturer ajax error: \'+textStatus);



Delete the Line: 2176


alert(\'Supplier ajax error: \'+textStatus);


That's not a solution. You are simply ignoring the warning. The error during XMLHttpRequest is still present, but not showing, so you are hiding a problem that could take your entire site down later. If the "check engine" light in your car turns on you have to take a look at the engine, not just turn off that light, that doesn't solve the problem.

Link to comment
Share on other sites

Hello, is this problem still occurring with a new install of 1.4.9? Thank you for the message.

I haven't tried 1.4.9 yet, but anyway, I haven't found the problem in a new install on any older version. The problem shows up later once you have added products to the database.

Link to comment
Share on other sites

  • 5 weeks later...

J'ai trouvé la solution, j'avais le même soucis ...


En fait j'avais importé ma base fournisseurs d'une autre application, et certains noms avait un \' dans le nom...


En changeant cela sur tous mes fournisseurs qui avaient ce problème, cela a fonctionné !

En fait, le caractère ' avait été changé par \' et la fonction ajax n'aime pas les \' .


Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...