Jump to content

Paypal not working: "Please wait, redirecting to Paypal" and "No template found for module PaypalPayment"


trivialtreasures
 Share

Recommended Posts

I cannot get my paypal module to complete a checkout. I have read several threads on the same issues, but nothing I have tried has fixed it. I have 2 different issues, depending whether or not the API setting is filled out:

When the API settings are filled out, and then I try to check out, I get this error message: "No template found for module PaypalPayment"

When the API settings are NOT filled out, and then I try to check out, it gets stuck at: "Please wait, redirecting to Paypal... Thanks. Cancel"

I am using prestashop version 1.4.2.5
I am using paypal version 2.4

This is a fresh install of prestashop. Nothing has been upgraded. I just installed it a week ago and have never been able to checkout.

I initially tried using the paypal module that comes with prestashop. I have tried uninstalling and reinstalling the paypal module several times. I have tried deleting and reuploading the /modules/paypal/ folder through FTP. I have tried changing permissions of the paypal folder to 775 and 777. I have tried changing both cache options on and off in Preferences -> Performance. None of that fixed it.

I have also noticed that my paypal module is listed under "Other Modules" instead of "Payments and Gateways".

If anyone can please help, I'd appreciate it very much.

Share this post


Link to post
Share on other sites

Thanks, but I did try choosing A B and C. I tried all three of them separate times, none of them worked. "A" is already automatically chosen anyway, it's impossible not to have any selected. And as far as I know, I'm not even using Integral Evolution. I don't think I have any of those three templates - There's no preview template thumbnail next to any of them and I would think that there should be, but I don't even know. Either way, even if I didn't have the template problem, I think I would still have that redirecting problem afterwards.

Share this post


Link to post
Share on other sites

I had a very similar problem, and I managed to fix it. I'm going to post it here in case it will help others, and maybe you too.

I am using prestashop version 1.4.10 and I was having the same behavior. I tried uninstall/install, enable/disable, clicking A, B, and C to no avail.

The way that I solved it is that I went back and downloaded Prestashop 1.4.10 and used the paypal module that came specifically with that version. This fixed my problem. Apparently I had deleted it, and then I went and downloaded my own version of the paypal module and this is what broke it. I assume that this is because it wasn't the right right version of paypal for my version of prestashop. I could see something similar happening if you try to upgrade and assume that your paypal does not need to be upgraded.

I realize that you said you tried the version already that came with your prestashop, and that you did not do any upgrades, so I guess the only help I can give is that perhaps version 2.4 of paypal is not the right one for 1.4.2.5. A worse case scenario is that you try an older version of prestashop. After all, paypal 2.4 is the same version that works for my 1.4.10 so maybe the paypal module is in need of an upgrade.

Finally, when I messed up my paypal module by downloading it instead of using the one that came with my prestashop, it showed up under my 'Other' category as well. Now it shows up (correctly) under the 'Payments and Gateways' category.

Don't know if any of that helps...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More