Jump to content
Sign in to follow this  
jomcdonald

[TUTORIEL] intégrer google +1 sur votre boutique

Recommended Posts

Voici la méthode pour intégrer le bouton +1 de google sur les pages produits (sous l'image du produit).

1- Dans "header.tpl" insérez le code suivant entre {$HOOK_HEADER} et la balise "</head>" :


Important: enlever le - à "s-cript"

2- Dans "product.tpl" insérez le code suivant entre "

  • " et {if $HOOK_EXTRA_LEFT}{$HOOK_EXTRA_LEFT}{/if} :




Voici une capture du résultat.

46898_0tr1ckVSIbizBNM8rkkg_t

Share this post


Link to post
Share on other sites

Bonjour
Ca ne marche pas pour moi (version 1.3.7)
J'ai bien enlever le - mais rien ne se passe
Pouvez vous m'aider SVP
Merci

Share this post


Link to post
Share on other sites

Avez vous modifié les 2 fichiers?
Cette astuce est compatible 1.4 et 1.2 donc surement 1.3.x mais je ne l'ai pas testé sur cette version.
Avez vous essayé avec le thème d'origine?

Share this post


Link to post
Share on other sites

Bonjour,

J'ai suivi précisément les instructions du tutorial et sans oublier aussi d'enlever le "-" J'ai modifié les 2 fichiers mais malheureusement le bouton +1 Google n'apparaît pas. J'ai même rafraichi le cache et forcer compilation, mais toujours rien qui apparaît.

J'utilise la toute dernière version de PS v1.4.2.5

Est-ce que j'ai manqué un petit détail ? Veuillez S.V.P. m'aider un grand merci d'avance.

Cordialement.

Share this post


Link to post
Share on other sites

Tomastouch ton code est OK.
Il est fort probable que votre thème ne soit pas compatible.

Essayez tout de même avec mes paramètre perso: Facebook + google
Mais je doute d'un changement.

product.tpl


<!-- usefull links-->




header.tpl
{$HOOK_HEADER}


</head>

Share this post


Link to post
Share on other sites

Merci je vais essayer ca
Concernant le theme , c le theme prestashop legerement arrangé mais rien de bien sorcier

Share this post


Link to post
Share on other sites

Ici ça fonctionne en enlevant bien le - de s-cript (sur celui du début et celui de la fin !!). Et en mettant au bon endroit la ligne dans product.
Donc fonctionne sur 1.3.1 et thème matrice.
Merci bcp.

Share this post


Link to post
Share on other sites

Bonsoir apprentice
J'ai essayer avec tes parametres et non , ca ne marche pas non plus
Merci et bonne soirée
Je vais continuer mes recherches

Share this post


Link to post
Share on other sites

Merci pour ce tuto.
Effectivement à lire et essayer par ci par là les différentes méthodes (dont celle-ci), j'ai toujours un problème car une fois cliqué mon bouton +1 devient rouge avec un point d'exclamation. Google me renvoit vers une page sans trop d'explications.
- J'ai donc vérifier que cela ne venait pas de mon compte Google, la réponse est non car je peux faire de +1 sur d'autres sites.
- J'ai essayé avec le thème d'origine PS, idem
- J'ai essayé via cette fonction, idem.
- J'ai essayé via le code Addthis, idem.

C'est lié à Prestashop mais à quoi ?

Share this post


Link to post
Share on other sites

Bonjour,

Comme sur le post 7 , tout est installé correctement je n'ai rien.
Testé sur une boutique en 1.4.3 de test neuve avec thème d'origine et sur une 1.4.3 en service avec theme modifié.

Cordialement

Share this post


Link to post
Share on other sites

Pour info, j'ai corrigé le problème en désinstallant le module url canonique natif sur le domaine en français, pour le remplacer par le module seofix qui génère des pages canoniques spécifiques.
D'après discussion sur d'autres forums, Google +1 peut être bloqué par une définition hasardeuse des url canoniques.
Si ça peut vous servir...

Share this post


Link to post
Share on other sites

Merci, ça marche bien, mais si on laisse la ligne "lang fr" du code donné par Google pour le bouton français, ça plante

 {lang: 'fr'}



sans cette ligne, OK, mais alors quand les gens cliquent sur le bouton il reçoivent les instructions en anglais...

une solution ?

Share this post


Link to post
Share on other sites

Salut !

J'ai suivi le tutorial à la lettre et rien ne s'affiche. Toujours pas de solutions ?

template uhu
version 1.4.1

Share this post


Link to post
Share on other sites

j'ai réussi, en revanche, les module facebook like et google+1 sont collés,

comment puis-je les décoller un peu svp ??

merci les gas !!

48721_r3hOYtkrAqYBLAfS5lQw_t

Share this post


Link to post
Share on other sites

Sorry, je ne sais pas...
Réduire la taille du bouton peut-être ?

Share this post


Link to post
Share on other sites

Merci bien. Le module est à 30€ donc... :)

30* pour un module comme ça voila l'arnaque profitez des gens qui y connaissent rien et qui veulent vendre c'est petit...

Quand je vois le nombre de modules inutiles et cher ça fait peur.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More