Jump to content

Kernel Container is not available - Upgrading Prestashop


Recommended Posts

Hi all, really hope someone can help me with this! We've been trying for months now to upgrade safely from Prestashop to 1.7.8

When we run the upgrade - and include the /install directory, after all the files have been update - we see the following error when running the database upgrades, something to do with  Kernel Container is not available.


[Mon Nov 06 11:59:36.719701 2023] [proxy_fcgi:error] [pid 3374385:tid 139838523156224] [client] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught PrestaShop\\PrestaShop\\Core\\Exception\\ContainerNotFoundException: Kernel Container is not available in /var/www/preprod.hobby-genki.com/src/Adapter/ContainerFinder.php:77\nStack trace:\n#0 /var/www/preprod.hobby-genki.com/classes/Tools.php(797): PrestaShop\\PrestaShop\\Adapter\\ContainerFinder->getContainer()\n#1 /var/www/preprod.hobby-genki.com/classes/Notification.php(133): ToolsCore::getContextLocale(Object(Context))\n#2 /var/www/preprod.hobby-genki.com/classes/Notification.php(57): NotificationCore::getLastElementsIdsByType('order', '0')\n#3 /var/www/preprod.hobby-genki.com/admin9662/ajax.php(120): NotificationCore->getLastElements()\n#4 {main}\n thrown in /var/www/preprod.hobby-genki.com/src/Adapter/ContainerFinder.php on line 77\n', 

Attached is a small video of when the error occurs - it's reported as an AJAX error but the logs show the above ^ 

I have seen similar mentioned here: 

And so I tried the same code edits on upgrade.php and still it has not worked: https://github.com/PrestaShop/PrestaShop/pull/14620/commits/b00b69060996cb9581f38c19171a1458b9e5971f

Has anyone ever dealt with this before? 

Cany anyone offer any help? Please it would be so amazing. 

Thank you all so much!  🙏

Link to comment
Share on other sites

Hi thanks so much for your help on this! Very much appreciated. 

Actually our host ended up making the upgrade for us but they did it manually not using the 1-Click upgrade module. 

I think our files have the correct file permissions but I can check this. 

Our setup is Debian 11 on a VM with PHP 8.1 and PHP 7.2 - using PHP-FPM to allow both versions to be executed according to our host. Does that mean we're not using Apache? 

We do actually have files in the Override directory - I'm sure what they are since I didn't work on the early version of the site. What would you recommend there? That we remove the files from the Override directory while the upgrade happens? 

Link to comment
Share on other sites

  • 2 weeks later...

Ah that's an interesting idea, I have attached a screenshot of our overrides file this is all I can see: 

Actually the Smarty directory just had a default index file in there - in fact they all seem to have empty directories with default index.php 

We are also getting a kernel error again - do you understand what this means? 

Just another question if I may -what is the latest version of Prestashop!? We are trying to upgrade from 1.7.5 to 1.7.8 but then I see the latest version is actually version 8! Does that mean 1.7.8 or actual version number 8? Because that's a big jump from 1.7.8 to 8. For example their Github page I can see 1.7.8 and also version 8. What is going on? Can you help me understand this? See: https://github.com/PrestaShop/PrestaShop/releases

Thanks for all your help so far! 

Screenshot 2023-11-20 at 12.18.03.png

Screenshot 2023-11-21 at 00.15.11.png

Link to comment
Share on other sites

As for the override files: normally when you uninstall modules they will remove their overrides. If you just delete modules the overrides may stay behind and cause trouble. One way to find out what overrides are for is to look into the file. Often above the functions you will a text telling you for which module they are. My free Prestools software offers a more comprehensive function to see from which module overrides come.

Under Advanced Settings->Performance Prestashop offers a menu option to disable overrides. You can just try it to see whether it has any effect.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...