Jump to content
ruloo

Problems with installation - persmission

Recommended Posts

Hi,

I'm trying to install Prestashop 1.7 on my http server created in VirtualBox (Centos 7).

I set files permissions to 777 (I know that the permissions should be 755 for folders and 644 for files, 777 is only for tests) and ownership to apache user but I still get an error: An error has occured:
You need to grant write permissions for PHP on the following directory: /var/www/html/shop

Is there anyone who have any idea what's wrong?

obraz.png.7619455c45dedfb9a00730a0e1042660.png

obraz.png.a2a54db521f40388a8e18fee30f58f1e.png

Thanks

Share this post


Link to post
Share on other sites

I have just overcome this problem. I am running selinux on fedora 32. SElinux error browser woke up and recommended to take some actions. This helped me to move forward.

But now I have other problems moving on in the installation. I get stuck on system compability check. I get an empty error message. Trying to install 1.7.7.0 beta2

Share this post


Link to post
Share on other sites
On 11/5/2020 at 4:44 PM, Gunnar said:

Trying to install 1.7.7.0 beta2

There is already RC1 released, better got with that version.

 

On 11/5/2020 at 4:44 PM, Gunnar said:

I get an empty error message

Whats your PHP version? Any errors in the error log files?

Share this post


Link to post
Share on other sites
12 minutes ago, JBW said:

There is already RC1 released, better got with that version.

 

Whats your PHP version? Any errors in the error log files?

I have PHP 7.4.12 (cli). When running php --version I get "PHP Warning:  PHP Startup: Unable to load dynamic library 'mysqli' (tried ....." & " PHP Warning:  PHP Startup: Unable to load dynamic library 'php_pdo_mysql.so' (tried: ....." & "PHP Warning:  PHP Startup: Unable to load dynamic library 'php_gd2.so' (tried: ...." Also claiming "No such file or directory" for these.

The funny thing is that I did made a "dnf update". And after that the Prestashop installation reported all fine and finalized the installation and all is looking good in BO. I've have imported categories, combinations and products. All is looking good. But still I have the warnings from "php --version"

Share this post


Link to post
Share on other sites
10 minutes ago, Gunnar said:

have PHP 7.4.12

Prestashop 1.7.7. is only compatible until PHP 7.3 - so you have to downgrade. And anyway you have to check why the libaries are not loaded

Share this post


Link to post
Share on other sites
8 minutes ago, JBW said:

Prestashop 1.7.7. is only compatible until PHP 7.3 - so you have to downgrade. And anyway you have to check why the libaries are not loaded

Oh. Thanks JBW.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More