Jump to content
pertho

[LUKKET] Simply.com opgraderer til PHP7.4. den 25.8.2020. Se her hvordan det påvirker din shop

Recommended Posts

Simply.com opgraderer PHP version fra PHP7.2 til PHP7.4 den 25.8.2020.

Jeg har lige prøvet den i et testsystem med en shop, som er på PS 1.7.6.5. Der er blandt andet problemer med oprettelse af varer, og så gik jeg ikke videre.

Så konklusionen må være, at PS versioner mindre end eller lig med 1.7.6.5 ikke virker med PHP7.4.

Afhængig af PS version, kan I sætte den manuelt i .htaccess filen. Du kan læse her, hvordan du gør.

Det sikreste ville være at sætte den til PHP7.2. Men min ene shop på PS 1.7.6.5 kører fint med PHP7.3. Den anden shop på PS1.6.1.23 kører fint med PHP7.3. 

Tilføjelse:
PHP7.4 virker ikke i PS1.7.6.7 (som er den nyeste).
PHP7.4 ser ud til at virke i PS1.7.7.0 (Som pt kun er i beta).

Opsummering 17.08.2020:
PHP7.3 virker på PS1.6.1.23. Virker måske også på mindre versioner af PS 1.6.x.x?
PHP7.3 virker på PS1.7.6.5. Virker måske også på mindre versioner af PS 1.7.x.x?
PHP7.4 virker ikke i PS1.7.6.7 (som er den nyeste).
PHP7.4 ser ud til at virke i PS1.7.7.0 (Som pt kun er i beta).

Edited by pertho (see edit history)

Share this post


Link to post
Share on other sites

Ja, det ser godt nok skidt ud. Min lokale Linux-maskine er også lige blevet opgraderet til PHP 7.4. Den kan jeg ikke bruge til så meget, når PrestaShop ikke engang virker med 1.7.6.5. Så kan jeg heldigvis falde tilbage på den gode gamle PHP 5.6. Men der må være mange hos simply.com, der bliver ramt af det her.

 

/Kjeld

Share this post


Link to post
Share on other sites
10 hours ago, presta-dyr said:

Ja, det ser godt nok skidt ud. Min lokale Linux-maskine er også lige blevet opgraderet til PHP 7.4. Den kan jeg ikke bruge til så meget, når PrestaShop ikke engang virker med 1.7.6.5. Så kan jeg heldigvis falde tilbage på den gode gamle PHP 5.6. Men der må være mange hos simply.com, der bliver ramt af det her.

 

/Kjeld

Ja. Der kommer sikkert mange indlæg her på forum den 25. Det er det jeg prøver at komme lidt i forkøbet med mit indlæg.

Share this post


Link to post
Share on other sites

hm.. jeg køre stadig på PHP 5.6 med min PS 1.6.1.6 - den crashede totalt dengang de gik på PHP 7xx

jeg køre derfor på "application/x-httpd-php-old .php" functionen via .htaccess

men som jeg kan læse kan det være den virker på php 7.3 ? 

er der nogen der har testet med den specifikke PS version 1.6.1.6

Share this post


Link to post
Share on other sites

PHP7.3 vil ikke virke på din shop.

Jeg havde i januar 2019 denne tråd. Den gang var jeg på PS1.6.1.7, som ikke kunne klare PHP7.1. Men du kan jo sætte den til PHP7.0. Det har simply.com jo givet mulighed for nu. Det kunne man ikke dengang.

Share this post


Link to post
Share on other sites
3 hours ago, pertho said:

PHP7.3 vil ikke virke på din shop.

Jeg havde i januar 2019 denne tråd. Den gang var jeg på PS1.6.1.7, som ikke kunne klare PHP7.1. Men du kan jo sætte den til PHP7.0. Det har simply.com jo givet mulighed for nu. Det kunne man ikke dengang.

ok, tak for linket, det må jeg prøve af... ellers står jeg jo med balladen den dag de cutter php 5.6 - vil gerne undgå at skulle lave egen webserver, blot for at komme over det problem at shopsystemet ikke opdateres længere til at kunne følge med nye PHP versioner.

Share this post


Link to post
Share on other sites
1 hour ago, diondp said:

ok, tak for linket, det må jeg prøve af... ellers står jeg jo med balladen den dag de cutter php 5.6 - vil gerne undgå at skulle lave egen webserver, blot for at komme over det problem at shopsystemet ikke opdateres længere til at kunne følge med nye PHP versioner.

Du kunne jo også overveje at opgradere din shop til nyeste PS1.6.1. Mener den hedder 25 til sidst. Så kan du bruge PHP7.3.

Jeg tror dog ikke at de dropper PHP5.6. Det er åbenbart den alle webhosts holder fast ved for ikke at lade nogen i stikken. 

Share this post


Link to post
Share on other sites

P.S. 1.6.2x kan køre med PHP 7.2, men har man ikke standard moduler, er det ofte dem der giver fejl pga. manglende opdatering. Jeg vil klart anbefale minimum PHP 7.0, sikkerheden og ikke mindst hastigheden er meget bedre end 5.6

Share this post


Link to post
Share on other sites

Jeg har mine shops hosted hos Simply, og har betalt et firma der laver Prestashop for at lave et fix til mig.

 

Så mine shops kører nu på den nye version af PHP som Simply har installeret....

Share this post


Link to post
Share on other sites

Lukkes. Der kan efterhånden ikke være flere, der kunne være ramt af den opgradering.

Simply.com's support har formentlig løst en del.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More