Jump to content

Impossible to add a product to cart on my new host


Recommended Posts

Hello everyone,


I've been working on a new prestashop version (1.7) of an old prestashop website (1.6) on a different host (let's call it : staging).

Everything was working perfectly fine on this host so we decided to move the files and database to the old host (OVH, shared : prod).

For the record, here are the steps I followed :

- Removed all files from prod host and truncated all tables

- Exported database from staging and replaced all occurences of 'staging.domain' to 'prod.domain'

- Uploaded all files and edited configuration for myqsl connection

- Imported database

- Regenerated .htaccess via admin


At first everything was looking fine but when I add a product to cart from a product single page, the ajax POST call returns a 302 response and then my browser starts an infinite loop. I then have to manually clear the cache of my browser to clear the TOO_MANY_REDIRECT error.

Any idea why apache is responding with a 302 ? On my staging environment this is working perfectly fine, the call is answered with a 200 and the cart data as json payload.


I'm pretty sure this is not related to any module since the same are installed on the staging environment.

The theme in use is Sting.


I can provide any further information if needed,

Thanks in advance for your help

Link to comment
Share on other sites

I am really what you are doing. Just copying tables from PS 1.7 to 1.6? Sounds like asking for trouble.

Did you check the data in ps_shop_url. 

Watch also SSL. Try to disable it for the moment. SSL can produce this kind of trouble - for example when there is one place that redirect http to https and another that redirects back.



Link to comment
Share on other sites

Hello musicmaster,


Thanks for your attention, you're mistaken, I didn't clone the website from 1.6 to 1.7. I've set up on an alternate host a new prestashop 1.7 environment and when everything was perfectly setup, I tried to clone from the new host to the old one (after erasing everything and upgrading PHP version from 5.6 to 7.1). That's when the redirection chain when adding a product to cart appeared.


I've also tried to disable SSL, since I got more attention on Prestashop's github you can find more information of the steps I took to troubleshoot this problem on this issue :


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...