Jump to content
Luisle7

No se ven los gráficos de la pestaña de inicio del backoffice

Recommended Posts

Cuando accedo al BackOffice, en la pestaña de inicio, no se ven ni los gráficos de previsiones ni los de ventas.

Si que se ve lo que es el entorno, pero en el gráfico sale siempre a 0, cuando ha habido ventas y deberían de verse los picos.

¿Alguna idea de qué puede suceder?, el gráfico de ventas he desinstalado y vuelto a instalar el módulo y ni por esas.

Un saludo.

Share this post


Link to post
Share on other sites

Buenos días,

Es un problema muy muy común, de todas formas lo más óptimo (para tu servidor y clientes) es que tengas una plataforma externa como puede ser Nirvine KPI para que la analítica sea precisa al 100% para tener controladas las ventas, clientes, productos y campañas al 100%

un saludo y mucha suerte!

Share this post


Link to post
Share on other sites

Hola @Luisle7

Damos por hecho que cambias los rangos de fechas para realizar la consulta ¿verdad?

Prueba también a reinicializar el módulo.

¿Puedes mandar un pantallazo?

Saludos.

Share this post


Link to post
Share on other sites

@Luisejo el módulo como puse lo reinicialicé pero sigue el mismo problema.

Si que he cambiado las fechas a ver si pasaba algo, pero ni por esas...

Adjunto pantallazo tal y como me has solicitado, ocultando obviamente los datos que no se pueden poner de forma pública y que tampoco hacen falta para este tema.

Un saludo.

 

pantallazo.jpg

Share this post


Link to post
Share on other sites

Hola, ¿si pones un rango de fechas menor tampoco te funciona? por ejemplo de ayer a hoy. Es que veo que estás intentando mostrar 1 año entero y a veces, según la cantidad de datos que tenga la base de datos y según el hosting puede llegar a dar time out y no mostrar nada.

Abre también la consola de navegador para ver la llamada que hace y comprobar que todo está correcto.
A ver si ahí podemos detectar algún error en el JS.

Ya nos cuentas.
Saludos.

Share this post


Link to post
Share on other sites

Mil gracias @Luisejo por tu preocupación.

Ponga el rango de fechas que ponga, no muestran nada los gráficos, así que por ahí no va el problema.

Pego lo que me dice la consola en cuanto a problemas de JS y demás:

----------

El recurso en “http://www.google-analytics.com/analytics.js” ha sido bloqueado porque está habilitado el bloqueo de contenido.

Error en el mapeo fuente: Error: NetworkError when attempting to fetch resource. URL del recurso: moz-extension://c6deedb2-a26d-44fa-a965-977788db4f92/node_modules/webextension-polyfill/dist/browser-polyfill.js URL del mapa fuente: browser-polyfill.js.map

Error en el mapeo fuente: Error: request failed with status 404 URL del recurso: http://www.midominio.com/backoffice/themes/default/css/admin-theme.css URL del mapa fuente: admin-theme.css.map

La codificación de caracteres de un documento en un marco no ha sido declarada. El documento puede mostrarse de manera diferente si se visualiza sin el documento que lo invoca como marco. enquire.min.js

La codificación de caracteres de un documento en un marco no ha sido declarada. El documento puede mostrarse de manera diferente si se visualiza sin el documento que lo invoca como marco. admin-theme.js

Campos de contraseña presentes en una página insegura (http://). Esto es un riesgo de seguridad que permite que se roben las credenciales de inicio de sesión de los usuarios.

El recurso en “http://www.google-analytics.com/analytics.js” ha sido bloqueado porque está habilitado el bloqueo de contenido.

Error en el mapeo fuente: Error: request failed with status 404 URL del recurso: http://www.midominio.com/backoffice/themes/default/css/admin-theme.css URL del mapa fuente: admin-theme.css.map

----------

Un saludo.

Share this post


Link to post
Share on other sites

Prueba a reinicializar el módulo de ventas y pedidos. A ver si así se soluciona el problema.
Te recomiendo hacer una copia de código fuente y base de datos antes de realizar cualquier otra acción.

image.png.1da676b7dc886d84b3f0520a4c39715e.png

Nos cuentas qué tal fue.
Saludos.

Share this post


Link to post
Share on other sites

@Luisejo a pesar del reinicio de este módulo, el problema persiste. Ya había hecho este reinicio y lo he vuelto a hacer ahora.

Igual es un bug como ha dicho @Daniel Díaz y no hay mucha solución.

Un saludo.

Share this post


Link to post
Share on other sites

¿Qué versión Prestashop tienes?
¿No te ha funcionado nunca?
A ver si vas a tener los stats desactivados para que no consuma DB

Saludos.

Share this post


Link to post
Share on other sites

Hola @Luisejo mi Prestashop está en la versión 1.6.1.11 y creo que estos gráficos no han funcionado nunca.

No se si tengo eso que dices desactivado, no se donde verlo.

No obstante me están saliendo el resto de datos numéricos informativos en esas estadísticas, lo único que fallan son los gráficos.

Un saludo.

Share this post


Link to post
Share on other sites

Hola de nuevo,

¿No tendrás ningún módulo activado como el stats data cleaner o similar?

Otra opción... Prueba buscar el modulo: Tabla de mando de estadísticas (statsforecast) en la pestaña módulos -> módulos haz click en configurar y en la parte superior donde dice un rango de fechas, ponle un rango valido. Y pruebas.

Y como última opción, si tienes el módulo de Google analytics, desinstálalo y prueba.

Ya me cuentas qué tal.
Saludos.

Share this post


Link to post
Share on other sites

@Luisejo de nuevo gracias por tu preocupación.

No tengo un módulo como el que dices instalado de limpieza de estadísticas.

En el módulo de "tabla de mando de estadísticas" he puesto el último mes y sigue sin funcionar el tema de los gráficos.

Por último, si que tengo un módulo de Google Analytics, lo he desinstalado y todo ha seguido igual, así que lo he vuelto a poner.

Un saludo.

Share this post


Link to post
Share on other sites

Hola, pues la verdad es que me voy quedando sin alternativas.

A ver si a alguien más en el foro le ha ocurrido y nos da un toque de luz :)

Saludos.

Share this post


Link to post
Share on other sites
On 11/18/2019 at 7:46 AM, Luisejo said:

Hola, pues la verdad es que me voy quedando sin alternativas.

A ver si a alguien más en el foro le ha ocurrido y nos da un toque de luz :)

Saludos.

Prueba Nirvine KPI, en el peor de los casos te llevas un reporte de ventas, clientes y productos gratis (trial) ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More