Vote to Improve PrestaShop

PrestaShop Forum: Build a free online shop. Count on the Community!

The best place in the world to ask questions about PrestaShop and get advice from our passionate community!

PrestaShop Forum: Build a free online shop. Count on the Community!

Jump to content

Photo

Mondialrelay 1.7 - Error 97 durant la sélection des points relais


  • Please log in to reply
20 replies to this topic
Vincent Schoener

    PrestaShop Apprentice

  • Members
  • PipPip
  • 330 posts

Posted 05 September 2011 - 10:22 AM

Bonjour,

J'ai remarqué un problème récurrent lors de cette mise à jour sur beaucoup de boutique quel soit en 14.1, 14.2, 14.3 et 1.4.4. Beaucoup de personne se voit confronter à ce message d'erreur lors de la récupération des points relais lors du checkout process :

Posted Image

En faite c'est du au fait que dans la partie back office de votre boutique, section Transport => Pays => Sélection de votre pays par défaut => Le Champ Format du code postal est vide et vous devez donc le renseigner en fonction du pays choisi.

Ce champ est nécessaire et doit etre normalement remplis par défaut pour vérifier le format du code postal avant l'envoi des donnée à Mondial relay.

A savoir que je viens d'y ajouter une modification afin que ce problème ne soit plus présent dans les prochaine version du module.

En espérant que ça aide ;)


Vincent Schoener • Freelance -Lead Developer @Batiwiz - Ex core developer @Prestashop

Développeur agréé PrestaShop

les2juls

    PrestaShop Apprentice

  • Members
  • PipPip
  • 44 posts

Posted 05 September 2011 - 05:26 PM

Bonjour,

Merci pour cette info.
J'ai aussi ce message d'erreur mais pas en Front Office lors de la sélection du point relais par le client mais dans la backoffice lorsque je souhaite générer l’étiquette.
J'ai eu dernièrement une commande vers la Belgique et j'ai ce message d'erreur:

This key [Dest_CP] hasn't a valid value format : 1000
There is an error number : 97
Details : Clé de sécurité invalide

Apparemment cela viendrait donc de ce que vous citez plus haut sauf que pour mon cas je suis en version 1.6 du module Mondial Relay.
Cela fonctionnait bien pour les commandes vers la France, c'est la première que j'ai pour la Belgique depuis que je suis en v1.6.

Depuis que j'ai eu ce bug, je n'ai pas eu de commande Mondial Relay vers la France, donc je ne sais pas si je vais avoir le même problème.

Pensez vous que je dois renseigner les champs CP de l'onglet Transport ?

En vous remerciant d'avance. Bien cordialement.

Julien
Prestashop 1.4.4.

quinou

    PrestaShop Apprentice

  • Members
  • PipPip
  • 108 posts

Posted 06 September 2011 - 01:00 AM

Bonjour,
Avec le format du code postal, ça fonctionne bien ds le Front office.
Mais la génération d'étiquettes n'a pas lieu. Le "temporisateur" apparait, puis la commande est effacée de la partie haute mais ne réapparait pas ds "Historique de la création d'étiquettes". Il n'a pas de message d'erreur. Il n'est donc pas possible d'imprimer l'étiquette. Aucun enregistrement n'a lieu non plus ds la table "mr_historique"
PrestaShop 1.4.3
MR ver 1.7
Merci pour une réponse future

quinou

    PrestaShop Apprentice

  • Members
  • PipPip
  • 108 posts

Posted 07 September 2011 - 04:51 PM

Bonjour,
un petit up !
Je viens également de faire un test en local avec la vers P.S. 1.4.4.1 d'origine, MR vers 1.7 et mes paramètres du compte Mondial Relay. Mais là non plus la génération d'étiquette ne se fait pas, pas de message d'erreur ni d'enregistrement ds "mr_historique"
Ce module est il vraiment opérationnel ou doit on encore attendre ?
André

Vanessa10

    PrestaShop Apprentice

  • Members
  • PipPip
  • 26 posts

Posted 07 September 2011 - 05:11 PM

J'ai déjà posté mais j'interviens dans ce post en espérant enfin avoir de l'aide !
Idem je suis en version 1.4.4.0 et MR en V1.7, la liste des point relais n'apparait pas , il cherche même pas, et pas non plus de message d'erreur..

Pour les étiquettes j'en sais rien, on verra après ce premier problème..

Ca fait deux semaines que j'essaye d'avoir de l'aide sur Mondial Relay et que je cherche désespérément.. si quelqu'un peut enfin nous venir en aide ce serait super..

au moins nous suggérer des pistes...

Merci d'avance !!!

sylvain41

    PrestaShop Newbie

  • Members
  • Pip
  • 10 posts

Posted 08 September 2011 - 12:57 PM

Bonjour à tous,

Je relance la discussion sur les err mondial relay.

J'ai la version 1.3.7.0 et effectivement après avoir installer le module mondial relay 1.7 j'ai également l'erreur

There is an error number : 97 et détail : clé de sécurité invalide

Sous ma version de prestashop je ne peut choisir un format de code postal option non disponible.

Que faire et aucun service technique mondial relay?

Merci d'avance et bonne chance à tous.

Vanessa10

    PrestaShop Apprentice

  • Members
  • PipPip
  • 26 posts

Posted 13 September 2011 - 08:30 AM

Bonjour,

Sylvain, j'ai eu le même problème que toi point de vue code postal et téléphone, YanK a corrigé ce problème dans mon module et tout fonctionne : voir le post : http://www.prestasho...post__p__628449

sylvain41

    PrestaShop Newbie

  • Members
  • Pip
  • 10 posts

Posted 16 September 2011 - 07:23 AM

Merci je suis allé voir, j'ai installé la version 1.4 de mondial relay mais cela ne fonctionne tjr pas.

shamon

    PrestaShop Addict

  • Members
  • PipPipPip
  • 730 posts

Posted 16 September 2011 - 08:24 AM

moi ça fonctionne mais je n'ai pas de raccourcit ds le back office pour générer les étiquettes,et personne ne répond sur le forum,j'espère pour vous que ce n'est pas la prochaine étape...
PS 1.3 - PS 1.4.1

Vincent Schoener

    PrestaShop Apprentice

  • Members
  • PipPip
  • 330 posts

Posted 26 September 2011 - 03:05 PM

Bonjour à tous,

Désolé de la réponse tardive :/

J'ai corrigé quelques bugs concernant MondialRelay, elle passe donc en version 1.7.2, si vous pouvez mettre à jour le module et me dire si vous rencontrez le moindre problème :)

Je reste à disposition pour tout problème lié à ce module

Cordialement
Vincent Schoener • Freelance -Lead Developer @Batiwiz - Ex core developer @Prestashop

Développeur agréé PrestaShop

shamon

    PrestaShop Addict

  • Members
  • PipPipPip
  • 730 posts

Posted 26 September 2011 - 09:01 PM

merci
PS 1.3 - PS 1.4.1

Patrick24000

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 posts

Posted 24 December 2011 - 12:39 AM

Bonsoir,

Je pensais que Mondial Relay allait me permettre de doper mes ventes en réduisant les frais de port. En fait, il dope surtout les réclamations des clients mécontents.

PS 1.4.4.1 (panier one page checkout + guest checkout, Smarty 3) - Mondial relay 1.7.9 - Format codes postaux conformes à ce qui est indiqué dans ce thread.

Premier essai panier : Tout semble fonctionner normalement sauf que le prix des frais de transport est indiqué pour la première fois en "H.T" (aucune taxe n'est utilisée dans ma boutique). Bref.

Identification => Les relais apparaissent bien.

1ère manip : J'augmente le nombre d'un même article jusqu'au changement de tranche de poids (et donc de prix). Mondial Relais est toujours coché mais les points relais ont disparu. Je coche donc un autre transporteur (Colissimo) et je reviens sur Mondial Relay. A ce moment là :
There is an error number : 97
Details : Clé de sécurité invalide

2ème manip : Déconnexion, reconnexion (récupération du panier). Toujours la même erreur ! :angry:

3ème manip : Je vide le panier, je me déconnecte. Je refais une autre commande (je n'oserai jamais demander ça à un vrai client ; ça fait peur).
Les frais de livraison sont toujours "H.T". Mondial Relay est définitivement bloqué :
There is an error number : 97
Details : Clé de sécurité invalide


4ème manip : Forcer la compilation "OUI" - Cache "NON" puis nouvelle commande : Les relais apparaissent de nouveau (l'erreur 97 a disparue). Les tarifs transporteurs sont de nouveau en H.T.

Mondial Relay étant toujours sélectionné, je rajoute un article au panier :
There is an error number : 97
Details : Clé de sécurité invalide

A noter qu'à ce moment précis, les tarifs transporteurs sont à nouveau affichés normalement (et non plus en H.T).


"Le module Mondial Relay pour PrestaShop a été développé par l'équipe de PrestaShop, garantissant une pleine compatibilité avec la solution de boutique en ligne PrestaShop."

Ah bon ??? Je ne sais pas si Mondial Relay est informé de tous nos déboirs mais en l'état actuel, c'est totalement inexploitable pour bon nombre d'utilisateurs (d'après ce que j'ai pu lire sur ces forums) !

Concrètement Vincent, on fait quoi ?

Patrick

Kali

    PrestaShop Apprentice

  • Members
  • PipPip
  • 277 posts

Posted 25 December 2011 - 03:50 PM

n'est-ce pas plus intéressant d'utiliser SoColissimo ?

J'ai la version 1.6.0.8
Mon hébergeur : PlanetHoster
 


Patrick24000

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 posts

Posted 27 December 2011 - 05:27 PM

n'est-ce pas plus intéressant d'utiliser SoColissimo ?

Bonjour,

En terme de fonctionnement : très certainement.
En terme de coût : ça m'étonnerait...

La Poste ne fait aucun effort pour sa tarification SoColissimo. Comparez leur tarif avec celui de Mondial Relay, et vous comprendrez...

Patrick24000

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 posts

Posted 27 December 2011 - 05:45 PM

Suite de mon post du 24 décembre (ci-dessus)

Après avoir lu quelques discussions à ce sujet, j'ai décidé de me passer des avantages du "one page checkout" s'il s'agit de LA solution pour que le module MondialRelay fonctionne.

Résultats : Plusieurs essais satisfaisants avec mon compte client de test dont une commande validée (sans toutefois aller jusqu'à créer l'étiquette d'expédition). Mais aujourd'hui, c'est de nouveau l'éternel blocage "There is an error number : 97" + clé de sécurité invalide aussi bien avec mon compte qu'avec celui d'un client réel qui tentait de passer commande !

Y aurait-t-il un développeur dans l'équipe Prestashop qui pourrait répondre, ou faut-il signaler ce (gros) problème directement à Mondial Relay ?

Kali

    PrestaShop Apprentice

  • Members
  • PipPip
  • 277 posts

Posted 27 December 2011 - 09:57 PM

J'ai vraiment l'impression que tout le monde s'en fiche !
J'ai signalé récemment ce problème à Mondial Relay : pas de réponse ! Pour ma part j'utilise les Lettre Max de la poste, achetées par paquets de 10 c'est vraiment intéressant, pensez-y si ce que vous envoyez est petit.

J'ai la version 1.6.0.8
Mon hébergeur : PlanetHoster
 


Patrick24000

    PrestaShop Apprentice

  • Members
  • PipPip
  • 41 posts

Posted 03 January 2012 - 11:52 PM

EUREKA !!!???

N'ayant reçu aucune réponse de Prestashop :(, j'avais envoyé un mail directement à Mondial Relay pour tenter de sortir de cette impasse, en les invitant à lire ce sujet ainsi que celui-ci : http://www.prestasho...ns-point-relay/

La personne qui a pris les choses en main (Philippe H.) m'a alors fourni une information intéressante relative au dernier essai que j'avais effectué avec un article de 2040 g :"le poids transmis dans la requête est de 2040000 grs, soit plus de 2 Tonnes" !

J'ai donc tenté le coup en modifiant le paramètre "coefficient de poids" du module à "1" (au lieu de 1000 comme indiqué dans la notice d'installation).

Après plusieurs essais avec des adresses de livraison différentes, les points relais ont chaque fois été indiqués y compris en Belgique (pays pour lequel ça n'avait jamais marché lors de mes précédents essais). J'ai fait faire aussi des tests ce soir à 2 amis dans des départements différents : aucun problème.

En regardant la notice d'installation du module (v1.7.8 et v1.7.9), on peut s'apercevoir que le fameux coefficient de poids est indiqué comme "grammes = 1kg" alors que dans le module v1.7.9, celui-ci est mentionné "grammes = 1g". Il y a donc eu un changement mais la notice n'a pas suivi.

En conclusion, on pourrait en déduire :

1/ Le calcul du port par rapport à vos tranches de poids est correct tant que vous n'êtes pas "sortis" de Prestashop.

2/ Au moment de choisir Mondial Relay comme transporteur, l'info du poids leur est automatiquement envoyée, en plus de l'adresse de livraison. Si le coefficient multiplicateur est de 1000 et que votre boutique est configurée en grammes, vous êtes alors "hors norme poids" et l'erreur retournée (pas très explicite) est "There is an error number : 97 Details : Clé de sécurité invalide"

Ayant fait tellement d'essais dans le passé, je suis incapable de me souvenir du contenu de mes paniers de test les quelques fois où le module a fonctionné normalement. Je suppose que ceux-ci ne devaient contenir que des articles très légers (j'en ai dans ma boutique) et malgré le coefficient multiplicateur de 1000, j'étais donc (aux yeux de M.R) en dessous des 20kg autorisés.

Naturellement, si l'unité de poids configurée dans votre boutique est le kg, votre coefficient du module Mondial Relay doit être laissé à "1000". Si par contre, comme beaucoup, vous utilisez le gramme, essayez de passer le coefficient à "1" et refaites des essais.

J'espère que ces explications vont vous permettre de sortir de votre galère d'affichage des points relais. Merci de faire part de vos retours d'expérience afin d'en faire profiter la communauté qui cherchera à l'avenir des informations dans ce forum.

Merci à Philippe H. de Mondial Relay pour avoir pris en considération mon appel au secours.

PS/ Pour le moment, je n'ai pas réessayé en "One page checkout". Je suis toujours en processus de commande classique. Permettez moi de ne plus toucher à rien et de penser à autre chose... :P

Patrick

Vincent Schoener

    PrestaShop Apprentice

  • Members
  • PipPip
  • 330 posts

Posted 15 February 2012 - 11:35 AM

Oula désolé je n'avais pas de retour sur ce post étant donné qu'un autre concernant les remonté d'erreur y est dédié :(

http://www.prestasho...220#entry751364

N'hésitez pas à y remonter tout problème remonté, j'y suis trés actif !

Cordialement
Vincent Schoener • Freelance -Lead Developer @Batiwiz - Ex core developer @Prestashop

Développeur agréé PrestaShop

aPlancon69

    PrestaShop Apprentice

  • Members
  • PipPip
  • 63 posts

Posted 13 March 2012 - 09:05 AM

Bonjour,

j'obtiens à chaque fois ce message:
There is an error number : 97
Details : Clé de sécurité invalide

alors que le format est bien défini pour le code postal et mes codes sont bons.
une idée ?

cdt,

samgruissan

    PrestaShop Apprentice

  • Members
  • PipPip
  • 31 posts

Posted 07 May 2012 - 12:57 AM

Bonjour à tous,
même problème, même message
Alors je me connecte sur le compte de ma cliente et dans l'adresse de ma cliente, dans le nom de la ville un accent ! Je l'enlève et au miracle la liste des point relay s'affiche.
Donc, la dernière version du module Mondial Relay n'accepte pas les accents !
Super, va falloir qu'à chaque client qui crée un compte, allez vite virer les accents avant qu'il ne parte chez le concurrent, faute d'avoir réeussi à commander sur nos sites !

A moins que quelqu'un ait la solution...

D'avance merci

Sandrine
Le monde de Salomé




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users