Jump to content

Recommended Posts

Hola a todos, es la primera vez que escribo en este foro, pasé de Prestashop 1.7.5.1 a Ps 1.7.6.0 por corregir errores de contenido mixto y los solucioné pero me causó un error de pago en la plataforma de Redsys, no había forma de recibir pagos y tuve que volver a la 1.7.5.1 mientras buscaba la solución.

Redsys me decía que su módulo estaba bien, y efectivamente no era cosa suya.

En el error de pago que aparecía en la pasarela de pago me di cuenta de que la cifra del total del pedido era una barbaridad.

nuestra web es https://www.alamedida.es donde actualmente está solucionado de la siguiente forma:

entrad en phpmyadmin, en vuestra base de datos buscad la tabla ??_currency ("??"=vuestro prefijo, en mi caso gqs) y tenéis que poner el código Iso de moneda 978 y la precisión ponerla de nuevo a Continuar

Hecho esto, yo lo he solucionado.
Espero que os pueda ayudar. Yo me estaba volviendo loco.

p.d. si no pertenece a esta sección por favor moverlo a la que toque, como digo es la primera vez que escribo en el foro, saludos.

Captura de pantalla 2019-07-29 a las 10.02.49.png

  • Thanks 1

Share this post


Link to post
Share on other sites

De nada, me alegro,

añado, que el código de numeración Iso no estaba tampoco en USD, en mi caso corregí también en la tabla esos valores para esta moneda
(usd nº 840)

Saludos.

Share this post


Link to post
Share on other sites

Hola @concienzudo, permíteme si eres tan amable hacerte un pa de preguntas.

Actualizastes a pelo con el actualizador de 1 click? Y funcionó todo?

A mi me da miedo la verdad, tengo la versión 1.7.4.3 y cuando la bajo e instalo en un server local para hacer la prueba (mediante XAMPP) se actualiza, pero revientan la mitad de las páginas con errores, y encima me sale en blanco el panel de admin..

 

Share this post


Link to post
Share on other sites

hola @RockStar360

A mi no me ha dado fallo al actualizar de la versión de prestashop 1.7.5.1 a la 1.7.6.0 con el módulo actualizado 1 click upgrade.
Primero creé un clon en otra carpeta del servidor e hice las pruebas de actualizar y corregir esas tablas, cuando vi que funcionaba bien, lo hice sobre la web en producción y tampoco me dio ningún fallo.
Lo hice por la mañana, para que si me daba fallo poder restaurar a la copia de seguridad automática que me crea cada día en mi hosting.

En mi versión de prestashop 1.7.5.1 tenía un error de contenido mixto que no conseguía corregir y que al actualizar se ha solucionado.

Share this post


Link to post
Share on other sites
4 minutes ago, concienzudo said:

hola @RockStar360

A mi no me ha dado fallo al actualizar de la versión de prestashop 1.7.5.1 a la 1.7.6.0 con el módulo actualizado 1 click upgrade.
Primero creé un clon en otra carpeta del servidor e hice las pruebas de actualizar y corregir esas tablas, cuando vi que funcionaba bien, lo hice sobre la web en producción y tampoco me dio ningún fallo.
Lo hice por la mañana, para que si me daba fallo poder restaurar a la copia de seguridad automática que me crea cada día en mi hosting.

En mi versión de prestashop 1.7.5.1 tenía un error de contenido mixto que no conseguía corregir y que al actualizar se ha solucionado.

Gracias por toda la info, se agradece mucho, pero perdona mi ignorancia en este sentido, crear una carpeta clon es copiar todo el htdocs? O la llamas de otra manera ? Esto no da problemas a la hora de acceder atraves de las urls? COnflictos, cosas asi? No sé muy bien como funciona el tema y la verdad te agradecería algo de luz..

Share this post


Link to post
Share on other sites

Buenas tardes,

Pero esto soluciona lo de que no crea pedido y envia la notificacion a la tienda?

Lo de error en el pago y los importes en otra cantidad ya lo solucioné!

Gracias

Share this post


Link to post
Share on other sites

@Jamones P. Castaño a mi me funciona, me llega el mail de Redsys. La notificación en la tienda, confieso que hace tiempo que no siempre llega, en alguna ocasión puntual no, y el estado del pedido se queda en awaiting cod validation pero como si que entra el mail de Redsys, compruebo el pago con mi banco y a mano cambio el estado a Pago aceptado

 

 

* * * Si te he ayudado me lo puedes agradecer pulsando en el corazón ❤ que aparece que aparece a la derecha de mi mensaje, marcándola como mejor respuesta o dándole un UP 

Gracias

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, concienzudo said:

@Jamones P. Castaño a mi me funciona, me llega el mail de Redsys. La notificación en la tienda, confieso que hace tiempo que no siempre llega, en alguna ocasión puntual no, y el estado del pedido se queda en awaiting cod validation pero como si que entra el mail de Redsys, compruebo el pago con mi banco y a mano cambio el estado a Pago aceptado

 

 

* * * Si te he ayudado me lo puedes agradecer pulsando en el corazón ❤ que aparece que aparece a la derecha de mi mensaje, marcándola como mejor respuesta o dándole un UP 

Gracias

 

Nada, lo hice y sigue igual. No crea el pedido ni sale notificacion ni nada.

Edited by Jamones P. Castaño (see edit history)

Share this post


Link to post
Share on other sites
hace 4 horas, Jamones P. Castaño dijo:

 

Nada, lo hice y sigue igual. No crea el pedido ni sale notificacion ni nada.

No he llegado a ver la foto que habías puesto, puedes subirla de nuevo? qué versión del módulo de Redsys utilizas? te dio algún error al actualizar a 1.7.6.0?  a lo mejor arrastras algún error de ahí, se me ocurre que desinstales y borres el módulo, y lo instales nuevamente. Copia antes la configuración, las claves, para poderlas pegar de nuevo en el módulo que instales. Que sea el módulo oficial de la web de redsys, no uses otra versión, el de ellos funciona, el que yo utilizo es descargado de su web.

 

* * * Si te he ayudado me lo puedes agradecer pulsando en el corazón ❤ que aparece que aparece a la derecha de mi mensaje, marcándola como mejor respuesta o dándole un UP 

Gracias

Share this post


Link to post
Share on other sites
9 hours ago, concienzudo said:

No he llegado a ver la foto que habías puesto, puedes subirla de nuevo? qué versión del módulo de Redsys utilizas? te dio algún error al actualizar a 1.7.6.0?  a lo mejor arrastras algún error de ahí, se me ocurre que desinstales y borres el módulo, y lo instales nuevamente. Copia antes la configuración, las claves, para poderlas pegar de nuevo en el módulo que instales. Que sea el módulo oficial de la web de redsys, no uses otra versión, el de ellos funciona, el que yo utilizo es descargado de su web.

 

* * * Si te he ayudado me lo puedes agradecer pulsando en el corazón ❤ que aparece que aparece a la derecha de mi mensaje, marcándola como mejor respuesta o dándole un UP 

Gracias

Buenos dias, la imagen ha sido un fallo mio de unas cosillas que no veía de las tablas.

El modulo me lo he descargado de su propia web. Ya hice lo de reinstalar todo y sigue igual. Ellos dicen que el error lo están estudiando que ahora mismo no tienen una solución.

LOS LOGS:

Jul 29 2019 18:50:38 -- m9XrV5IQQ1dtJZJakU5m -- La moneda no coincide. (0 : 978)
Jul 29 2019 18:50:38 -- m9XrV5IQQ1dtJZJakU5m -- El pedido con ID de carrito 116 es inválido.
Jul 31 2019 18:47:23 -- m81D0aDqlWV6wSr0es5o -- La moneda no coincide. (0 : 978)
Jul 31 2019 18:47:23 -- m81D0aDqlWV6wSr0es5o -- El pedido con ID de carrito 116 es inválido.

Share this post


Link to post
Share on other sites

Buenos días,

Has probado a eliminar ese carrito, a limpiar caché, y probar de nuevo a crear el pedido e intentar el pago?

Llegas a pagar o te da fallo? Veo la misma ID de carrito en los Logs...

Cuando se hacen varios intentos de pago sobre un mismo número de carrito suele dar error. No se si van por ahí los tiros, probablemente no, pero prueba.

Si no es, hasta ahí llego, a ver si alguien con más conocimientos sabe decirte.

 

* * * Si te he ayudado me lo puedes agradecer pulsando en el corazón ❤ que aparece que aparece a la derecha de mi mensaje, marcándola como mejor respuesta o dándole un UP 

Gracias

Share this post


Link to post
Share on other sites
2 hours ago, concienzudo said:

Buenos días,

Has probado a eliminar ese carrito, a limpiar caché, y probar de nuevo a crear el pedido e intentar el pago?

Llegas a pagar o te da fallo? Veo la misma ID de carrito en los Logs...

Cuando se hacen varios intentos de pago sobre un mismo número de carrito suele dar error. No se si van por ahí los tiros, probablemente no, pero prueba.

Si no es, hasta ahí llego, a ver si alguien con más conocimientos sabe decirte.

 

* * * Si te he ayudado me lo puedes agradecer pulsando en el corazón ❤ que aparece que aparece a la derecha de mi mensaje, marcándola como mejor respuesta o dándole un UP 

Gracias

Hecho,,, pero igual

He borrado carrito, limpiado cache y comprado desde un movil y sigue igual.

Jul 29 2019 18:50:38 -- m9XrV5IQQ1dtJZJakU5m -- La moneda no coincide. (0 : 978)
Jul 29 2019 18:50:38 -- m9XrV5IQQ1dtJZJakU5m -- El pedido con ID de carrito 116 es inválido.
Jul 31 2019 18:47:23 -- m81D0aDqlWV6wSr0es5o -- La moneda no coincide. (0 : 978)
Jul 31 2019 18:47:23 -- m81D0aDqlWV6wSr0es5o -- El pedido con ID de carrito 116 es inválido.
Aug 01 2019 10:38:16 -- NPuu3HyoVywU1L79aFOq -- La moneda no coincide. (0 : 978)
Aug 01 2019 10:38:16 -- NPuu3HyoVywU1L79aFOq -- El pedido con ID de carrito 117 es inválido.

Gracias por la ayuda

Share this post


Link to post
Share on other sites

Muchísimas gracias por la ayuda!!! me ha servido y está funcionando perfectamente en ps 1.7.6

Un saludo!

Share this post


Link to post
Share on other sites
En 29/7/2019 a las 10:26 AM, concienzudo dijo:

Hola a todos, es la primera vez que escribo en este foro, pasé de Prestashop 1.7.5.1 a Ps 1.7.6.0 por corregir errores de contenido mixto y los solucioné pero me causó un error de pago en la plataforma de Redsys, no había forma de recibir pagos y tuve que volver a la 1.7.5.1 mientras buscaba la solución.

Redsys me decía que su módulo estaba bien, y efectivamente no era cosa suya.

En el error de pago que aparecía en la pasarela de pago me di cuenta de que la cifra del total del pedido era una barbaridad.

nuestra web es https://www.alamedida.es donde actualmente está solucionado de la siguiente forma:

entrad en phpmyadmin, en vuestra base de datos buscad la tabla ??_currency ("??"=vuestro prefijo, en mi caso gqs) y tenéis que poner el código Iso de moneda 978 y la precisión ponerla de nuevo a Continuar

Hecho esto, yo lo he solucionado.
Espero que os pueda ayudar. Yo me estaba volviendo loco.

p.d. si no pertenece a esta sección por favor moverlo a la que toque, como digo es la primera vez que escribo en el foro, saludos.

Captura de pantalla 2019-07-29 a las 10.02.49.png

@Jamones P. Castaño Tienes la tabla gqs_currency como en la imagen?   tienes todos los valores igual?  el error que te da, parece que es de la moneda, comprueba los valores de nuevo a ver

Share this post


Link to post
Share on other sites
On 8/1/2019 at 2:13 PM, concienzudo said:

@Jamones P. Castaño Tienes la tabla gqs_currency como en la imagen?   tienes todos los valores igual?  el error que te da, parece que es de la moneda, comprueba los valores de nuevo a ver

La cosa va de mal en peor.

He ido a asegurar que todo estuviera como poneis arriba y PUM error 500

imagen.thumb.png.0a6a3390b7586dcaa64d8919a8144c1b.png

He restaurado copia de seguridad, archivos 1 por 1. Me he descargardo prestashop 1.7 para coger los originales, y nada, no paso de aqui.

imagen.thumb.png.c30abe3488fbcb4a637680c258a603b7.png

Share this post


Link to post
Share on other sites
Posted (edited)

@@Jamones P. Castaño Revisando la captura de pantalla de la tabla ps_currency veo que el nombre de la moneda, yo tengo Euros y tu tienes EUROS
No se si eso puede ser lo que te generaba el fallo o no, no estaría de más que lo pusieras como en la captura.
Del fallo que tienes, no se si lo habrás corregido, ahí no puedo ayudarte mucho, yo cuando me he encontrado con un error 500 ha sido después de toquetear algún módulo, mi solución normal es entrar al administrador de archivos y renombrar la carpeta del módulo para que deje de funcionar éste, y solucionado.
cuando con eso no lo arreglo suelo restaurar una copia antigua, mi servidor hace copias automáticas cada noche y eso me ha salvado más de una vez. 

 

* * * Si te he ayudado me lo puedes agradecer pulsando en el corazón ❤ que aparece que aparece a la derecha de mi mensaje, marcándola como mejor respuesta o dándole un UP 

Gracias

Edited by concienzudo
resaltar descripción de moneda (see edit history)

Share this post


Link to post
Share on other sites

Hola, tengo ese fallo pero en mi tabla de currency no me aparece el campo precision. ¿Qué puedo hacer?

 

Captura de pantalla 2019-10-26 a las 13.40.15.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More