Jump to content
Habakuk34

Problem - Category not found

Recommended Posts

Posted (edited)

Prestashop 1.6.1.24
Dodałem do bazy MySQL dodatkowe kategorie, uzupełniłem tabele wg istniejącego  już schematu w jakim dodane były wcześniej kategorie.
Dokładnie uzupełniłem następujące tabele ps_categoty, ps_category_group, ps_category_lang, ps_category_product, ps_category_shop.

Sytuacja wygląda nastepująco:
A adminie - (Katalog > Kategorie) wszystko działa i wyświetla się prawidłowo, nazwy, podkategorie itp

Problem pojawia się na sklepie
Nowo dodane kategorie wyświetlają się na liście kategorii, po kliknięciu wyświetla błąd: Category not found.
Kategoria dodana ręcznie do menu, po kliknięciu wyświetla błąd: Category not found.
Kategoria wyświetla się na karcie produktu, po kliknięciu wyświetla błąd: Category not found.
Produkty z"niewidocznych" kategorii wyświetlają się w innych modułach (Nowości, Polecane)

Czy spotkaliście się z taka sytuacją ?
Na co mogę zwrócić uwagę, co poprawić ? Może jeszcze gdzieś należy coś dopisać do innej tabeli w bazie ?

Problem występuje na każdym szablonie.

Edited by Habakuk34 (see edit history)

Share this post


Link to post
Share on other sites
Posted (edited)

A skąd do głowy ci przyszło zeby dodawać kategorie bezpośrednio do bazy? Takie błędy przy takich kombinacjach są nieuniknione. Presta ma to do siebie, że często pakuję w bazie  jedna rzecz w wielu miejscach, niejednokrotnie dziwnych. Dlatego ktoś wymyślił i zaimplementować coś takiego jak CSV żeby uniknąć takich wpadek jak właśnie u ciebie. 

Przy takich kombinacjach ciężko wyluskac co mogłeś zrobić nie tak... Nie podlega dyskusji to, że gdzieś popełniłes błąd, ale teraz żeby go wskazac trzeba by zaglądać w źródła i dokładnie krok po kroku to obadać. Raczej na pomoc w 'online' za bardzo bym nie liczył bo to mało realne 

Edited by design4VIP (see edit history)

Share this post


Link to post
Share on other sites

Kategorie i produktu importowałem poprzez API do bazy pomocniczej, i stąd przekopiowałem tylko to co się zaimportowało.
Na gołej preście API działa dobrze. Jednak potem jak instaluje na to szablon Bionic Dorado, jest milion problemów z szablonem.
Zainstalowałem gotowy sklep z szablonem, jest w paczce z szablonem, i tutaj API tym razem wywala mnóstwo błędów, dlatego zaciągłem produkty do bazy testowej skąd przeniosłem nowe kategorie, produkty, producentów.

Tak to w skrócie wygląda :(
nie orientujesz się czy może jeszcze gdzieś być zaszyta informacja o kategoriach ?

docelowo jestem skłonny odpłatnie zlecić to komuś...

 

Share this post


Link to post
Share on other sites

Jak pisałem, presta często wali wiele rzeczy w jakieś "mało domyślne" tabele. Jakoś nigdy tak do końca się nie skupialem gdzie dokładnie. Poza tym niektóre podweersje już sieją zamieszanie w bazie danych. Jak można by wnioskować stąd u ciebie na jednym sklepie działa, na drugim nie działa etc. 

Jeżeli na golej prescie działa to zaimportuj przez API, zrzuc do CSV i zaimportuj na drugim sklepie. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More