Jump to content
clement242

[RESOLU] Lenteur extreme produit avec déclinaison uniquement

Recommended Posts

Bonjour,

J'ai un problème de lenteur sur certaine page d'article comme celui ci par exemple:

https://www.242graphics.fr/kit-déco-100-perso/144-element-kit-déco-au-detail.html

Alors que certain on un temps de chargement "normal" comme celui ci

https://www.242graphics.fr/kit-déco-100-perso/139-kit-deco-perso-motocross.html

Si quelqu'un a une idée d'ou cela peu venir ? (Les modules sont a jours via le BO)

Edit: Ça semble venir du nombre de déclinaison sur le produit.

Ça fonctionner normalement il y a encore peu de temps, je m'en suis rendu compte par hasard enfaite.

Version de PrestaShop 1.6.0.11

BO/PERFORMANCE: 

Smarty: 

Recompiler les fichiers de templates s'ils ont été mis à jour

Cache: Oui

Vider le cache chaque fois qu'il y a une modification

Mode Debug:

Désactiver les modules non dev par presta : Non

Déactiver toutes les surcharges: Oui

CCC:

Tout est sur OUI

Chiffrement:

Algorithme: Utiliser Rijndael avec la bibliothèque mcrypt. (vous devez installer l'extension Mcrypt) (ca ne me dis rien d'avoir instaler Mcrypt parcontre...)

CACHE:

OUI

Systeme de cache: Systeme de fichier

Je vous remercie de votre aide.

Edited by clement242 (see edit history)

Share this post


Link to post
Share on other sites

Mon navigateur, c'est a dire ? Safari et Chrome même combat de mon coté :( 

Enfaite ça semble lier au nombre de déclinaison ! Un article avec beaucoup de déclinaison est très lent contrairement à un article sans.

Je continu de chercher mais si quelqu'un a la solution, merci.

Share this post


Link to post
Share on other sites

Toi: Docteur j'ai des douleurs dans le bas du dos!

Docteur: Prenez cette prescription!

Toi: Pourquoi ça? Je pense que ça vient d'un problème de tachycardie, je vais aller consulter une autre médecin

Docteur: Si ça vous fait plaisir

Share this post


Link to post
Share on other sites

Ok Doekia, mais j'ai loupé la prescription alors, du moins ton lien ne me parle absolument pas avec uniquement des morceaux de code, je n'ai pas tes connaissances, donc sans pédagogie/explication ça ne m'aide pas au contraire :( 

Et en terme de navigateur j'ai essayer avec le même résultat : Safari / Chrome / Firefox / Internet Explorer... D'ou ma réponse.

Si tu pouvais me faire une ordonnance + lisible :) 

Merci

Share this post


Link to post
Share on other sites

Le lien que donne Doekia montre les lignes à ajouter/supprimer/modifier dans certains fichiers de prestashop.
Pour chaque fichier, tu fais une sauvegarde et tu appliques les modifications indiquées.

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour,

le liens proposé par Doekia est très claire, je propose le même sur l'article que j'avais écrit à l'époque https://www.mediacom87.fr/prestashop-enregistrement-produit-impossible/ et comme je l'explique dans cet article, si vous ne comprennez pas ce qui est à faire il vous suffit de passer par un professionnel pour la mise en oeuvre de la correction.

Share this post


Link to post
Share on other sites

En relisant votre topic je me demande en même temps si la réponse n'est pas à côté de la plaque 🙂

En regardant votre page qui semble avoir un soucis j'ai surtout l'interrogation de connaitre la différence entre PitBike et MotoCross, car, sans connaissance, j'ai l'impression que se sont 2 choses totalement différentes mais pourtant on peut sélectionner les 2 options, ce qui ne me semble pas logique, mais je le rappelle, je n'y connais rien.

Cette fiche produit est complexe pour le client, entre les déclinaisons et les personnalisation il serait peut être bon de réfléchir à la simplifier au maximum et peut être de séparer chaque éléments dans une fiche produit unique.

Share this post


Link to post
Share on other sites

Mediacom87,

Mon problème n'est pas en BO effectivement (meme si j'ai deja rencontrer celui ci mais la c'était pas le sujet). Après c'est peu être lier je ne sais pas du tout, je vous fait confiance...

Prenons une autre fiche produit ou le problème est identique: (car depuis j'ai recréer 2 fiches produit 1 motocross et 1 pitbike)

https://www.242graphics.fr/kit-deco-perso-bucci-moto-242graphics/236-kit-deco-perso-bucci-moto-protrack-242graphics.htm

Share this post


Link to post
Share on other sites

Solution après un appel à OVH:

Dans mon fichier config/settings.inc.php remplacez l'adresse DB_SERVER qui était: 10.0.XXX.XX par directement l'adresse de mon SQLPRIVE : sqlprive-xxxxxxxx.privatesql

Je passe de 22 secondes à 2 secondes d'affichage

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More