Jump to content
kjou06

Je ne reçois pas les emails envoyés par le formulaire contact

Recommended Posts

Bonjour à tous,
Je suis en version 1.7.5 de Prestashop et je ne reçois pas les emails sur ma messagerie lorsqu'un client utilise le formulaire de contact. J'avais d'abord configuré avec la fonction mail (test positif), j'ai donc changé pour configurer avec l'envoi en SMTP (test toujours positif) mais je ne reçois toujours rien. En revanche, les messages sont bien enregistrés dans le back-office.
Une idée ?

Share this post


Link to post
Share on other sites

Merci Esh-Network mais bon… cela va de soi, qu'avant de poster ce topic, j'ai regardé les spams et vérifié l'adresse de contact 😊

Share this post


Link to post
Share on other sites

Il y a peut-être un autre moyen de m'aider qu'en donnant les identifiants de mon back-office, non ?

Share this post


Link to post
Share on other sites
Posted (edited)

Dans l'administration de Prestashop : Paramètres avancés > Emails

Envoyer un email de test à l'adresse que vous indique cette page : https://www.mail-tester.com/

Lisez le rapport pour comprendre votre problème

Si le service ne reçoit pas votre email de test, c’est que votre hébergeur a désactivé vos envois de mail ou que votre serveur est blacklisté probablement à cause d’une vague de spam réalisée depuis votre site. Par exemple si vous constatez beaucoup de faux comptes clients.

Si vous n’êtes pas encore en 1.7.5.2, faites la mise à jour pour être protéger contre la vague de spam, en complément installez un module de captcha pour accroître la robustesse de la protection anti-spam. Vérifiez également que vos modules sont protégés contre le spam si certains peuvent envoyer des mails.

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, je rencontre exactement le même problème que vous.
Tout les mails de confirmation de commandes sont bien envoyés (et reçus par l'admin et par le client) par contre les mails de SAV ne partent pas, les messages sont enregistrés dans SAV mais je ne reçoit rien, rien dans les spams non plus. On m'a conseillé de renseigner les paramètres IMAP également mais sans plus de succès.

J'ai fait le test d'envoi email dans "Paramètres avancés > emails" vers mail-tester.com, pas de soucis, score de 8.7/10. J'ai donc fait le même test en changeant l'adresse destinataire du formulaire de contact mais là mail-tester.com ne reçoit pas de mail.

J'ai testé également avec plusieurs destinataires différents avec des adresses mails aux domaines différents et aucun ne reçoit les mails de contact. J'ai également essayé en désactivant les modules que j'avais rajouté. 

Bref si quelqu'un a d'autres tests à faire faire, je suis preneur également.

Merci

Share this post


Link to post
Share on other sites
On 5/13/2019 at 6:06 PM, Janett said:

Dans l'administration de Prestashop : Paramètres avancés > Emails

Envoyer un email de test à l'adresse que vous indique cette page : https://www.mail-tester.com/

Lisez le rapport pour comprendre votre problème

Si le service ne reçoit pas votre email de test, c’est que votre hébergeur a désactivé vos envois de mail ou que votre serveur est blacklisté probablement à cause d’une vague de spam réalisée depuis votre site. Par exemple si vous constatez beaucoup de faux comptes clients.

Si vous n’êtes pas encore en 1.7.5.2, faites la mise à jour pour être protéger contre la vague de spam, en complément installez un module de captcha pour accroître la robustesse de la protection anti-spam. Vérifiez également que vos modules sont protégés contre le spam si certains peuvent envoyer des mails.

Janet Les tests e-mail sont OK et je reçois bien les messages par e-mail si un client envoie un message depuis sa page commande. En revanche, je ne reçois rien par le formulaire de contact

Share this post


Link to post
Share on other sites
15 minutes ago, inei said:

Bonjour, je rencontre exactement le même problème que vous.
Tout les mails de confirmation de commandes sont bien envoyés (et reçus par l'admin et par le client) par contre les mails de SAV ne partent pas, les messages sont enregistrés dans SAV mais je ne reçoit rien, rien dans les spams non plus. On m'a conseillé de renseigner les paramètres IMAP également mais sans plus de succès.

 

Si tu veux recevoir les messages SAV par email : dans l'admin de Pestashop > Paramètres de la boutique > contacts :
Modifier les contacts et désactiver "Enregistrer les messages"

Share this post


Link to post
Share on other sites
1 minute ago, Esh-Network said:

@kjou06 as-tu fait ce que j'ai poster?

Dans le module de contact ?

Je suis sur Prestashop 1.7.5.0 et je ne vois pas de module Formulaire de contact

Share this post


Link to post
Share on other sites
Just now, Esh-Network said:

À mon avis, Esh-Network, tu ne dois pas bien connaître la version 1.7.5. : la fonction rechercher les modules ne fonctionne pas (ça fait partie des merveilles de cette version!)

 

Share this post


Link to post
Share on other sites
1 minute ago, Esh-Network said:

à mon avis tu ne connais toi pas cette version.

Je connais la version comme ma poche pour preuve regarde en haut à gauche 1.7.5.2 j'ai fait 3 migration 1.6 vers 1.7 pour mes clients et j'installe que cette version pour mes futur clients.

25b3a1ad1da81b8bca0ba15bf207f50b.png
https://gyazo.com/25b3a1ad1da81b8bca0ba15bf207f50b

OK. Trouvé et modifié. Ça marche! Merci Esh-Network 😀

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More