Jump to content
renoproc

Presta 1.6+1&1 : page blanche backoffice après modification

Recommended Posts

Posted (edited)

Bonjour tout le monde,
nouveau sur Presta, j'ai tout d'abord fait une installation du dernier 1.6 sur mon serveur dédié pour mes tests avant de passer sur l'hébergement web de mon client sur 1&1 (webhosting simple). Tout fonctionne bien sur mon propre serveur (pas en local je précise), mais gros bug dans le prestashop que j'ai installé chez 1&1.

L'installation sur 1&1 est toute récente et le seul module supplémentaire activé était le Klikandpay v3.11 (seule solution de paiement proposée par la banque de mon client). Le bug n'est présent que sur le backoffice : dès que je valide une modification pour changer une catégorie, ou activer/désactiver un module, je me retrouve avec une page complètement blanche (le backoffice n'est plus visible).
Point positif toutefois: si je rappelle la page (sans renvoi du post) elle s'affiche bien comme il faut avec la modification que j'ai apporté.

J'ai essayé de voir les erreurs de plusieurs manières : tout d'abord en passant le _PS_MODE_DEV_ à true, puis également en rajoutant ini_set('display_errors', 'on'); dans le fichier config.inc.php, et aussi en créant un fichier php.ini spécifique à la racine de mon presta et en mettant
 

error_reporting = E_ALL | E_STRICT
log_errors = On
display_errors = On
error_log =/kunden/homepages/42/d782359592/htdocs/meslogs/php-error.log

Rien n'y fait: aucune erreur affichée, aucune erreur dans les logs -d'ailleurs j'ai salement l'impression que l'utilisation du php.ini ne fonctionne pas chez 1&1-, rien.

Les seuls info que j'ai pu obtenir c'est le warning ci-dessous pour le module que j'ai installé (qu'il soit désactivé ou non, installé ou non) qui s'affiche sur chaque page backoffice, visible grâce au _PS_MODE_DEV_ à true  :

Warning à la ligne 1829 du fichier /homepages/42/d782359592/htdocs/prestashop/classes/controller/AdminController.php
[2] Cannot modify header information - headers already sent by (output started at /homepages/42/d782359592/htdocs/prestashop/modules/klikandpay/fr.php:1)

Le fichier klikandpay/fr.php en question n'a rien de spécial, c'est la traduction du module :

<?php

global $_MODULE;
$_MODULE = array();
$_MODULE['<{klikandpay}prestashop>klikandpay_a70c10aaf94ae7588b6b227a536ffdd0'] = 'Klik and Pay';
// etc, etc...

Après plusieurs manip, il a fallut que je supprime complètement le module Klikandpay pour que cela revienne à la normal.
Ce qui est vraiment bizarre c'est que sur mon serveur (une debian stretch en prod) avec la même version PHP 5.6 je n'ai eu aucun problème...

Est-ce que vous auriez des pistes ? Des idées ou autre ?
Merci d'avance

Edited by renoproc
précision (see edit history)

Share this post


Link to post
Share on other sites

bonjour,

avant de supprimer le module tu peu simplement le désactiver en ajoutant X devant le nom du dossier dans le ftp

exemple : Xnomdumodule.

 

Ensuite il y a surement un problème de compatibilité as-tu essayer de réinitialiser le module ?

Vidé le cache manuellement aussi ?

Share this post


Link to post
Share on other sites

Oui, j'avais fait tout cela, sans changement.
Finalement j'ai trouvé une solution en installant le module depuis le github de l'auteur, ça a arrangé mon problème.
Ce qui n'empêche que cela signifie des problèmes de stabilité : l'installation qui m'a causé des soucis a été faite sur un webhosting 1&1, la même version de presta 1.6, avec les mêmes modules, sur une Debian (en serveur distant) n'a pas eu de problèmes.
D'ailleurs j'ai à nouveau un soucis sur un thème cette fois, pas les mêmes erreurs, mais c'est vraiment trop pénible.
A mon avis c'est l'hébergement 1&1 qui entraîne ces bugs a répétition, mais je ne sais pourquoi...

Share this post


Link to post
Share on other sites

Certainement, j’héberge mes propres clients je ne préconise en aucun cas les hébergements mutualisé.

Donc je ne peu t'aidé plus malheureusement.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More