Jump to content
ovt001

Erreur Kiala :[8] Undefined property: Kiala::$_html

Recommended Posts

Bonjour à tous,

un de nos client vient de me signaler qu'il n'arrive pas a finaliser un achat du au module Kiala.

Dans la BO, quand j'ouvre le module, je reçois l'erreur suivante:

Notice à la ligne 342 du fichier /home/cyberren/public_html/be-aroma.be/modules/kiala/kiala.php[

8] Undefined property: Kiala::$_html

Si je clique sur "enregistrer", idem même erreur

Est-ce que quelqu'un à déjà eu ce problème?

Merci

O.

 

Share this post


Link to post
Share on other sites

C'est une notice et concernant l'affichage donc rien à voir.

Si vous êtes une agence ca ne devrait pas être compliqué pour vous de trouver l'erreur.

  • Like 1

Share this post


Link to post
Share on other sites

non je ne suis pas une agence. et c'est quoi les "notices" dans la BO?

J'ai aussi remarqué que la commande a été tentée par un client qui venait de créer son compte aujourd'hui, mais quand j'ouvre la fiche client dans la BO, je reçoit une autre erreur:

Notice à la ligne 785 du fichier /home/cyberren/public_html/be-aroma.be/cache/smarty/compile/ad/ee/42/adee42c9172cfb2a161409d19b634da264b9a1fe.file.view.tpl.php
[8] Undefined index: order

Notice à la ligne 785 du fichier /home/cyberren/public_html/be-aroma.be/cache/smarty/compile/ad/ee/42/adee42c9172cfb2a161409d19b634da264b9a1fe.file.view.tpl.php
[8] Trying to get property of non-object

Edited by ovt001 (see edit history)

Share this post


Link to post
Share on other sites

il faut plutot regarder le fichier error.log chez votre hébergeur ou alors activer le mode debug et tenter de repasser la commande

Share this post


Link to post
Share on other sites

Est-il possible qu'il y ait une incompatibilité de version entre ma version de PS (1.6.0.9) et la version de PHP de mon hébergeur?

Puis-je sans risque faire un upgrade de prestashop vers la dernière version (1.7.5.2)? 

Merci

 

Share this post


Link to post
Share on other sites

ok alors là on part à la catastrophe.

Si vous devez mettre à jour et ne désirez pas perdre quoique ce soit, ne dépassez pas la 1.6.1.24 (compatible PHP 7.1/2)

Effectuez une sauvegarde complète avant (ftp et bdd)

Mais mettre à jour ne résoud pas le problème tant que vous n'avez pas consulté les logs d'erreurs.

Share this post


Link to post
Share on other sites

OK, merci, je vais demander à la personne qui s'occupe de mon hébergement de regarder cela.

 

Share this post


Link to post
Share on other sites

Quelle est votre version de PHP ? (Dans votre BO -> Paramètres avancés -> Informations)

Share this post


Link to post
Share on other sites

Informations sur votre serveur Linux #1 SMP Wed Mar 20 07:36:02 EDT 2019 x86_64

Version du logiciel serveur Apache

Version de PHP 5.6.40

Limite de mémoire 256M

Temps d'exécution maximal (max_execution_time) 60

Share this post


Link to post
Share on other sites

Votre version de PHP est trop récente pour Prestashop 1.6.0 par contre pour une 1.6.1 ce sera parfait.

Donc une mise à jour jusqu'à la dernière 1.6.1.24 réglerait pas mal de soucis, en revanche votre problème actuel vient d'un module ancien et non compatible avec PHP 5.6, il vous faudra également mettre à jour vos modules ainsi que votre thème.

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites

?

Les 1.4 et 1.5 fonctionnent en PHP 5.6

Share this post


Link to post
Share on other sites

ok, merci 

la question est donc de savoir si les modules "trop anciens" ont une mise à jours vers un PS 1.6.1.24

Et si après la mise à jour vers 1.6.1, certains modules ne sont pas "upgradable", je serai dans l’embarras... 

 

Share this post


Link to post
Share on other sites

Elles sont conçues pour PHP 5.2 jusqu'à 5.4, en 5.6 ça fonctionne majoritairement mais y a quand même des endroits où y a des problèmes qui ont été patchés dans les versions suivantes. Globalement ça fonctionne mais sur certaines fonctionnalités en 5.6, y aura des notices et des warnings mais pas de fatal.

Pour les modules qui n'ont pas de mise à jour disponible, un développeur pourra vous aidez à les patcher pour les faire fonctionner en 5.6

Edited by Janett (see edit history)

Share this post


Link to post
Share on other sites
il y a 54 minutes, Eolia a dit :

Mais mettre à jour ne résoud pas le problème tant que vous n'avez pas consulté les logs d'erreurs.

On tourne autour du pot tant que vous n'aurez pas consulté vos logs pour comprendre les erreurs.

Share this post


Link to post
Share on other sites
9 hours ago, Eolia said:

On tourne autour du pot tant que vous n'aurez pas consulté vos logs pour comprendre les erreurs.

oui, oui, j'ai demandé que l'on regarde les logs.  je n'ai pas accès moi même à cette partie de l'hébergement.

 

Share this post


Link to post
Share on other sites

Ah bon ???

ce n'est pas vraiment normal ça...

Share this post


Link to post
Share on other sites
9 hours ago, Eolia said:

Ah bon ???

ce n'est pas vraiment normal ça...

si, si, c'est un copain qui a mis le site en place pour moi. moi je ne fais que la gestion de l'e-commerce.... on peut pas tout faire 😉 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More