Jump to content
cmak

[?] Etapes pour mise à jour 1.4.8.2 -> 1.7.5.1

Recommended Posts

Posted (edited)

Bonjour,

Je dois mettre à jour un Prestashop 1.4.8.2 vers la dernière version 1.7.5.1
Il y aura peut être quelqu'un qui saura m'aider à trouver l'information...

Je voudrais utiliser les fonctions de mise à jour automatique pour migrer les données sans me casser la tête.
Il faudra peut être procèder par étapes, je cherche cette info
 

Par exemple :
14.8.2 -> 1.5.0.0 -> 1.6.2.2 -> 1.7.5.1


Il faut conserver
 - Le catalogue
- Les clients enregistrés
- Les commandes
- Les stats
- Le CMS

On peut oublier les modules de la version 1.4.8.2 et leurs données.

Merci d'avance  pour toute source d'information

Edited by cmak
correction txt (see edit history)

Share this post


Link to post
Share on other sites

Il n'y a aucun problème à faire le grand saut 1.4.8.2 =>  1.6.1.23 (faut le faire en mode avancé avec zip)

Je te déconseille 1.7

Et surtout les migrations 1.7 c'est la Bérézina

Share this post


Link to post
Share on other sites

Non tu télécharges le zip de la version 1.6.1.23, tu le dépose dans le répertoire /admin/autoupgrade/download/

Tu choisis le mode avancé et tu lui précise par archive locale, et tu entre le numéro de version à la main

Le reste fonctionne exactement pareil

 

IMPORTANT: BACKUP !! ftp+sql (que tu fais manuellement en dehors du module 1-click)

 

Par contre aux vues de tes questions, sache que ça demande quand même pas mal de doigté de faire une mise à jour, je ne sais pas si tu n'aurais pas plus intérêt a faire faire cela par quelqu'un de compétent.

 

Share this post


Link to post
Share on other sites

Ok merci pour cette précision.

Pour le reste: ça fait 7 ans que je n'ai pas mis les main dans ce CMS.
https://www.prestashop.com/forums/profile/379658-cmak/
J'ai trop peu de temps pour me lancer dans la création d'interfaces et une migration digne de ce nom.

Ta signature "aucun support pour des 1.7 tant qu'elle ne sera pas complète et stable (peut-être 2019, probablement jamais)" ne rassure pas
  Alors j’espérais que ce CMS soit un peu plus... Un peu mieux... ...fidélisant
  Si je dois me taper tout le reverse pour un interfaçage propre et net, autant changer de CMS... Les devs devraient y penser... Le freelance est son premier interprète.

 

Share this post


Link to post
Share on other sites
45 minutes ago, cmak said:

J'ai trop peu de temps pour me lancer dans la création d'interfaces et une migration digne de ce nom

j'ai pas compris

48 minutes ago, cmak said:

Si je dois me taper tout le reverse pour un interfaçage propre et net

en moins

Share this post


Link to post
Share on other sites

Je veux dire 'migration de données' d'un 1.4 vers un 1.7 : développer des scripts et/ou des tables formant des interfaces entre les deux structures de données
En bref, des interfaces.
Et pour ça, il faut étudier les structures des bases 1.4 et 1.7
En bref, se taper du reverse.
Si je devais (re)faire ce travail ce sera pour changer de CMS vers plus pérenne.
A moins que Prestashop ne le soit plus que votre signature le laisse entendre.
 

Share this post


Link to post
Share on other sites

Je déconseille 1.7, la 1.6 fonctionne très bien avec plus de fonctionnalités.

Je n'ai jamais réussi mes tests de migrations 1.6 => 1.7, mais je ne tente pas chaque version, j'ai des clients à m'occuper.

Et passer de 1.6 et inférieur à 1.7, c'est presque aussi différent que de passer du Français au Russe, il faut creuser dans les profondeurs de Symfoni où avant tu avais le code pile poil dans une classes propriétaire. Pour moi, 1.7 et freelance (donc mono-cerveau) ça n'est pas compatible avec expertise sur le produit. 42 sous-projet Symfoni à surveiller, connaître, suivre ...

Share this post


Link to post
Share on other sites

Bonjour,

Je viens de tenter de migrer de la 1.6.0.6 vers la 1.6.1.24 du 2 mai 2019, et cela ne fonctionne pas !
Une erreur sur un soit disant problème de droits sur le .htaccess alors qu'il a bien été modifié par contre plus grave, les colonnes manquante dans la base SQL sur les tables PREFIX_images par exemple.
Je me demandais aussi si il fallait passer par les versions intermédiaires mais quand je vois qu'entre les deux il a de 33 release, ... c'est pas possible !
Cette colonne est pourtant bien présente dans le CREATE TABLE du script d'installation 'db_structure.sql'.
Je vais continuer à gratter pour voir comment résoudre cela.

A ce propos, le 1-Click Upgrade est complètement perdu si le dossier admin a été renommé. Il faut forcer les chemins et ne pas tenir compte de certaines erreurs 😉

ps : évidement sur un miroir du site en local

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More