Jump to content

Recommended Posts

Salut,

je voudrais installer un module compatible 1.7 sur 1.6 ...

est-il possible si je modifie quelques codes ou non ?

merci

Share this post


Link to post
Share on other sites
il y a 3 minutes, doekia a dit :

Oui

merci, y'a t-il un tutoriel qui peu m'aider à le faire ...  ?

Share this post


Link to post
Share on other sites

Je sais que l'univers est vaste mais avec une question qui en couvre plus de 80%, qu'attends tu comme réponse ?

 

Share this post


Link to post
Share on other sites
il y a 3 minutes, doekia a dit :

Je sais que l'univers est vaste mais avec une question qui en couvre plus de 80%, qu'attends tu comme réponse ?

 

j'attends une réponse qui peut m'aider et pas un "oui" ou "non" avec une publicité au dissous !!!

  • Like 1

Share this post


Link to post
Share on other sites

Comment, par la plus grande volonté puis-je connaître l'étendue de ton incompétence?

Tu demandes, si c'est possible, je te réponds cela est possible. Je ne fais aucune publicité et, sois sûre que si tu me sollicitais sur le sujet, ma réponse serait encore plus vindicative.

Ta question est tellement n'importe quoi que je ne comprends pas ce que tu en attends::

tu demande si, il est possible d'être plus efficace qu'un développeur qui s'est cassé le fion a faire un truc sur une 1.7 pour l'adapter en 1.6. Désolé la seule réponse est "oui". Maintenant, est-ce judicieux, utile, efficace, n'est ni dans la question, et quand bien même, si c'était l'affaire d'un tuto à la con, penses-tu que l'auteur n'aurais pas, ni la présence d'esprit, ni l'intuition, ni la compétence pour appliquer ce tutos a son code? La meilleure probabilité, est que c'est pas si simple, et que ça demande un investissement particulier, non rentable en l'état.

Donc si ce besoin est vital pour toi, la réponse est oui si tu sais aligner du code... ou oui si tu sais trouver la ressource adaptée.

 

Share this post


Link to post
Share on other sites
Il y a 7 heures, doekia a dit :

Comment, par la plus grande volonté puis-je connaître l'étendue de ton incompétence?

j'ai un niveau assez bien ou pas mal au développement en générale mais je n'ai pas de grand chose concernant la structure de développement de prestashop ...

donc la réponse pour moi est "Non" car je ne peux pas le faire tout seul et sans aide ... merciiii de tt façon

  • Sad 1

Share this post


Link to post
Share on other sites

Je trouve la réponse de départ de @doekia parfaitement juste.

Votre question est

Il y a 10 heures, Sarrah a dit :

je voudrais installer un module compatible 1.7 sur 1.6 ...

est-il possible si je modifie quelques codes ou non ? 

Donc, comme lui je dirais que Oui

Mais avez vous au moins demandé au développeur du module si il n'a pas fait une adaptation 1.6 ou si il ne va pas la faire ?

Vous ne donnez pas d'information donc la réponse est générique et même si elle ne vous convient pas il est impossible de faire mieux avec aussi peut d'information.

Share this post


Link to post
Share on other sites

j'été sur prestashop 1.7 avec un module de Marketplace que j'ai acheté depuis plus que un an, maintenant j'ai acheté un thème qui fonctionne sur prestashop 1.6 et j'ai constaté que mon module marketplace ne fonctionne pas, j'ai contacté le developpeur de thème, il m'a dit que je dois contacter le développeur de module ... mais ce dernier me demande d'acheter un autre compatible 1.6 qui coute 199€ ...

laisse tomber, j'ai une autre question comment faire pour apprendre développer un module prestashop de a jusqu'à z ?

Share this post


Link to post
Share on other sites

????????

vous êtes depuis 1 an sur 1.6 et tout d'un coup rien que pour un template vous changez pour une version 1.6 de PrestaShop ?????

incompréhensible.

Sinon pour apprendre à développer un module de a à z pour PrestaShop il faut :

  • Avoir des bases html et css
  • De bonnes connaissances PHP
  • Connaître la POO
  • Pour la 1.7 des connaissance Synfony est un plus
  • Connaitre les framework de template Smarty et peut être Twig
  • Maitriser les requêtes MySQL
  • Savoir manier les algorythmes
  • être développeur

Share this post


Link to post
Share on other sites
Posted (edited)

Vraiment j'ai vu que le thème est impressionnant :)

    Avoir des bases html et css   oui
    De bonnes connaissances PHP   oui
    Connaître la POO   oui
    Pour la 1.7 des connaissance Synfony est un plus    non
    Connaitre les framework de template Smarty et peut être Twig    non
    Maitriser les requêtes MySQL   oui
    Savoir manier les algorythmes   débutant
 

Question :

j'ai pensé d'installer Prestashop 1.7 sur un autre Serveur pour les Vendeur, et j'y installe alors le modules multi-vendeur, et prestshop 1.6 reste pour les Clients.

l'idée est quand un client veut voir une catégorie ou un produit, prestashop 1.6 vas chercher les produit sur le serveur distant de prest 1.7...

que dois je faire pour réaliser ça  ?

merci

Edited by Sarrah

Share this post


Link to post
Share on other sites
22 hours ago, Sarrah said:

Question :

j'ai pensé d'installer Prestashop 1.7 sur un autre Serveur pour les Vendeur, et j'y installe alors le modules multi-vendeur, et prestshop 1.6 reste pour les Clients.

l'idée est quand un client veut voir une catégorie ou un produit, prestashop 1.6 vas chercher les produit sur le serveur distant de prest 1.7...

que dois je faire pour réaliser ça  ?

merci

Allez voir le vieux sage en haut de la montagne sacrée, il vous apprendra les arts ancestraux ésotériques qui vous permettront de venir à bout de la ligue du portnawakisme du démon Habé-Rassion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More