Jump to content
MrSoulPC915

Coup de gueule ICU / INTL Prestashop 1.7.5.1

Recommended Posts

Posted (edited)

Bonjour,

Je souhaite faire une fresh install de Prestashop dernier du nom pour tester deux trois trucs, mais il y a un truc qui m'agace vraiment, ce message d'erreur :

Quote

To get the latest internationalization data upgrade the ICU system package and the intl PHP extension.

Avoir un message d'erreur à l'installation, c'est pas bon, surtout sur un logiciel de prod dit "stable".

On est bien d'accord, prestashop 1.7 n'est pas une version alpha ? ni beta ? même pas release candidate ? J'imagine que non vu que c'est bien cette version que le site propose en page d'accueil et pas une vieille version 1.6 qui n'est pas recommandé.

D'autant que je respecte scrupuleusement le System requirements for PrestaShop 1.7

Pour se faire, j'ai tout tenté, l'installation de php 7.0.33, 7.1.27, 7.2.16, et même 7.3.3, avec mise à jour des modules php-intl.

  • php7.0-intl:amd64/stretch 7.0.33-5+0~20190309015553.9+stretch~1.gbp4c6517 uptodate
  • php7.1-intl:amd64/stretch 7.1.27-1+0~20190307202204.14+stretch~1.gbp7163d5 uptodate
  • php7.2-intl:amd64/stretch 7.2.16-1+0~20190307202415.17+stretch~1.gbpa7be82 uptodate
  • php7.3-intl:amd64/stretch 7.3.3-1+0~20190307202245.32+stretch~1.gbp32ebb2 uptodate

Ainsi que les binaires icu-devtools et php-symfony-polyfill-intl-icu.

On peut pas faire plus fresh !

Par contre, peut-importe la version de php /module, phpinfo me donne :

Quote

intl
Internationalization support    enabled
version     1.1.0
ICU version     57.1
ICU Data version     57.1
ICU TZData version     2016b
ICU Unicode version     8.0

Or, si on lis le post suivant, on s'aperçoit que c'est la version 63.1 d'ICU qui est nécessaire pour Prestashop 1.7.5.1.

 

C'est là qu'il faut m'expliquer, je suis sur Debian 9, pour avoir cette version 63.1, il faudrait que j'installe un paquet de Debian 10 (Buster) qui est je le rappel en status testing.
Bref, de faire quelque chose qui n'est ABSOLUMENT PAS RECOMMANDÉ.

Vous pourriez croire que je fais mon Debian Boy, mais c'est la même chose avec Ubuntu qui n'a se paquet qu'avec la version active development !

Ou alors c'est que Prestashop est en version Alpha (Beta, c'est plus une phase de test que pour l’expérimental) ???

 

Bref, quel est l'implication de ne pas avoir ICU à jour ? Et quel sera l'implication de ne pas l'avoir à jour avec les prochaines mises à jour de prestashop ?

 

PS : Désolé du ton, comme dit dans le titre, c'est principalement un coup de gueule.

Capture d’écran 2019-03-17 à 02.08.03.png

Edited by MrSoulPC915

Share this post


Link to post
Share on other sites

1/ En quelle couleur veux tu une note - un rappel - une information complémentaire? camaieu? fushia ? taupe? Ton voyant principal est au vert, on t'ajoute un complément d'information pourquoi t'énerver dessus?

2/ Le problème ne vient pas de prestashop mais bien de ce "super" bundle nommé symfony. c'est vers eux qu'il faut demander c'est quoi cette recommandation d'un ICU alpha dans un code prétendu stable.

3/ Les packagers debian on fait le travail nécessaire pour que l'ICU match ta version du module php d'internationalisation. Pourquoi te prendre la tête ?

3.bis/ Mais d'ailleurs, la seule version disponible officiellement sur le canal Debian9, c'est php7.0.33 -

4/ PrestaShop cherche toujours à sortir de son périmètre. S'occuper du système au lieu de se concentrer sur le commerce. C'est idiot, surtout quand il n'a aucun moyen de connaître  l'architecture sous-jacente. C'est régulièrement source de confusion ou même de problème quand il se veut meilleur que l'adminsys.

5/ Avoir un ICU pas a jour peut te causer quelques désagrément lorsque tu va devoir utiliser tel ou tel caractère kanji, ou sanscrit, farsil, kmer, ... donc l'unicode vient juste d'être mis à jour pour identifier a quelle majuscule correspond telle minuscule ... je simplifie mais de peu

6/ N'essaie même pas la php7.3, ou tu vas rencontrer de sérieux problème. Même 7.2 il reste encore des bugs non-fixés

http://php.net/manual/fr/intro.intl.php

Quote

L'extension d'Internationalization (qui est aussi appelée Intl) est une interface pour la bibliothèque » ICU, qui permet aux développeurs PHP d'effectuer des opérations compatibles avec les paramètres régionaux, incluant, mais non limité, au formattage, la translitération, la conversion d'encodage, les opérations de calendrier, collation » UCA-conforme conforme, localisation des limites du texte et l'utilisation des identificateurs de paramètres régionaux, des fuseaux horaires et des graphèmes

 

Share this post


Link to post
Share on other sites
Posted (edited)

En passant, selon moi  tu devrais plutôt utiliser la forge pour ce genre de problème.

Le public du forum est essentiellement composé d'utilisateurs lambdas d'un côté (des marchands qui administrent leurs boutiques eux-mêmes) et de développeurs, intégrateurs & webmasters chevronnés de l'autre. Les 2nds répondent aux questions des 1ers. Mais il y a rarement des conversations aussi pointues et techniques. Il suffit de voir le niveau des questions dans la section "Prestashop pour les développeurs" pour comprendre, c'est souvent du "Commen je changes la couleure du bouton ?".

Bon là forcément tu es tombé sur @doekia , c'est pas forcément un bon exemple. C'est un des 2 puits de science ici

Edited by BeComWeb
ortho
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More