Jump to content
renaud2263

Class Db not found après upgrade 1.7.5

Recommended Posts

Bonjour à tous,

Je viens de passer de 1.6.20 à 1.7.5. J'ai utilisé le module 1Click-upgrade (dernière version) et tout se déroulait normalement jusqu'à une interruption brutale :

Quote

Ajax / Server Error for action download] textStatus: "error " errorThrown:" " jqXHR: " "

J'ai tenté de rafraîchir, mais là gros plantage :

Quote
Fatal error</b>: Uncaught Error: Class 'Db' not found in /xxx/config/alias.php:48
  Stack trace:
  #0 /xxx/config/alias.php(53): pSQL('configuration')
  #1 /xxx/classes/Configuration.php(155): bqSQL('configuration')
  #2 /xxx/classes/Configuration.php(209): ConfigurationCore::loadConfiguration()
  #3 /xxx/classes/PrestaShopAutoload.php(171): ConfigurationCore::get('PS_DISABLE_OVER...')
  #4 /xxx/classes/PrestaShopAutoload.php(130): PrestaShopAutoload-&gt;generateIndex()
  #5 [internal function]: PrestaShopAutoload-&gt;load('Db')
  #6 /xxx/config/alias.php(48): spl_autoload_call('Db')
  #7 /xxx/config/alias.php(53): pSQL('configuration')
  #8 /xxx in <b>/xxx/config/alias.php</b> on line <b>48</b>

2 jours que je cherche, j'ai vérifié le thème (classic vu que mon ancien thème n'allait pas supporter le changement), les droits...rien y fait.

Je veux bien quelques conseils SVP. 

Share this post


Link to post
Share on other sites

Reprends ton backup complet (fichiers + bdd)

Ta mise à jour a planté au milieu, tu n'a donc plus qu'un demi-code

 

Share this post


Link to post
Share on other sites

FTP + phpmyadmin.

Je veux dire oui recharger ton système  à l'état juste avant que tu ne lance ta mise à jour

 

Share this post


Link to post
Share on other sites

Oui, je crois qu'il n'y a pas d'autres soluces. Maintenant il faut que je comprenne quelle erreur il y a eu...pour qu'elle ne se reproduise pas.

Est ce que Click1-Upgrade est le mieux ? J'ai vu ça aussi: 

Qu'en penses-tu ?

Share this post


Link to post
Share on other sites

Je fais 100% des migrations avec l'outil standard sans problème.

Mais pourquoi se lancer dans le brouillard de la 1.7 si tu as un 1.6 qui roule?

 

Share this post


Link to post
Share on other sites

Bonne question...parce que l'hébergeur (1and1) facture chaque mois une "maintenance php anciennes versions" et que la 1.6 ne tourne pas en 7.2...

Et ce n'est pas moi qui décide de l'hébergeur. Merci pour tes conseils, en tout cas.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More