Jump to content
Sarrah

ma page ne se charge pas correctement

Recommended Posts

Salut tout le monde,

ça commence aujourd'hui, bien fréquemment la page d’accueil ne se charge pas complétement accompagné de ce message:

Warning: chmod() has been disabled for security reasons in /home/specials/public_html/classes/Media.php on line 589

Warning: chmod() has been disabled for security reasons in /home/specials/public_html/classes/Media.php on line 752

Les deux lignes concernés sont les suivantes:

chmod($cache_filename, 0777);    ---> L589
chmod($compressed_js_path, 0777);   ----> L752

Bien-sure  j'ai passé en mode développeur..

aaa.thumb.png.cba160258eac63123deb1805aa4d18a9.png

quand j'ouvre le tableau de bord pour vider le cache, ce message apparaisse :

Warning à la ligne 79 du fichier /home/specials/public_html/tools/smarty/sysplugins/smarty_internal_write_file.php
[2] chmod() has been disabled for security reasons

bbbb.thumb.png.3a10e98d98171a852a266c306b5c016d.png

 

Share this post


Link to post
Share on other sites

A voir avec votre hébergeur pour qu'il réactive cette fonction ( chmod() ) sur votre espace.

  • Like 1

Share this post


Link to post
Share on other sites
Il y a 13 heures, Eolia a dit :

A voir avec votre hébergeur pour qu'il réactive cette fonction ( chmod() ) sur votre espace.

réellement, je j'ai pas un problème avec le message warning car il n'apparait que lorsque j'active le mode développeur, et je doute que le ce chmod à un effet sur le chargement de  la page d'acceuil, j'ai bien dit page d'acceuil, car le problème de chargement n'attaque que cette page, aussi lorsque la chargement de la page s'arrête et je rafraichi la page alors la ça passe bien et par fois reste bloqué

y'a t'il une manière pour savoir à quelle étape la chargement s’arrête exactement, peut être un module qui cause ce problème dans ce cas je l'enlève et c'est tout

voici le lien de mon site voir vous même, https://www.specialshop.tn/

essayer avec différentes navigateurs

merci

Edited by Sarrah (see edit history)

Share this post


Link to post
Share on other sites

Ben si vous n'avez pas de problème avec ces notices cachées alors tout va bien^^

Un Prestashop qui ne peux pas affecter des droits à un fichier ou répertoire qu'il crée est un problème, et un site ne devrait afficher aucun warning ni notice en mode debug si tout était vraiment ok.

Après, c'est vous qui voyez...

Concernant votre page d'accueil:

image.thumb.png.faf15c6489010a1e9faf8bea00f8d134.png

Share this post


Link to post
Share on other sites
il y a 16 minutes, Eolia a dit :

Ben si vous n'avez pas de problème avec ces notices cachées alors tout va bien^^

Un Prestashop qui ne peux pas affecter des droits à un fichier ou répertoire qu'il crée est un problème, et un site ne devrait afficher aucun warning ni notice en mode debug si tout était vraiment ok.

Après, c'est vous qui voyez...

Concernant votre page d'accueil:

image.thumb.png.faf15c6489010a1e9faf8bea00f8d134.png

je suis débutante dans ce domaine d'erreur et franchement je suis devenu Frustrée après avoir tt ces erreurs, est ce que je dois corriger tt ces problèmes un par un ?

dis moi svp que dois-je faire comme première étape maintenant ?

j'ai envie de pleurer 😢

Edited by Sarrah (see edit history)

Share this post


Link to post
Share on other sites

Ah bon ? La page n'est toujours pas secure (pas de cadenas https^^)

image.thumb.png.da85daf28fe3d3ee3e708942ce8ea389.png

Share this post


Link to post
Share on other sites

Ok je vais t'expliquer :)

la page est bien sécurisé regarde:

1.thumb.png.492f1379c537ff4b679190ff399f788f.png

mais les messages d'erreur qui apparaissent concernent le lien externe http://placehold.it/228x228  qui est intégré dans le fichier index inséré par l'admin de theme ajouté (lorsque une image ne se charge pas alors elle sera remplacer par une image vide, voir le lien) alors que ce dernier n'est pas sécurisé par HTTPS, c'est un lien simple. d’où ces messages ..

Bon pour le problème principale est que la page d’accueil ne se charge pas complétement, alors j'ai constater dans le console qu'une erreur parle d'une fichier JS manquante qui se trouve dans le dossier theme/cache alors la j'ai désactiver le cache de .js   et voila le problème est résolu ...

Je vais désactiver le HTTPS pour toi et vous allez voir que toutes les erreurs disparaisse :)

j'attends votre réponse pour le réactiver :)

à bientôt ❤️

SARRAH

Share this post


Link to post
Share on other sites
il y a 4 minutes, biliyat a dit :

ça commence aujourd'hui, bien fréquemment la page d’accueil ne se charge pas complétement accompagné de ce message:

?????

Share this post


Link to post
Share on other sites

Sous chrome un mixed-content désactive le ssl et la page n'est pas indexée par Google, FF mis à jour fait la même chose d'ailleurs à présent.

Share this post


Link to post
Share on other sites
il y a 29 minutes, Eolia a dit :

image.thumb.png.93de9002fb841392ec848c6008b87763.png

Moi je dis ça, je dis rien^^

Vraiment je comprends pas ce que ce passe, c'est quoi la version de ton navigateur, j'utilise 3 navigateur chrome ,opera et firefox ... J'ai envie vraiment de corriger ces problèmes :)

Share this post


Link to post
Share on other sites
Il y a 2 heures, Eolia a dit :

Dans ta console, regarde le level^^

oui c'est vrai, bon je ne sais pas d'où il viennent ces erreurs mais j'ai constaté que ces mêmes types d'erreurs existe chez beaucoup de grandes sites comme Cdiscount et Amazon :

amaz.thumb.png.2e6f327d8f153ca4fcb419000f8d33fc.png

cdis.thumb.png.8e501e641d3d232f722deb5860a7654b.png

donc je pense que si cela ne pose pas des problèmes fonctionnel je les ignores, qu'en dit tu ??

si'il y a une solution je vais le faire si non que dois-je faire :)

je te remercie pour votre effort ... ❤️ ❤️

 

Share this post


Link to post
Share on other sites
Il y a 4 heures, yama a dit :

Met à jour ton thème. Si j'en crois les commentaires du dev' de ton thème, ce probleme de mixcontent à été corrigé y'a plus d'un an.

Bonjour :), pour le problème de Mixed-Content je viens de trouver une solution, comme vous voyez la connexion est désormais sécurisée ...

sec.png.4d02aca025f524ab4cc8f88b9a220f3f.png

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More