Jump to content
Aurelou

Mise à jour 1.7.4.2 à 1.7.5 impossible

Recommended Posts

Bonjour,

Je souhaite mettre à jour Prestashop de la version 1.7.4.2 à la version 1.7.5 et je ne rencontre que des problèmes.

Je n'ai pas pu le faire avec le module One click car après avoir résolu un premier problème ("Error Unable to check md5 files") en changeant les permissions des fichiers et dossiers du module, la mise à jour des pages s'est bien passée bien mais j'avais toujours l'erreur suivante au moment de la mise à jour de la base de données : Ajax / Server Error for action unzip] textStatus: "error " errorThrown:"Gateway Timeout".

J'ai essayé de changer les permissions de toutes les façons possibles mais sans succès. Certaines personnes qui ont cette erreur préconisent de switcher sur le thème classique et que la mise à jour fonctionne, mais je ne peux pas le faire car en le faisant je perds toutes les configurations de mon thème (Manor par Leo theme).

J'ai donc décidé de faire la mise à jour manuellement. J'ai donc copié mes pages sans problème par ftp puis j'ai lancé le lien http://monsite/install/upgrade/upgrade.php pour mettre à jour la base de données, comme c'est préconisé dans la documentation Prestashop. Et là, encore une erreur : error 28 qui signifie que ma base de données est déjà à jour. Pourtant l'opération ne s'est jamais bien déroulée.

Côté admin, ils m'est indiqué que je suis bien en 1.7.5 mais mon site ne s'affiche pas du tout correctement, j'ai donc un gros doute que la base de données soit vraiment à jour.

Voici ce qui m'est affiché dans la table ps_configuration :
PS_VERSION_DB 1.7.5.0
PS_INSTALL_VERSION 1.7.4.2

Est-ce normal que ce ne soient pas les mêmes versions ?

J'ai essayé de modifier manuellement PS_VERSION_DB 1.7.5.0 en 1.7.4.2 pour que je puisse relancer le lien de mise à jour de la base de données sans qu'il ne m'affiche plus l'erreur 28. Et là j'ai un beau "Gateway Timeout The gateway did not receive a timely response from the upstream server or application". Ensuite si je retourne voir ma base, la valeur de PS_VERSION_DB se change de nouveau en 1.7.5.0, ce qui fait que si je relance le lien je me retrouve de nouveau avec l'erreur 28, et ainsi de suite.

Je précise que je suis en mutualisé chez OVH.

Merci pour votre aide, j'ai vraiment besoin de passer à la nouvelle version car la 1.7.4.2 ne me cause que des problèmes.

Edited by Aurelou (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

Je me réponds à moi-même si certains auraient le même problème. Je ne sais pas ce qui a causé le problème mais ma base de données était bien déjà mise à jour. Ca a du fonctionner lors d'unes des nombreuses tentatives... Il est normal que PS_VERSION_DB et PS_INSTALL_VERSION ne soient pas les mêmes car PS_INSTALL_VERSION correspond à la première version installée

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More