Jump to content
JFA

Après migration changement de statuts de commande intempestifs

Recommended Posts

Bonjour à toutes et tous,

Je viens de migrer de prestashop 1.2.5 vers prestashop 1.3.7. (aujourd'hui)
j'ai eu des soucis car l'installation bouclait (bloquait ?) sur Système et permission et ne s'est pas finie proprement. Puis lenteur sur le site...mais ce n'est pas cela qui m'amène (par contre c'est peut-être une cause...donc je le souligne)

J'étais en cours de modification d'un certains nombres de statuts de commande (vers un statut personnalisé); ce qu'il se passe c'est que lorsque je change le statut d'une commande "En cours de livraison" vers le nouveau statut (qui s'appelle votre avis nous intéresse), cela change le statut d'une commande antérieure. Non seulement cela la change, mais ça fait une rétroaction du statut "livré" vers "en cours de livraison" (en supprimant le statut "livré" de l'historique...)
J'ai essayé en changeant vers un statut par défaut de prestashop, ca fait la même chose.
Je remodifie le changement de la commande dont le statut a été changé, ca refait la même chose....étrange non ?
Ca parle à quelqu'un ?
je n'ai pas de doublon dans mes numéros de commande...

Peut-être faut-il que je fasse marche arrière et retourne vers ma 1.2.5....

En vous remerciant.

Share this post


Link to post
Share on other sites

Essaie d'importer la base de ton prestashop en local, pour voir si ce comportement est lié au serveur.

Share this post


Link to post
Share on other sites

merci pour le message.
Je viens (ce matin) de faire des modifs sur les fichier smarty.config.inc.php car le serveur ramait. (solution trouvée sur le forum). Le CPU du serveur est retombé à une activité normale...après cela effectivement je n'ai plus eu ce comportement
Donc sûrement lié à la saturation du serveur (hébergement gandi 2 coeurs).

donc a priori résolu.

Share this post


Link to post
Share on other sites

Très étrange vu que Smarty n'est pas utilisé pour ce genre d'opérations, mais tant que ca marche ....

Share this post


Link to post
Share on other sites

non non rien avoir avec smarty je pense. Simplement il y avait ce problème de CPU qui saturait parce que smarty compilait encore je crois...et peut-être que la saturation du serveur avait des effets de bord.

Share this post


Link to post
Share on other sites

Bonjour je rencontre un pb qui resemble à ça. Je viens de migrer de 1.2.5 en 1.3.7. Mes commandes en instance passent automatiquement en paiement accepté (alors que ça n'était pas le cas en 1.2.5)...
En clair, quand un produit est en stock, ça ne pose pas de pb, mais si le produit n'est pas en stock, ça doit rester en instance... Quelqu'un peut il m'aider ?

Share this post


Link to post
Share on other sites

Bonjour Fred A,

j'ai le même problème, je suis passé d'une version 1.2.5 à 1.4.7.3, avez vous trouvé la solution?

 

Ckarone

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More