Jump to content
kerlin

[RESOLU]PS 1.7.2.4 la ercherche fait n'importe quoi bis

Recommended Posts

Bonjour, je reposte pour mon problème de recherche parce que je n'arrive pas à trouver de solution.
Donc c'est une install de 1.7.2.4 dans laquelle j'ai fait l'import des tables d'un 1.6.1.4 pour récupérer produits, catégories, clients, commandes, etc.

Tout roule, sauf la recherche ! Par exemple si on tape "piles" dans la case, il affiche plein de produits où il est mis dans la description que l'appareil est fourni avec des piles, mais aucun produit piles.

J'ai vidé les tables search_index et search_word + tables pos_search_index et pos_search_word (de rockpos), vidé les caches (non activés d'ailleurs), refait je ne sais combien de fois une indexation des produits ...
Et absolument rien ne change !

Vous pouvez voir le site ici

 

Dans les réglages de la recherche, le poids du nom du produit est 10 et celui de la description 3 (de mémoire, je ne l'ai pas sous les yeux). Mais c'est quand même la description qui l'emporte et le nom n'est absolument pas pris en compte.

Auriez-vous des pistes à creuser ?

Merci d'avance !

 

Edited by kerlin (see edit history)

Share this post


Link to post
Share on other sites

Vérifie que tu n'as pas d'alias sur le mot pile

Vérifie que tu n'as pas un module tiers / override sur la recherche

Quels sont les weight du mot pile pour un produit donné? Compare un dont c'est le titre par rapport a un sans

 

Edited by doekia
erreur d'analyse (see edit history)
  • Haha 1

Share this post


Link to post
Share on other sites

Merci Doekia pour ton aide.

Pas d'alias ni sur piles ni sur quoi que ce soit.

Il y a Rockpos qui permet d'indexer aussi les produits et qui a ses propres tables search index et search word. Je les ai vidées à plusieurs reprises. Si j'indexe les produits avec ce module seulement, la recherche ne trouve carrément rien. J'ai donc vidé ses tables et reconstruit l'index avec l'outil de PS. La recherche affiche des résultats ... mais toujours erronés.

 

Weight du mot "piles" pour le produit "Piles auditives audilo" : 24 (dans la bdd)

Weight du mot "piles" pour le produit "Traitement acouphène Marpac ..." : 1 ( le mot est dans la description : ne fonctionne pas sur piles)

 

C'est comme si le poids était pris à l'envers !

 

Dans les réglages de PS :

- poids du nom : 10

- poids de la ref : 10 (comme sur le site d'origine)

- poids de la descr : 1

- poids de la cat : 3

- poids de la marque : 3

- poids des mots-clé: 8 (auparavant 6, j'ai essayé en modifiant vers le haut)

- poids des attributs : 2

- poids des caractéristiques : 2

Comme c'est le site de développement avant remplacement du site de prod qui est sur un PS 1.6, et où la recherche fonctionne bien, j'ai même testé en important le contenu des tables search_index et search_word du prod sur le dev, et les tables de recherches du module rockpos
Vidage de cache, vidage du cache du navigateur ...
Résultats de la recherche inchangés !

Ce matin, on a installé un module payant de recherche, la popup ajax affiche des résultats meilleurs, mais quand on clique sur OK, la liste des résultats est toujours foireuse.

C'est vraiment très curieux !

Share this post


Link to post
Share on other sites

Si le module de recherche tier (rockpos) ne trouve rien c'est que ce module est visiblement malade.

Le désinstaller, le supprimer et s'assurer qu'il n'a pas laissé d'override.

Recommencer alors le test

Share this post


Link to post
Share on other sites

Merci Doekia pour ton aide.

 

La désinstallation du module n'a hélas rien résolu.

Finalement, en allant jusqu'au bout du résultat de recherche j'ai vu que les piles étaient en dernier. En triant par Nom, A à Z, elles sortaient correctement. Vérification sur une des autres copies de travail où le résultat était correct :le lien sur le mot Pertinence de la case tri affichait les résultats en mode croissant sur l'un, et décroissant sur l'autre. J'ai donc changé ce réglage dans PS ... et les résultats sont ok !

Bref des heures pour pas grand chose !

Enfin ! je peux mettre en résolu !

 

Merci en tout cas de t'être penché sur on souci ! Bonne journée à toi.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More