Jump to content
Hect02

Impossible d'activer le SSL

Recommended Posts

Bonjour,

Prestashop 1.6.0.9

Nous avons un certificat SSL sur notre hébergement, et nous souhaitons activer le SSL sur Prestashop, mais lorsque je clique sur : Activer le SSL : cliquez ici pour utiliser le protocole HTTPS avant d'activer le mode SSL.  (dans l'onglet Préférences), j'obtiens cette page et je n'ai pas la possibilité d'activer le SSL :

<?php
/*
* 2007-2014 PrestaShop
*
* NOTICE OF LICENSE
*
* This source file is subject to the Open Software License (OSL 3.0)
* that is bundled with this package in the file LICENSE.txt.
* It is also available through the world-wide-web at this URL:
* http://opensource.org/licenses/osl-3.0.php
* If you did not receive a copy of the license and are unable to
* obtain it through the world-wide-web, please send an email
* to license@prestashop.com so we can send you a copy immediately.
*
* DISCLAIMER
*
* Do not edit or add to this file if you wish to upgrade PrestaShop to newer
* versions in the future. If you wish to customize PrestaShop for your
* needs please refer to http://www.prestashop.com for more information.
*
*  @author PrestaShop SA <contact@prestashop.com>
*  @copyright  2007-2014 PrestaShop SA
*  @license    http://opensource.org/licenses/osl-3.0.php  Open Software License (OSL 3.0)
*  International Registered Trademark & Property of PrestaShop SA
*/

$timer_start = microtime(true);
if (!defined('_PS_ADMIN_DIR_'))
	define('_PS_ADMIN_DIR_', getcwd());

if (!defined('PS_ADMIN_DIR'))
	define('PS_ADMIN_DIR', _PS_ADMIN_DIR_);

require(_PS_ADMIN_DIR_.'/../config/config.inc.php');
require(_PS_ADMIN_DIR_.'/functions.php');

//small test to clear cache after upgrade
if (Configuration::get('PS_UPGRADE_CLEAR_CACHE'))
{
	header('Cache-Control: max-age=0, must-revalidate');
	header('Expires: Mon, 06 Jun 1985 06:06:00 GMT+1');
	Configuration::updateValue('PS_UPGRADE_CLEAR_CACHE', 0);
}

// For retrocompatibility with "tab" parameter
if (!isset($_GET['controller']) && isset($_GET['tab']))
	$_GET['controller'] = strtolower($_GET['tab']);
if (!isset($_POST['controller']) && isset($_POST['tab']))
	$_POST['controller'] = strtolower($_POST['tab']);
if (!isset($_REQUEST['controller']) && isset($_REQUEST['tab']))
	$_REQUEST['controller'] = strtolower($_REQUEST['tab']);

// Prepare and trigger admin dispatcher
Dispatcher::getInstance()->dispatch();

 

Avez vous une idée du problème ?

 

Merci pour votre aide,

 

Cordialement

 

 

 

 

Share this post


Link to post
Share on other sites

Si tu obtiens cela en "page" c'est que le PHP ne s'exécute pas sur le port 443, il y a donc un gros problème sur ton hébergement

  • Like 1

Share this post


Link to post
Share on other sites
39 minutes ago, Jawher Integ/Dev web said:

BD 'prefixe'_configuration => PS_SSL_ENABLED => value =1

 

Si il n'a pas de PHP sur son vhost en 443, en quoi changer le drapeau de la bdd va résoudre son problème ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More