Jump to content

Page Blanche Malgré Display error on


Recommended Posts

Bonjour,

Mon site a fonctionné pendant plus d'un mois, et depuis une semaine:

Il est hebergé sur un serveur dedié Kimsufi sous Plesk 9.3
Je suis confronté a une erreur qui va bientôt me rendre fous...

Page Blanche en boutique et en admin

J'ai donc modifié le fichier
/config/config.inc.php

@ini_set('display_errors', 'on')


J'ai ajouté un fichier .htaccess pour forcer l'affichage des erreurs

php_flag display_errors on
php_flag display_startup_errors on

Verif sur un fichier php info

display_errors On
display_startup_errors On

J'ai egalement activé le mode debug de SMARTY

$smarty->force_compile = true;
$smarty->debugging = true;
$smarty->debug_tpl = _PS_ALL_THEMES_DIR_ . 'debug.tpl';


Voila si vous avez une solution pour que je puisse au moins connaitre l'erreur qui m'amène a cette page blanche

Merci pour vos idées

Share this post


Link to post
Share on other sites

Merci pour ta réponse,


Mais le serveur fonctionne bien, tout est OK, d'autre sites fonctionnent, de plus le php info fonctionne et des "echo" aussi.

J'ai downloadé le site pour le tester sur Wamp pour isoler le probléme, et sur wamp rien a faire non plus....

JE ne sais plus quoi faire, peut on a partir d'une nouvelle installation recupérer toute la config de l'instal tombé ?

MErci

Share this post


Link to post
Share on other sites

Non rien a faire... JE m'y recolle demain
Pour l'instant cela semble venir de SMARTY, j'avance de ligne en ligne avec des echo("coucou")....

Peux tu me donner plus d'info sur ta config serveur, perso le probléme coincide avec une mise a jour de plesk sous linux, mais bon j'ai 15 sites sur le serveur et seul celui sous prestashop pose probléme


Bonne soirée

Share this post


Link to post
Share on other sites

Bon la j'aurais vraiment besoin d'aide...

A voir ca beug dans le fichier Smarty

Dans mon fichier config.inc.php l'execution du code s'arrête aprés:

require_once(_PS_SMARTY_DIR_.'Smarty.class.php');


Dans

Smarty.class.php

A voir la condition

if(time()>1289398898) tpl();


n'est pas ok et je vais donc directement a

function tpl(){
exit();
}
/* vim: set expandtab: */

Merci de m'indiquer des infos par rapport à la premiére condition

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More