Jump to content

Pb installation sur serveur dédié


Recommended Posts

Bonjour à tous,

Je viens d'installer PrestaShop sur un serveur dédié Dedibox pour un site de vente de tableaux pour ma femme (pour l'instant je n'ai rien modifié c'est le site de base)
Le contenu de la boutique se trouve sous www/TineShop/
Quand j'accède au site http://www.tablotine.fr , j'ai plusieurs problèmes :

- Les css ne sont pas reconnues
- Lors du clic sur un lien, l'url pointée est http://www.tablotine.fr/TineShop/LeLienClique et non http://www.tablotine.fr/LeLienClique

Pour infos, j'ai bien déclaré le nom du site dans le fichiers hosts et j'ai créé un Virtualhost comme ceci:

    DocumentRoot /var/www/TineShop/
    ServerName www.tablotine.fr



Si quelqu'un avait une idée, ca m'aiderait bien...
Merci d'avance !!

Share this post


Link to post
Share on other sites

Bonsoir,

Dèja un petit problème dans le virtualhost.
Pas de http, car tu travailles avec des noms de domaine et non des url

Pour l'exemple donné, et c'est vraiment le plus simple que l'on puisse faire :


  DocumentRoot /var/www/TineShop
  ServerName tablotine.fr



Cordialement,

Dominique

Share this post


Link to post
Share on other sites

Bonsoir Dominique,

Merci pour ta réponse rapide !

Alors, j'ai modifie le VirtualHost comme tu me l'as indiqué :


  DocumentRoot /var/www/TineShop
  ServerName tablotine.fr



Et du coup, comme ceci en tapant l'url www.tablotine.fr au lieu de tomber sur la racine du site, comme indiqué par le DocumentRoot (/var/www/TineShop) je tombe directement sur /var/www

Ensuite, en cliquant sur TineShop je tombe bien sur le site qui fonctionne correctement, c'est déjà mieux mais je ne comprends pas pourquoi ca ne pointe pas directement sur /var/www/TineShop ?

Share this post


Link to post
Share on other sites

Bonjour,

Merci Frederic, j'ai essayé en modifiant le VirtualHost comme tu me l'as indiqué et du coup, je tombe sur une 404. Ce qui est normal non ? car on lui indique par /www/TineShop/ que le dossier www est à la racine, ce qui n'est pas le cas...

@gt40: le tuto a l'air bien complet, je vais me pencher dessus, merci !

Share this post


Link to post
Share on other sites

Pour ma pat j'ai apprit sur la toile pour ls tutos et celui d'Olanges est complet et traite bien des configuration d'une machine dédié sous linux (debian,ubuntu)

Tournant sous OpenBsd cela reste similaire dans la gestion des virtual Vhost.
Mais si l'ont suit bien chaque étape préstashop tourne sans souci particulier

Share this post


Link to post
Share on other sites

J'ai regardé un peu le tuto d'Olanges et ce qui m'embête c'est l'utilisation de BIND9 alors que dans tous les autres exemples de conf de virtualHosts que j'ai pu voir, on n'en parle pas.
Du coup, je me pose la question: Est-il possible de configurer des VirtualHosts simplement avec Apache et sans BIND9 ?

Merci

Share this post


Link to post
Share on other sites
J'ai regardé un peu le tuto d'Olanges et ce qui m'embête c'est l'utilisation de BIND9 alors que dans tous les autres exemples de conf de virtualHosts que j'ai pu voir, on n'en parle pas.
Du coup, je me pose la question: Est-il possible de configurer des VirtualHosts simplement avec Apache et sans BIND9 ?

Merci



Bind 9 est utilisé si ont veut géré soit même le serveur DNS chose qui est possible sur une grande infrastructure,pour ma part je laisse les DNS sur le registar du domaine mes machine sont installé avec apache2,nginx pour un cache et qui soulage apache et serveur sql sur une autre machine pas la peine d'instalé le serveur dns Bind9,

Cette partie là suffit amplement
http://olange.developpez.com/articles/debian/installation-serveur-dedie/?page=page_3#LIII-D

et pour le serveur ftp pro-ftpd est suffisant

instalation du client FTP

apt-get install proftpd
ln -s /etc/proftpd/proftpd.conf /etc/proftpd.conf

édité le fichier de configuration
nano /etc/proftpd.conf

ajouté ses quelques lignes à la fin

DefaultRoot ~
IdentLookups off
ServerIdent on "FTP Server ready."

Redemaré le daemon

/etc/init.d/proftpd restart

Share this post


Link to post
Share on other sites

Oui,

Pas besoin de bind pour faire des virtualhost.

La config que j'ai donné doit fonctionner, il faut juste s'assurer que les chemins donnés en exemple soit les réels chemins.

Apparament tu as du faire un export d'un site se trouvant déjà dans un dossier "TineShop" que tu as recopié dans un dossier du même nom.

Si tu as fait la config que je t'ai donné, il n'est pas possible que cela fonctionne avec http://www.tablotine.fr/TineShop/ sauf si ton site se trouve sur /var/www/TineShop/TineShop/
En plus, prestashop n'aurait pas du fonctionner correctement sauf si tu as déclaré dans la config que la racine du site se trouve sous /TineShop
Je reviens donc à ma premiere idée, tu as du copier le dossier TineShop de ton site sous /var/www/TineShop, ce qui te donne une adresse réel de /var/www/TineShop/TineShop/

Share this post


Link to post
Share on other sites
Oui,

Pas besoin de bind pour faire des virtualhost.

La config que j'ai donné doit fonctionner, il faut juste s'assurer que les chemins donnés en exemple soit les réels chemins.

Apparament tu as du faire un export d'un site se trouvant déjà dans un dossier "TineShop" que tu as recopié dans un dossier du même nom.

Si tu as fait la config que je t'ai donné, il n'est pas possible que cela fonctionne avec http://www.tablotine.fr/TineShop/ sauf si ton site se trouve sur /var/www/TineShop/TineShop/
En plus, prestashop n'aurait pas du fonctionner correctement sauf si tu as déclaré dans la config que la racine du site se trouve sous /TineShop
Je reviens donc à ma premiere idée, tu as du copier le dossier TineShop de ton site sous /var/www/TineShop, ce qui te donne une adresse réel de /var/www/TineShop/TineShop/


Alors, pour t'expliquer ce que j'ai fait depuis le début :

- J'ai dézippé Prestashop dans un dossier TineShop sur mon pc en local.
- J'ai uploadé ce même dossier TineShop sous /var/www sur mon serveur, ce qui fait que l'index.php se trouve sous /var/www/TineShop/
- J'ai lancé l'install de Prestashop en précisant bien dans la config pour le répertoire PS: /TineShop/

Du coup, pour essayer de comprendre ce qui se passe, j'ai créé un second répertoire nommé /var/www/test/ dans lequel juste un index.html
Dans mes VirtualHosts, j'ai déclaré en premier le virtualhost test (en partant du principe que si celui de tablotine n'est pas reconnu, par défaut Apache se rabat sur le premier virtualhost de la liste


   DocumentRoot /var/www/test
       ServerName www.test.fr



   ServerName tablotine.fr
   DocumentRoot /var/www/TineShop/



Ensuite, en tapant soit l'ip de mon site, soit http://www.tablotine.fr, ca me renvoie automatiquement vers ma page test.

Et lorsque je modifie le virtualhost de test comme ceci :


   DocumentRoot /var/www/
       ServerName www.test.fr



Quand je tape l'ip de mon serveur suivi de /TineShop (http://mon-ip/TineShop/) , j'arrive bien sur la page d'accueil et idem pour http://www.tablotine.fr/TineShop/

Donc en gros, tout ce que je comprends c'est que mon virtualhost pour tablotine n'est pas bien déclaré puisque quoi qu'il arrive, Apache redirige systématiquement vers le premier virtualhost déclaré lorsque j'essaye d'accéder à tablotine...

Mais par contre, je suis toujours autant perdu sur une éventuelle solution !!
J'espère que j'ai pas été trop fouilli dans mes explications !!

Merci de votre aide !

Share this post


Link to post
Share on other sites

Salut domi77185 !

Je viens de vérifier et en effet, dans mon httpd.conf, j'ai un ServerName de déclaré, ce n'est pas tablotine.fr mais le nom de ma dedibox:


ServerName sd-maDedibox



Du coup, faut que je le supprime ?

Share this post


Link to post
Share on other sites

Non tu ne le supprimes pas, si tu n'as que ce site sur ce serveur, tu peux le remplacer par "ServerName tablotine.fr".

Vérifie car tu doit avoir un DocumentRoot quelque part, tu le remplaces par "DocumentRoot /var/www/"

Tu redémarres le deamon Apache.
Tu mets une page index.html de test dans le dossier www et tu tests.

Si par la suite tu veux faire des sous domaines, tu les feras par virtualhost.

si ça fonctionne pas, c'est qu'il y a autre chose, dans ce cas envoi moi ton httpd.conf par mail, je regarderai de plus près.

Normalement avec ce que tu avais cela aurai du fonctionner sans faire cette modif.
Le mieux serai d'envoyer ton httpd.conf ou de le mettre sur ce forum avant toute modif.

A+
Dominique

PS : Penses à faire une sauvegarde de ton httpd.conf avant de le modifier ;-)

Share this post


Link to post
Share on other sites

Je vois que tu as mis un fichier qui affiche "coucou" sur ton site, il est dans quel dossier de ton serveur ?
Tu as quoi dans ton VirtualHost ?

On va déjà vérifier avant de modifier quoi que ce soit.

Share this post


Link to post
Share on other sites

Salut Domi,

Désolé pour le temps de réponse, je n'ai pas me repencher sur mon pb pendant quelques jours...

Alors, pour répondre à tes questions :

Voici le contenu de mon httpd.conf:

 ServerName sd-xxxxx 


ou xxxxx = le nom de ma dedibox

le fichier qui contient "coucou" se trouve sous

/var/www/test/index.html



et mes virtualhosts donnent ca :



   DocumentRoot /var/www/test
       ServerName www.test.fr

       Options FollowSymLinks
       AllowOverride None





   ServerAdmin contact@tablotine.fr
   ServerName tablotine.fr

   DocumentRoot /var/www/TineShop

       Options FollowSymLinks
       AllowOverride None


       Options Indexes FollowSymLinks MultiViews
       AllowOverride None
       Order allow,deny
       allow from all


   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

       AllowOverride None
       Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
       Order allow,deny
       Allow from all


   ErrorLog /var/log/apache2/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /var/log/apache2/access.log combined

   Alias /doc/ "/usr/share/doc/"

       Options Indexes MultiViews FollowSymLinks
       AllowOverride None
       Order deny,allow
       Deny from all
       Allow from 127.0.0.0/255.0.0.0 ::1/128






Sachant que la boutique prestashop avec l'index.php se trouve sous

/var/www/TineShop




Et autrement, mais je ne sais pas si c'est important ou pas, voici le contenu du fichier hosts :

127.0.0.1    localhost.localdomain    localhost
88.191.xxx.xxx    sd-xxxxx.dedibox.fr           tablotine.fr
88.191.xxx.xxx tablotine.fr

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts



Merci d'avance !

Share this post


Link to post
Share on other sites

Bonsoir,

Ton fichier me parait correct, si ce n'est que la partie supérieur est inutile car je ne pense pas que tu geres le domaine test.fr

Donc supprimer :

ServerAdmin admin@tubewatcher.tv

   DocumentRoot /var/www/test
       ServerName www.test.fr

       Options FollowSymLinks
       AllowOverride None




Dans ton hosts tu as un tablotine.fr de trop, donc supprimer (après dedibox.fr) ou supprimer la 3e ligne.

je suppose pour l'exemple que tes deux adresses IP 88.191.xxx.xxx sont les mêmes.

127.0.0.1    localhost.localdomain    localhost
88.191.xxx.xxx    sd-xxxxx.dedibox.fr     
88.191.xxx.xxx tablotine.fr



Attention à la casse, tu as écrit TineShop avec un T et un S majuscule, cela doit donc être écrit partout pareil. Aussi bien dans ta config que dans le nom du répertoire.

Il reste également à vérifier que tu possédes bien une ligne

NameVirtualHost *


ou

NameVirtualHost *:80



quelque part dans ta config.
Soit (en général vers la fin) dans ton httpd.conf, soit dans un fichier de conf appelé par "Include" dans ton fichier de conf principal.

Tu peux également rajouter dans ton virtualhost un ServerAlias de ton domaine.
Ce qui donne pour les premières ligne du virtualhost :

   ServerAdmin contact@tablotine.fr
   ServerName tablotine.fr
   ServerAlias www.tablotine.fr



Voila, un redemarrage de deamon apache et cela devrait maintenant fonctionner.

Share this post


Link to post
Share on other sites

Alors, pour le host, ok je viens de supprimer la troisième ligne.
J'ai également rajouté le ServerAlias dans mon VirtualHost pour tablotine

Ensuite:

J'ai rajouté dans mon httpd.conf :

NameVirtualHost *:80



Alors que dans apache2.conf j'ai

# Include the virtual host configurations:
NameVirtualHost IP:port
Include /etc/apache2/sites-enabled/



Est-ce que ca va être en conflit ?

Et enfin, j'ai laissé le VirtualHost test (effectivement je ne gère pas le domaine test.fr ;-)) :



   DocumentRoot /var/www/test
       ServerName www.test.fr

       Options FollowSymLinks
       AllowOverride None





Car comme expliqué plus haut, je l'avais rajouté en premier dans mes VirtualHosts en partant du principe que si celui de tablotine n’était pas reconnu, par défaut Apache se rabattrait sur le premier virtualhost de la liste. Cela donc juste pour être sur qu'il y avait bien un problème avec sur VirtualHost de tablotine.

Et j'ai bien fait attention à la casse TineShop est écrit comme ceci dans le nom du répertoire et dans le reste de la config.

Après ces quelques modifs, j'ai redémarré apache mais toujours le même pb, www.tablotine.fr pointe encore sur le VirtualHost test et renvoie sur le répertoire /var/www/test et la page "Coucou"

Hum, désolé mais je suis un peu perdu la... merci de ton aide en tout cas !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More