Jump to content

Recommended Posts

Bonjour
j'essaie de mettre mon site en ligne et je n'y arrive pas.
J'ai l'impression que le probleme vient de ma base de données. A l'interieur de celle ci il y a plusieurs prefixes differents est-ce normal?
J'arrive sur une page blanche avec ecrit index of/ fichierssite> c'est comme ça que s'appelle le fichier que j'ai placé dans public.html
et si je clic sur fichierssite il m'affiche "Link to database cannot be established."
Avez-vous un peu de temps pour m'aider à solutionner mon problème, merci. Lise

Share this post


Link to post
Share on other sites

bonsoir,

Le fichier setting.inc.php présent dans le dossier config est t-il bien configurer ?

Les préfixes sont t-il parce que plusieurs scripts sont installer ou non ?

Cordialement

Frédéric.L

Share this post


Link to post
Share on other sites

le fichier setting.inc.php est surement mal configuré je ne sais pas si je dois mettre /public.html/fichierssite/ ou juste /fichierssite/ pour l'instant ça ne marche ni avec l'un ni avec l'autre. Et pour le préfixe vu qu'il y en a 3 ou 4 dans la même table je ne sais pas quoi mettre pour le reste le nom de la table est bon le nom d'utilisateur de la table est bon et le mot de passe est bon. C'est le mot de passe que j'ai mis en creant la base de donnée sur mon serveur c'est ça?

Share this post


Link to post
Share on other sites

Je les ai déjà parcouru...quand je faisais mon site en local. Malheureusement je n'ai pas trouvé de réponse à mon problème. Merci quand même d'avoir répondu. Lise

Share this post


Link to post
Share on other sites

Pourquoi ne transférez-vous pas directement l'ensemble de vos fichiers directement à la racine de /public_html.

Ensuite dans votre settings.inc.php, indiquez :

define('__PS_BASE_URI__', '/');



Pour la base de données, il vous faudra spécifier les accès de votre hébergeur :

define('_DB_NAME_', '????');
define('_DB_SERVER_', '????');
define('_DB_USER_', '????');
define('_DB_PREFIX_', '????');
define('_DB_PASSWD_', '????');



Et n'oubliez pas bien sur si cela n'est pas fait, d'envoyer le contenu de votre base de données vers l'hébergeur aussi à l'aide de PhpMyAdmin par exemple.

Bonne chance

Share this post


Link to post
Share on other sites

j'ai fait ça ;-) j'ai bien ma base de donnée dans phpMyAdmin crée à partir de mon cpanel....je crois que j'ai du supprimer des dossiers qui étaient dans le dossier public.html et que je n'aurais pas du. Je viens d'envoyer un message à mon hébergeur pour savoir s'il peut les remettre.
Pour le nom du serveur dans phpmyadmin il est écrit localhost alors j'ai mis localhost....je ne sais plus trop quoi faire en fait...

Share this post


Link to post
Share on other sites

Tout dépend de votre hébergeur et de sa gestion des accès bases.
Dans 90% des cas, c'est localhost pour signifier que la base de données est sur le même serveur que le site (et limité les accès % de l'extérieur).

Mais il arrive, comme pour les contrats ovh mutualisés, que l'accès se fasse par des domaines locaux dans l'infrastructure.
Et donc ce n'est pas localhost, mais l'accès au nom du serveur en lui même. Il faut voir tout ça dans votre contrat.

Share this post


Link to post
Share on other sites

ça y est en effet il ne faut pas vider le contenu du dossier public.html pour y mettre ses dossiers ;-) mais bien tout laisser en place. Je ne sais pas où noter RESOLU. Merci à tous pour votre aide. Lise

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More