Jump to content

Recommended Posts

Hi All,

I'm currently using php 7.2 and 7.1

And I'm trying to access to the back office
Without successfull
How can I solve that? I tested with php 5.6 it's working..
I'm getting this error:

image.thumb.png.142b2311c00666186118241dfd199e10.png

Edited by sinzen (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

seule la dernière version 1.6 peut être considérée comme compatible avec PHP7

Share this post


Link to post
Share on other sites

merci pour ta réaction..

Donc la version 1.6.1.18 de prestashop est compatible avec php 7.2 et 7.1 en l'occurence?

pourtant j'ai tenter un install qui a échouer..
Peut-être qu'il me manque des parametre dans php.ini?

Une idée..

 

Edit: je viens de tester avec php en version 7.1 et l'install est passé. Mais la connexion au BO bloque.. sur la capture que j'ai poster plus haut..

 

voici mon error log de apache: 

[Mon Mar 26 12:30:02.711740 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00428: Parent: child process 22304 exited with status 255 -- Restarting.
[Mon Mar 26 12:30:02.964540 2018] [ssl:warn] [pid 13440:tid 580] AH01909: localhost:446:0 server certificate does NOT include an ID which matches the server name
[Mon Mar 26 12:30:02.977606 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00455: Apache/2.4.29 (Win64) OpenSSL/1.0.2n PHP/7.1.15 configured -- resuming normal operations
[Mon Mar 26 12:30:02.977606 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00456: Apache Lounge VC14 Server built: Nov  5 2017 12:14:48
[Mon Mar 26 12:30:02.977606 2018] [core:notice] [pid 13440:tid 580] AH00094: Command line: 'C:\\Bitnami\\wampstack-7.1.15-0\\apache2\\bin\\httpd.exe -d C:/Bitnami/wampstack-7.1.15-0/apache2 -f C:\\Bitnami\\wampstack-7.1.15-0\\apache2\\conf\\httpd.conf'
[Mon Mar 26 12:30:02.978607 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00418: Parent: Created child process 10340
[Mon Mar 26 12:30:03.279486 2018] [ssl:warn] [pid 10340:tid 512] AH01909: localhost:446:0 server certificate does NOT include an ID which matches the server name
[Mon Mar 26 12:30:03.406312 2018] [ssl:warn] [pid 10340:tid 512] AH01909: localhost:446:0 server certificate does NOT include an ID which matches the server name
[Mon Mar 26 12:30:03.419347 2018] [mpm_winnt:notice] [pid 10340:tid 512] AH00354: Child: Starting 64 worker threads.
[Mon Mar 26 12:30:08.191887 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00428: Parent: child process 10340 exited with status 255 -- Restarting.
[Mon Mar 26 12:30:08.458684 2018] [ssl:warn] [pid 13440:tid 580] AH01909: localhost:446:0 server certificate does NOT include an ID which matches the server name
[Mon Mar 26 12:30:08.472751 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00455: Apache/2.4.29 (Win64) OpenSSL/1.0.2n PHP/7.1.15 configured -- resuming normal operations
[Mon Mar 26 12:30:08.472751 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00456: Apache Lounge VC14 Server built: Nov  5 2017 12:14:48
[Mon Mar 26 12:30:08.472751 2018] [core:notice] [pid 13440:tid 580] AH00094: Command line: 'C:\\Bitnami\\wampstack-7.1.15-0\\apache2\\bin\\httpd.exe -d C:/Bitnami/wampstack-7.1.15-0/apache2 -f C:\\Bitnami\\wampstack-7.1.15-0\\apache2\\conf\\httpd.conf'
[Mon Mar 26 12:30:08.473243 2018] [mpm_winnt:notice] [pid 13440:tid 580] AH00418: Parent: Created child process 26400
[Mon Mar 26 12:30:08.796129 2018] [ssl:warn] [pid 26400:tid 544] AH01909: localhost:446:0 server certificate does NOT include an ID which matches the server name
[Mon Mar 26 12:30:08.938531 2018] [ssl:warn] [pid 26400:tid 544] AH01909: localhost:446:0 server certificate does NOT include an ID which matches the server name
[Mon Mar 26 12:30:08.950570 2018] [mpm_winnt:notice] [pid 26400:tid 544] AH00354: Child: Starting 64 worker threads.

 

Edited by sinzen
EDIT (see edit history)

Share this post


Link to post
Share on other sites

Bon j'ai essayé de mettre le debug à True

Mais rien ne se passe 

Tester sur une fresh install de prestashop 1.6.1.18

Je dois activité des extensions dans php.ini? Eg; xdebug

 

Merci pour vos réactions.

Edited by sinzen (see edit history)

Share this post


Link to post
Share on other sites

Je confirme php 7.2 -> passe pas

php 7.1 -> ca passe

 

cote backoffice et front office

 

donc c'est résolu.. :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More