Jump to content
Powerbook1800

PaymentModule::validateOrder - Secure key does not match Après changement de mot de passe client.

Recommended Posts

Bonjour à tous,

Après de long travaux de préparation, répétition et autres... j'ai pu réaliser ma migration d'un vénérable PS1.4.2.8 vers un PS1.7.2.4.
Cette migration a pu être mise en production, mais suite à la découverte d'un gros problème par un client qq heures après la mise en production il a fallu faire un rollback malheureusement.

Coté PS1.7.2.4 (version stable disponible quand j'ai commencé mes travaux de préparation): Aucune modification du code de la boutique ou autre.
La seule "modification" c'est la valeur du "cookie_key" dans parameters.php avec la valeur "historique" de la boutique en PS1.4 pour que les clients puissent se connecter à la boutique après migration vers le PS 1.7 (et cela fonctionne bien).

Après investigation, le problème est commun à tous types d'utilisateurs : "anciens" c.a.d migré ou pour un utilisateur "nouveau" c.a.d créé après la migration.

Cas d'usage : un client existant ou nouveau (il vient de s'enregistrer), rempli un panier, sélectionne le transporteur, le moyen de paiement (Paypal / Payplug, virement ou chèque), valide le paiement -> Tout est parfait, mails envoyés au client, BO à jour -> c'est nickel.

Un client existant avant la migration, ou le nouveau qui vient de créer son compte, change son mot de passe, soit par sa fiche personnelle ou par "mot de passe oublié".
Tout se passe bien, après changement du mot de passe, la connexion sur la boutique est OK.

De nouveau ce client rempli un panier, transporteur, choix d'un moyen de paiement, au retour du paiement et la c'est le drame :
- Coté client : "Erreur fatale"
- BO : pas de commande
- Le paiement a bien été réalisé (paypal, payplug), c'est donc bien au retour vers la boutique que ça explose.
- logs : "PaymentModule::validateOrder - Secure key does not match"

C'est la même "punition" qqsoit le moyen de paiement (chèque, virement, PayPal ou Payplug).

Le problème apparait donc quand le client change son mot de passe.

Je lance un S.O.S si qqun à une idée, piste ou la solution...

Merci d'avance pour votre aide.

Edited by Powerbook1800 (see edit history)

Share this post


Link to post
Share on other sites

Bonjour, 

 

Avez-vous pu solutionner le problème je suis EXACTEMENT dans le même cas et ca me fait perdre des commandes, je suis totalement perdu pour regler le soucis :((( 

 

Merci à vousssss

Share this post


Link to post
Share on other sites

Bonjour à tous,

J'ai l'impression d'avoir le même genre de problème ici : certains clients n'arrivent pas à valider leur commande, et j'ai plein d'erreurs comme ça dans les logs :

PaymentModule::validateOrder - Secure key does not match

Share this post


Link to post
Share on other sites

Bonjour Matthieu,

J'avais "posté" ce problème après une migration PS1.4 -> 1.7 avec un module de migration 'MigrationPro" pour ne pas les citer (j'ai passé 2 mois a débugger leur module, cela n'a jamais fonctionné à 100%...).

Le problème était lié à mes clients "avant migration", si le client changeait son mot de passe, j'avais cette erreur.

La "solution" de la société qui éditait le module avait été de supprimé la vérification dans le module "ValidateOrder", pffffff c'est c'est du correctif !

Comme j'ai eu bien d'autres problèmes avec la migration de ma boutique, j'ai stoppé mon projet de migrer vers une 1.7. et avant de perdre totalement la tête et stopper les heures et les heures de tentatives de migrations infructueuses, j'ai eu recours à un spécialiste Prestashop... qui c'est occupé de la migration avec succès (vers le dernier PS1.6). Je peux passer l'échéance de l’arrêt de PHP5.x sereinement maintenant. Bref cela ne va pas t'aider tout ça...

Tu as fait des modifications de la config ou autre sur ta boutique site dernièrement ?

Bon courage.

++

Powerbook.

 

Share this post


Link to post
Share on other sites

On a fait une mise à jour (1.7.x -> 1.7.3) il y a quelques semaines. Mais a priori, les erreurs n'ont commencé que cette semaine... En même temps, on rentre dans la période où le nombre de commandes augmente énormément, et du coup forcément, statistiquement, les erreurs ont plus de chances de se produire...

Share this post


Link to post
Share on other sites

Bonjour,

je rencontre de plus en plus souvent ce problème ces derniers jours sur une boutique en 1.7.5.2, aussi bien avec Paypal que par paiement CB via Monetico.

Aucune mise à jour récente n'a été faite de PS ou de modules. Paypal et Monetico sont bien à jour.

J'ai vu sur GitHub que quelqu'un avait un problème d'ajout de produit au panier par le module Mailchimp qui créait un problème de correspondance d'ID panier/commande, mais je n'ai pas ce module chez moi.

 

Est-ce que quelqu'un rencontre encore ce problème ?

A-t-il été résolu, et de quelle manière ?

 

Merci pour votre aide.

Share this post


Link to post
Share on other sites
Posted (edited)

Bonjour,

Problème identifié pour ma part.
En regardant les tables _cart et _customer, j'ai vu que la valeur du champ secure_key était différente entre les deux.

J'ai en fait 2 comptes client identiques (hormis l'ID). La récupération et le contrôle de la valeur secure_key se faisait sur l'id client le plus récent, alors que celle du panier était sur le plus ancien.

Reste à comprendre comment je peux avoir deux comptes client créés en même temps...

Edited by Howie (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More