Jump to content
mawrex

Ostrzeżenia przy wejściu w BO

Recommended Posts

Witam wszystkich.

 

Dzisiaj miałem problem z błędęm 500 w FO. Przy debugowaniu wyskoczył błąd w lini modułu gdzie nagle się pojawił podwójnie parametr id_shop. Usunąłem jeden i wszytko działa. Natomiast gdy wchodzę w moduły w BO wyświetlają mi się nastepujące ostrzeżenia: 

 

/public_html/modules/payu/payu.php
[2] Declaration of payu::validateOrder($id_cart, $id_order_state, $amountPaid, $paymentMethod = 'Unknown', $message = NULL, $extraVars = Array, $currency_special = NULL, $dont_touch_amount = false) should be compatible with PaymentModuleCore::validateOrder($id_cart, $id_order_state, $amount_paid, $payment_method = 'Unknown', $message = NULL, $extra_vars = Array, $currency_special = NULL, $dont_touch_amount = false, $secure_key = false, Shop $shop = NULL)

Warning w linii 278 w pliku public_html/modules/payu/payu.php
[2] Declaration of payu::displayConfirmation() should be compatible with ModuleCore::displayConfirmation($string)

Unknow error w linii 112 w plikupublic_html/tools/pear/PEAR.php
[8192] Methods with the same name as their class will not be constructors in a future version of PHP; PEAR has a deprecated constructor

Unknow error w linii 829 w pliku public_html/tools/pear/PEAR.php
[8192] Methods with the same name as their class will not be constructors in a future version of PHP; PEAR_Error has a deprecated constructor

 

 

 

Modułu PayU nie używam, zostawić to w spokoju? Co z pear.php i ostrzeżeniem o nowej wersji PHP(na serwerze używam 7.0)?

Share this post


Link to post
Share on other sites

Potrzebuje bardzo pomocy, nie wiem co się ze sklepem stało. Przy drugim etapie realizacji zamówienia gdy kliknie się realizuj zamówienie wyskakuje mi to:

 

Fatal error: Uncaught Error: Access to undeclared static property: Validate::$data in /public_html/classes/ObjectModel.php:1067 Stack trace: #0 //public_html/controllers/front/AuthController.php(409): ObjectModelCore->validateController() #1 public_html/controllers/front/AuthController.php(242): AuthControllerCore->processSubmitAccount() #2

public_html/classes/controller/Controller.php(171): AuthControllerCore->postProcess() #3 public_html/classes/Dispatcher.php(373): ControllerCore->run() #4 /public_html/index.php(28): DispatcherCore->dispatch() #5 {main} thrown in

public_html/classes/ObjectModel.php on line 1067

 

 

EDIT:

 

Niestety gdy chce włączyć iframes  wysypuje się i wyskakuje: Serwer  nie może teraz obsłużyć tego żądania.

HTTP ERROR 500
Edited by mawrex (see edit history)

Share this post


Link to post
Share on other sites

O matko admin zmienił PHP na 7.0 bez powiadomienia. Przepraszam za stratę czasu czytającego.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More