Jump to content
djixas

Unable to update settings

Recommended Posts

Hi,

 

Using 1.7.2.0

PHP 7, mem limit 1gb, max execution time 500 sec

 

When using configurable products with ~300-900 attributes, 9 out of 10 times Pretashop fails to save settings and gives error: "Unable to update settings"

 

The problem does not appear when saving the first time (right after generating configurations), the error only appears when editing items afterwards, like changing description, etc. it just gives this error, apache log gives no errors, debug doesn't help too. Sometimes if you hit save like 10 times in a row, it saves. Sometimes it doesn't.

 

Any ideas? I have seen same bug reported in other threads since 1.7.x but no solution. 

 

Can't even submit a bug on presta site as it is broken: http://imgur.com/a/WjimV

Edited by djixas (see edit history)

Share this post


Link to post
Share on other sites

The same issue here - using Prestashop 1.7.2.2    Simply cannot edit a product listing.

 

It's strange that a very basic like this goes unnoticed.  Too many problems with prestashop 1.7    Not ready for use.

Share this post


Link to post
Share on other sites

We had the same issue, as we installed the prestashop over the cpanel auto installer.

When we uploaded it via ftp, and installed it the error was gone. Some extra php extensions were requested.

I guess the auto installer from cpanel makes some error.

Hope this helps, as it took us a full day to figure this out.

  • Haha 1

Share this post


Link to post
Share on other sites

We are getting the same error but on only SOME products on our 1.7 version. I made a copy of a product that did not give the error and I made a copy of a product that did. I did not get an error updating the first but I did with the second. I've tried to compare the two products but for the life of me I cannot see the difference. I've turned on debugging and I cannot see the difference. It cannot be theme related because some do and some don't update on our cpanel install.

I've checked the logs and the error does NOT appear to be being added to the logs. (The updated one does).

 

Share this post


Link to post
Share on other sites

OK looks like our issue was due to a faulty import from 1.6. It was new products that saved and the imported ones didn't.
We imported using csv for products.

Edited by msjs08
More info (see edit history)

Share this post


Link to post
Share on other sites

Just found another possible reason for products created in 1.7.
Cutting and pasting from the description of another product, to a new product causes it not to save in Edge on win10 but fine in Firefox on linux. If you cut and paste just the line in Edge, it saves. (Need to get user to install other browser)

Is there an issue with line endings?

Share this post


Link to post
Share on other sites

Same problem... clean 1.7.2.4 installation, all basic (theme n plungins). I've create products with 2 color combinations, and when I try to edit those products the sometimes it says "unable to update settings"... sometimes only! It's frustrating...

Share this post


Link to post
Share on other sites

Related the "unable to update settings" problem that does not let you save product modifications.

Go to Catalog -> Products -> Open a product -> go to Description tab -> Make sure 6000 character limit is not exceeded -> Click Save ==> https://i.imgur.com/jOTEhzR.png

After that i was able to save any modification made to that product!

Selection_150.png

  • Like 1

Share this post


Link to post
Share on other sites

Hello, we have same issues on 2 scenarios:

1- migrated My site to a new VPS and will not allow to update any products. This is a V1.7.2

2- created a new install for testing on a sub folder to discard possible VPS migration errors but same problems with updating products. This is a V1.7.5

2 different installs, 2 different versions, same problem... does anybody have a clue of what could be happening?

Have seen this issue on many forums w/o a solution, does any one know how to fix the problem please?

 

Thanks

juan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More