Jump to content
LCInformatique

Module Google Analytics ou insertion manuel du code suivi dans header.tpl ne fonctionne pas

Recommended Posts

Bonjour,

 

Version 1.4.2.5 de Prestashop

Google Analytics module v1.5

 

J'ai voulu ajouter le suivi google analytics en utilisant d'abord le module Google Analytics par Prestashop. Je l'ai téléchargé et copié/collé dans le dossier modules.

En me rendant dans le BO, il n'y se trouve null part.

 

J'ai donc voulu insérer le code suivi manuellement dans le header.tpl de mon thème entre les balises <head> comme suit

	<head>

<script>
{literal}
  
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-XXXXXX-X', 'auto');
  ga('send', 'pageview');

{/literal}
</script>

......

</head

Mais aucune réaction dans les pages, même après avoir vidé le cache du navigateur et l'avoir redémarré. Le Google Tag manager ne le trouve pas non plus.

 

Merci d'avance

Edited by LCInformatique (see edit history)

Share this post


Link to post
Share on other sites

Non personne

 

Bonjour doekia,

Merci pour votre retour, il n'y a pas de solution/piste ? c'est étrange que le module ne se montre pas dans le BO quand même, vous ne trouvez pas ?

Share this post


Link to post
Share on other sites

Tu as peur de nous donner suffisament d'info pour t'aider alors on ne pourra pas t'aider

url ?

 

Qu'est ce que tu entends par copier coller? un module s'installe à partir de son zip depuis le BO, il n'y a pas de copier coller

 

Tu as mis ton code jsdans ton header mais, as-tu bien changer la valeur UA.

 

Et finalement, je ne sais pas si la version 1.5 de ganal est compatible avec la version 1.4.2.5 de PS. A l'époque c'est la version 1.4.3

Share this post


Link to post
Share on other sites

Tu as peur de nous donner suffisament d'info pour t'aider alors on ne pourra pas t'aider

url ?

 

Qu'est ce que tu entends par copier coller? un module s'installe à partir de son zip depuis le BO, il n'y a pas de copier coller

 

Tu as mis ton code jsdans ton header mais, as-tu bien changer la valeur UA.

 

Et finalement, je ne sais pas si la version 1.5 de ganal est compatible avec la version 1.4.2.5 de PS. A l'époque c'est la version 1.4.3

 

1. URL : je ne pensais pas que cela était primordiale mais je le mettrai dorénavant.

2. Installation: J'ignorai qu'il fallait l'installer en .zip, je l'avait décompressé et copier/collé via FTP.

3. Code suivi : Oui, j'avais bien mis le code, je l'avais retiré pour ce post

4. ça doit être la bonne version car après avoir importé le module en .zip, l'avoir retrouvé dans les modules non-installés, l'avoir activé, configuré,...ça marche...

 

merci pour ton aide

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More