Jump to content
Audray

Impossible d'installer un module

Recommended Posts

Bonjour à tous !

 

J'utilise PS 1.6.1.14, et l'installation d'un module me pose problème :

 

Il se nomme searchcategories :
    Impossible d'installer la surcharge : Class SearchControllerOverride595201cc48300 does not exist

 

Il semble manquer un dossier mais "searchController" est bien dans module/overide/controllers/ 

! peut être un problème d'écriture..

 

Quelqu'un a déjà rencontré ce problème SVP ?

 

Gros merci d'avance ;)

 

Share this post


Link to post
Share on other sites

Hello

 

Le nom de la surcharge ne me semble pas correct...

 

La 1ère chose à faire serait de contacter le dev du module, non ?

Share this post


Link to post
Share on other sites

Oui problèmes de droits, lorsque prestashop à fini de modifier la surcharge avec son nom temporaire il plante soit à la transférer au bon endroit, soit à le relire.

Dans les 2 cas, problèmes de droits et d'accès aux répertoires

Share this post


Link to post
Share on other sites

Merci pour vos réponses :)

 

J'ai finalement réussi a débuggé dans : 

Performance > Désactiver toutes les surcharges > Non

 
Il était sur oui, je l'ai mis sur non, j'espère que c'est bien ça mais pour l'instant ça fonctionne !
Edited by Audray (see edit history)

Share this post


Link to post
Share on other sites

C'est un peu radical, puisque cette option de permet de ne pas prendre en compte toutes les surcharges présentes sur ton site (via des modules, notamment). Mais tu avais peut-être d'autres modules qui avaient modifié le comportement de PS. Faut vérifier le contenu de ton répertoire /overrides, et le comportement de ton site

Share this post


Link to post
Share on other sites

Radical c est vrai mais je commence à perdre patience avec ce thème qui franchement me pose toujours problème !

 

Genre là, je passe mon temps à vider le cache mais il est toujours plein !

Comme je change le graphisme c est légèrement handicapant !

Pourtant j'ai désactivé le cache et forcé la compilation, j'ai même ajouté un code de non cache dans le <head> du header.tpl mais rien n'y fait...

Bref je continue à chercher la solution sur le web mais je risque d'ouvrir un autre sujet d'ici peu :(

Share this post


Link to post
Share on other sites

Tu as mis le bon le réglage => sur NON

Il n'y a aucune raison autre qu'un debug temporaire d'avoir cette option sur autre chose que NON - jamais

 

 

edit: erreur de saisie

Les surcharges doivent toujours être autorisé en fonctionnement normal

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More