Jump to content

Recommended Posts

Bonjour,

 

Je fais appel à la communauté car je ne trouve pas de solution de mon côté.

 

J'ai installer prestashop 1.6.

 

Pour l'instant je suis en maintenance.

 

Lorsque j'active ma boutique, pour vérifier si tout va bien, je remarque que  les frais de port soit n'apparaîssent pas, soit ils apparaîssent mais c'est pas le bon tarif, soit c'est à définir.

 

Voici les conseils que j'ai trouvé sur internet :

 

Vérifier dans livraison les transporteurs, j' ai  mondial relay et la poste, dans destination d'expédition et coût j'ai coché la case france, créer les tranches, j'ai désactiver le transporteur ,la facturation est en poids, je posais la question est-que je dois activé dans commande la facturation?

 

Verifier dans localisation, la zone, j'ai créer la zone france et pays, j'ai modifier la zone en france

 

Vider le cache dans paramètre avancés, performance, c'est fait

 

Je remercie les personnes qui prendront le temps de m'aider à y voir plus claire.

 

Share this post


Link to post
Share on other sites

Bonjour.

 

S'il y a une zone France, est-ce que le pays "France" est bien enregistré dans cette zone ?

Il y a 3 comportements différents : est-ce que les poids sont bien paramétrés pour chaque produit ?

Est-ce que les 2 transporteurs sont proposés à chaque commande ? Si non, est-ce normal ?

Share this post


Link to post
Share on other sites

Merci pour m'avoir répondu

 

J'ai créer la zone france et dans pays, j'ai modifier la zone en france.

 

Pour chaque produit, dans livraison, j'ai rempli le poids du colis.

 

Les 2 transporteurs ne sont pas proposés pour chaque commande car, suivant le poids du colis, j'ai pris le transporteurs le moins cher. par exemple pour un produit qui s'appel disque à démaquiller les frais de port sont de 1.96€ par la poste et par mondial relay 3.79€. Donc j'ai mis dans livraison préférences la poste, car c'est eux les moins cher.

Share this post


Link to post
Share on other sites

Et si vous réglez cette préférence sur "Le meilleur prix", qu'est-ce qui se passe ?

Share this post


Link to post
Share on other sites

Merci pour votre réponse et de votre aide

 

Je viens de réessayer, les frais de port ne sont toujours pas fonctionnel.  Les frais de port ne sont afficher sur aucun de mes articles. Je me demande si les modifications doivent être instantanés.

 

Quand j'active ma boutique pour vérifier, je constate que même que le panier a un problème, je suis en maintenance et l'affichage me dit que mon panier à 17 produits sur un certain article.

 

Je me demande si il y a lien avec le problème de frais de port.

 

Avez-vous d'autres pistes à me suggérer?

 

Merci

Share this post


Link to post
Share on other sites

Peut-être un pb de cookies, pour le coup.

Laissez en mode Maintenance mais ajoutez votre IP sur la même page de réglages. Puis faites vos tests en front-office.

Share this post


Link to post
Share on other sites

Je suis toujours en mode maintenance et IP est déjà régler dans préférences Maintenance IP de maintenance. Par contre je suis en train de chercher comment faire des test en front office. Je ne sais pas comment faire. Si vous pouvez m'aider. Si je comprends les explications sur les différentes pages internet le front office c'est les réglages des modules par défaut de prestashop? ou alors j'ai rien compris à leur explications. Quel genre de test dois-je faire? J'ai l'impression de tourner en rond, a force de revoir et revoir tous les paramétrage.

 

Merci

Share this post


Link to post
Share on other sites

Apparemment on peut cliquer sur un lien qui se trouve en haut à droite et qui  permet d’accéder rapidement au front office et voir les modifications, j'ai beau regarder je ne le vois pas. Seriez vous comment le trouver. Merci

Share this post


Link to post
Share on other sites

Il y a un lien "Ma Boutique" en haut à droite, qui renvoie vers le Front.

 

Le Front-office, c'est la partie visible par le public, les internautes. Le back-office est la partie Administration du site.

S'il y a une IP d'indiquée sur la page de maintenance, il est en principe inutile de désactiver le mode Maintenance pour faire des tests. Par contre, l'IP d'une Box classique change régulièrement, contrairement à une IP fixe.

Quand je parlais de test, c'était simplement des tests d'affichage des tarifs de livraison.

Share this post


Link to post
Share on other sites

Auriez vous d'autres conseils. J'ai enlevée le module mondial Relay pour voir si c'était celui-ci qui posait problème, j'ai supprimée dans produit le transporteur, la taille et le poids et puis les ai reparamétrées. Que puis-je faire d'autre?

Share this post


Link to post
Share on other sites

Je suppose que ça ne fonctionne toujours pas :(

Passez en mode Debug pour voir s'il y a des messages d'erreurs exploitables.

Share this post


Link to post
Share on other sites

J'ai enfin trouver la solution après de nombreux tests et heures de travail.

 

Pour ceux qui auraient rencontrer le même souci que moi, étant novice dans la création d'un site internet, voici quelques conseils.

 

Pour la livraison commencez à paramétrer le transporteur.

 

Lorsque vous installez un module de livraison (moi j'ai installer mondial relay). Regarder comment il est paramétré lors de l'ouverture du module.

 

Pour mondial relay, les plages des tranches que vous retrouvez dans livraison transporteur, destinations d'expédition et des coûts, ils sont configurer pour 10kg,

 

J'ai fait des tranches par rapport au poids de mes produits jusqu'à atteindre les 10 kg.

 

Ne pas remplir l'url dans paramètre généraux.

 

Dans destinations d'expédition et des coûts, j'ai paramétré comme suit :

 

Ajouter les frais de manutention oui

Frais de port offert non

Facturation: en fonction du poids total

Taxes : aucune taxe

Comportement hors tranches : désactiver le transporteur

 

Pour les prix et les tranches vous les retrouvez lorsque vous avez ouvert un compte pro chez mondial relay.

 

Dans taille et groupes associés remplir comme suit :

 

Largeur :120

 

Hauteur : 120

 

Profondeur : 120

 

Poids maximum : 30 kg

 

Ensuite j'ai créer 3 fois le même transporteur : la poste, en fonction des poids de mes produits, pour créer les tranches.

 

Dans destination d'expédition et coûts : comme pour mondial relay

 

Comportement hors tranches : désactiver le transporteur.

 

Voici un exemple de ce que j'ai fait pour mondial relay (pour les tranches)

 

sera appliquée lorsque le poids est supérieur, égale à :

 

0.000000 1 ère tranche 3.79€, 0.500000 2ème tranche, 4.37€, 2.000000 3ème tranche, 5.66€, 3.000000,4ème tranches, 6.66€, 5.000000, 5ème tranches, 8.75€ 7000000, 6ème tranches 10.63€

 

Sera appliquée lorsque le poids est inférieur à :

 

0.500000 1 ère tranche, 1.00000 2ème tranche, 3.000000, 3ème tranche, 5.00000, 4ème tranches, 7.000000, 5ème tranches, 10.000000, 6ème tranches

 

Faire de même pour la poste.

 

Ensuite dans catalogue produit :

 

Livraison, faire attention au poids par ex: 0.78 kg pour un produit pesant 78 grammes

 

Frais de port supplémentaire inscrivez les frais d'emballages ou d'enveloppe, pour ma part, je prends 10 centimes pour les frais d'enveloppes, inscrivez 0.10.

 

Choisissez le transporteur par rapport au poids de vos produits.

 

Faire attention au quantités des produits.

 

Tous les produits d'une même catégorie, doivent avoir : quantité minimal,la  même valeur, pour moi 1.

 

Bien tout remplir dans chaque champs de la fiche produit quand même.

 

Donc si je résume :

 

Commencez par paramétrer les transporteurs

 

Faire attention au paramétrage du module transporteur a l'ouverture et créer les tranches en fonction, sauf pour ceux de la poste, créer à partir des poids de vos produits, il est important de bien paramétrer les tranches.

 

Créer si besoin plusieurs fois le même transporteur selon le poids de vos produits

 

Ajouter les frais de manutention

 

Pensez à convertir les grammes en kg (produit, livraison)

 

Vérifier que les produits d'une même catégorie ai la même valeur de quantité minimal

 

J'espère que ce post vous aidera

 

Cordialement

Share this post


Link to post
Share on other sites

J'ai le même problème, pour moi, le "bug" venait du paramétrage de la case "frais de port offert à partir de", il faut le désactiver (0), sinon il efface les paramètres configurés dans le transporteur.

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai un problème similaire et je souhaiterais savoir si votre solution peut le régler : j'ai bien paramétré mes transporteurs par poids et disponibles en fonction des pays. Tout fonctionne bien lorsque l'utilisateur renseigne son adresse.

Toutefois, je souhaite que la mention livraison gratuite s'affiche par défaut et seulement lorsque l'utilisateur renseigne son adresse où il indique un pays A pour lequel j'ai configurer des frais de livraison alors il les voit apparaître. Est-ce possible ?

 

Bonne journée,

Clément

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More