Jump to content
jlweb

Désactivation des surcharges

Recommended Posts

Bonjour,

Je suis confronté à un bug qui semble provenir d'une surcharge. Lorsque je souhaite modifier un produit en enregistrant une caractéristique, j'ai bien un message d'erreur indiquant que le produit est bien enregistré mais la caractéristique ne s'est pas enregistrée. 

 

Ainsi, j'ai fouillé un peu et patché le bug concernant le problème d'"asynchrone" sur PS 1.6.

 

En back-office, lorsque je désactive les surcharges dans le menu "Performances", le bug n'est plus présent et les caractéristiques s'enregistrent bien. Ainsi, j'en déduis que mon problème provient d'une surcharge. Donc en théorie, si je réactive les surcharges depuis le back-office et que je renomme le répertoire /override en /override_test (par exemple), cela devrait avoir pour effet de "désactiver" les surcharges (?)

 

Mais en faisant cela, le bug est bel et bien présent. 

 

PS : j'ai bien pensé à supprimer /cache/class_index.php avant de faire les essais.

 

Ainsi mes questions sont les suivantes : 

- la désactivation des surcharges en back-office n'impacte t elle QUE /override ?

- y a t il des surcharges autre part que dans /override ? 

- une autre suggestion ?

 

J'avoue ne pas comprendre le phénomène...

 

Dans l'attente, je l'espère, d'une petite lumière dans ce tunnel sombre ...

 

Merci d'avance

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More