Jump to content
autonomie

impossible d'installer module v3.0.0-autoupgrade

Recommended Posts

Bonjour a tous

je n'arrive pas a installer ce module pour passer de la version 1.6.1.2 a la version 1.7

quand je charge le module , j'ai une erreur !

[PrestaShop] Fatal error in module file :/home/clients/1c22854170caf3fdb0a6aa7bc4ce43fd/web/modules/autoupgrade/autoupgrade.php:

Call to undefined method Autoupgrade::trans()

 

je suis hebergé chez infomaniak

version 5.4 php

version sql 5.6

 

si quelqu'un a une idée, je suis preneur

 

merci

Fred

Share this post


Link to post
Share on other sites

A moins de chercher à entièrement bousiller ton shop. Ne fait pas l'autoupgrade vers la 1.7, donc reste avec l'autoupgrade de la branche 1.6

Share this post


Link to post
Share on other sites

oui mais le module que j'ai sur la 1.6 ne m'upgrade qu en 1.6 

et je souhaite passer en v 1.7 ?

Share this post


Link to post
Share on other sites

Autant jouer à la roulette russe avec un automatique.

La 1.7 c'est encore terrain miné, 80% des modules manquants, etc

Share this post


Link to post
Share on other sites

L'erreur est à l'image de la 1.7: pas finie, pas aboutie et pas testée.

 

La 1.7 est un gros test effectué à vos dépends, c'est vous qui essuyez les plâtres et tant pis si ça plante votre shop

 

Si vous n'en avez pas besoin pour vivre, alors allez-y et amusez-vous bien, mais n'espérez aucun support sur ce forum. La Team ne répond plus et les connaisseurs n'utilisent pas cette version.

 

Vous êtes tout seul sur le coup^^

  • Like 1

Share this post


Link to post
Share on other sites

Bonjour

As-tu trouvé une solution? J'ai 1.6.0.9 et je voudrais mettre à jour mais j'ai ce même message d'erreur à l'install du module.

Je suis chez infomaniak aussi

 

Linux #52~16.04.1-Ubuntu

serveur Apache/2.4.18 (Ubuntu)

PHP 7.0.18-1+deb.sury.org~xenial+1

MySQL 5.7.18

 

 

[PrestaShop] Fatal error in module autoupgrade:
Uncaught Error: Call to undefined method Autoupgrade::trans() in /var/www/machin.net/boutique/modules/autoupgrade/autoupgrade.php:50 Stack trace: #0 /var/www/machin.net/boutique/classes/module/Module.php(1234): Autoupgrade->__construct() #1 /var/www/machin.net/boutique/controllers/admin/AdminModulesController.php(1341): ModuleCore::getModulesOnDisk(true, false, 3) #2 /var/www/machin.net/boutique/classes/controller/Controller.php(180): AdminModulesControllerCore->initContent() #3 /var/www/machin.net/boutique/classes/Dispatcher.php(373): ControllerCore->run() #4 /var/www/machin.net/boutique/admin-investig/index.php(54): DispatcherCore->dispatch() #5 {main} thrown

 

La page module et la sous page module meurent sur ce message, j'ai bien sûr vidé les caches

Edited by Fefaine (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

j'ai exactement le même problème, et du coup je ne peux pas accéder à mes modules! :( :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More