Jump to content
Kzoo

URL Rewriting causant une erreur 404

Recommended Posts

Bonjour, 

 

Je suis sur une migration de site entre deux serveurs et je rencontre quelques soucis, actuellement avec l'url rewriting. 

J'ai parcouru pas mal le forum, effectuer aussi des recherche avec google, mais les solutions que j'ai trouvé n'ont pas fonctionné. 

 

Je tourne sous 1.6.1.0 le temps de finaliser la migration correctement. Lorsque tout sera OK, je ferais les mises à jour vers la dernière 1.6. 

 

Lorsque j'active l'url rewriting, ma page d'accueil passe en erreur 404 en indiquant que le /fr/ n'existe pas. 

Je n'ai aucun soucis lorsque l'option est désactivé. J'ai vérifier les droits fichier/dossier, que l'option soit bien activée sur mon serveur, le htaccess est bien modifier lorsque j'active ou désactive l'option.

 

L'option activé, j'ai bien ces lignes de présentes :

 

RewriteEngine on

 

RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^api$ api/ [L]

 

RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L]
 
Et biensur vider cache site/navigateur. 
 
Je fonctionne sur un serveur dédié ovh, fonctionnant sur Débian 8, Apache 2 et php 5.6 si cela peut être utile.
 
J'avoue qu'un peu d'aide serait la bienvenue.

Share this post


Link to post
Share on other sites

Bonjour,

 

avez vous vérifié que le mod_rewrite d'apache est bien installé sur le nouveau serveur ?

Share this post


Link to post
Share on other sites

Oui oui, il est bien activé.

 

Voilà la liste des modules activé :

 

Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 filter_module (shared)
 headers_module (shared)
 mime_module (shared)
 mpm_prefork_module (shared)
 negotiation_module (shared)
 pagespeed_module (shared)
 php5_module (shared)
 reqtimeout_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 socache_shmcb_module (shared)
 ssl_module (shared)
 status_module (shared)
Edited by Kzoo (see edit history)

Share this post


Link to post
Share on other sites

Je me demande si, étant donner que le nom de domaine n'est pas encore rattaché, si cela n'a pas d'influence. Pour le moment je fonctionne avec l'url du serveur en directe. Mais en même temps je ne vois pas en quoi, cela peut changer quelque chose que ce soit en xxxxxxxxxx.com ou en nsip89.74.78.77.eu

Share this post


Link to post
Share on other sites

Si tu affiches un phpinfo à la racine de ton site vois tu bien HTTP_MOD_REWRITE : On ?

Share this post


Link to post
Share on other sites

Bonjour, 

 

Je n'ai pas la ligne sur mon phpinfo, mais j'ai :

oaded Modules core mod_so mod_watchdog http_core mod_log_config mod_logio mod_version mod_unixd mod_access_compat mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_host mod_authz_user mod_autoindex mod_deflate mod_dir mod_env mod_filter mod_headers mod_mime prefork mod_negotiation mod_instaweb mod_php5 mod_reqtimeout mod_rewrite mod_setenvif mod_socache_shmcb mod_ssl mod_status

 

url_rewriter.tags a=href,area=href,frame=src,input=src,form=fakeentry a=href,area=href,frame=src,input=src,form=fakeentry

Share this post


Link to post
Share on other sites

Par contre c'est bien présent dans le htaccess

Share this post


Link to post
Share on other sites

Dans mon htaccess tu dois avoir ces lignes

 

#If rewrite mod isn't enabled
ErrorDocument 404 /index.php?controller=404

Essaie de modifier 

/index.php?controller=404

en une page qui existe 

ça permettra de confirmer que c'est bien un problème de mod_rewrite qui n'est pas activé

Share this post


Link to post
Share on other sites

Alors, j'ai fais une tentative, non concluante, cela ne renvoie pas vers la page indiqué. 

 

En revanche, si je ne laisse qu'une seule langue d'activé sur le site, cela fonctionne. Mais quand j'arrive sur la page d'accueil et que je veux aller sur une fiche produit ou sur une page du CMS genre qui sommes-nous, je tombe de nouveau sur une page 404. Comme si le site n'arrivait plus à convertir les URL.

 

J'avoue je ne comprend pas.

Share this post


Link to post
Share on other sites

Y aurait-il un autre htaccess plus bas dans l'arborescence ?

 

Sinon à ta place j'essaierai d'installer un prestashop de base pour voir si c'est l'hébergement ou une configuration de ta boutique qui pose problème

Share this post


Link to post
Share on other sites

Alors, teste avec une nouvelle installation bidon, même problème donc c'est un problème serveur.

Share this post


Link to post
Share on other sites

Je crois avoir pointé un truc dans la configuration d'apache2. Ceci dit, c'est un dédié, du coup faut que je trouve.

Share this post


Link to post
Share on other sites

En fait non, rien de nouveau. Je calle

Share this post


Link to post
Share on other sites

En fait non, rien de nouveau. Je calle

 

Tu n'as pas un support avec ton heberger qui pourrait t'aider ?

 

Sinon je peux jeter un coup d'oeil si tu m'envoies des accès ftp ou ssh en MP mais pas avant ce week end par contre

Share this post


Link to post
Share on other sites

J'ai exactement le même problème et j'ai aussi un dédié kimsufi.

Quand je supprime la 2e langue installée ou que je choisi aucune redirection pour l'url cananonique, seule la page d'accueil s'affiche et sans les images des produits. Aucune autre page ne s'affiche.

Sinon, avec plusieurs langues ou des redirections pour les urls canoniques, rien ne s'affiche. Je n'ai que des 404.

mod-rewrite est bien activé, il fonctionne avec d'autres sites sur le même serveur.

Même en local je n'arrive pas à faire les redirections.

Si je trouve la solution, je la posterai ici.

Share this post


Link to post
Share on other sites

J'ai trouvé.

Dans mon cas, il m'a suffit de mettre la directive

AllowOverride All

dans mon vhost ou dans le fichier conf qui gère votre dossier prestashop.

Avant c'était en

AllowOverride None

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Merci beaucoup Mootookoi, cela a fonctionné pour moi aussi avec la directive AllowOverride All.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More