Jump to content
Idlook

Back office moitié français moitié anglais

Recommended Posts

Bonjour,

 

Je m'appelle Adeline, 28 ans, je créé ma boutique en ligne de vente de vêtements et chaussures. 

 

J'ai installé prestashop 1.6 hier, et sur mon back office, le menu est bien en français, mais à l'intérieur, c'est en anglais. J'ai tout essayé pour modifié cela, mais rien n'y fait.

J'ai un acheté un thème, j'utilisé auparavant le cloud, et je n'avais pas ce souci là. 

 

Autre souci, lorsque je veux visualiser ma boutique, je tombe sur une page de mon hébergeur, disant "ce nom de domaine est déjà enregistré".

 

Pouvez-vous m'aider?

Merci

Edited by Idlook (see edit history)

Share this post


Link to post
Share on other sites

SVP j'ai vraiment besoin d'aide...

 

La langue est bien en Français, et si je veux changer la langue de mon back office dans "traduction", j'ai ce message d'erreur : Warning! Your PHP configuration limits the maximum number of fields allowed in a form: 5000 for max_input_vars.

Please ask your hosting provider to increase this limit to 5270 at least, or you will have to edit the translation files.

 

 

Est ce que ça vient de là?

Edited by Idlook (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Le warning sur la configuration peut en effet être lié au problème de traductions non complètes que tu décris. Es-tu sur un hébergement dédié ou virtuel ? Sinon tu devrais demander à ton hébergeur d'augmenter la valeur du paramètre max_input_vars dans le fichier php.ini.

Share this post


Link to post
Share on other sites

Merci pour ta réponse

 

Je suis chez 1&1.

 

Tu penses donc que ça vient de ça alors? Parce que quand je l'utilisais en cloud, je n'avais pas ce souci là. 

Share this post


Link to post
Share on other sites

Ok merci.

 

Je vais contacter d'abord mon hébergeur et je verrais ensuite...

Share this post


Link to post
Share on other sites

Bonjour,

 

Je ne suis pas vraiment certain que le warning et le problème de traduction soient liés mais la coïncidence est troublante.

En tant que développeur je commencerai de toute manière par régler ce problème si j'étais à ta place.

Share this post


Link to post
Share on other sites

Ok, je vais le contacter cet après midi. 

J'ai commencé à regarder pour charger le pack traduction français, mais je ne le trouve pas.

J'ai quand même peur d'acheter un module et que ça ne fonctionne toujours pas.

Share this post


Link to post
Share on other sites

Je viens de me rendre compte que j'ai exactement le même problème que toi sur la démo de mes modules : menu en français et contenu en anglais ...

J'ai re-importé le pack français (dans localisation > premier item) mais cela ne change rien. Je pense que c'est lié au cache ou aux cookies, je vais jeter un coup d'oeil.

Mais dans tous les cas tu devrais régler ton problème de warning car il va t'empêcher de modifier manuellement les traductions.

Share this post


Link to post
Share on other sites

@Idllook, 

J'ai une bonne nouvelle pour toi !

 

Voilà, suite à ton dernier message je suis allé voir dans le premier back-office que j'avais sous la main et je me suis retrouvé dans la démo de mes modules qui avait exactement le même problème que ton site. A force de travailler sur PrestaShop je ne me suis juste jamais rendu compte que la moitié du back-office est en anglais pour les utilisateur français... On le voit vite dans le tableau de bord : il est écrit «dashboard».

 

Voiçi ce que j'ai fait :

1/ Ajout du paramètre «max_input_vars = 6000;» dans php.ini (le paramètre n'y était pas et donc utilisé avec sa valeur par défaut 1000)

2/ Redémarrage d'apache

3/ Dans localisation > traductions j'ai cliqué sur AJOUTER / METTRE À JOUR UNE LANGUE et tout fonctionne (https://demo1-6.smart-plugs.net/adminDemo) !

 

Par contre, j'ai l'impression que les traductions personnelles du front-office sont écrasées par cette manip.

Share this post


Link to post
Share on other sites

ok Smartplugs, super nouvelle!

 

Mais où est-ce que je peux modifier moi-même le paramètre max_input?

Et qu'est-ce l'apache?

 

Et puis comme tout est en Anglais, je comprends rien en naviguant sur mon back office!  :angry:

Edited by Idlook (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Demande à ton hébergeur pour le max_input_vars.

Apache est le nom du logiciel qui traite les requêtes des internautes et renvoi les pages de ton site, le serveur web donc. Ne t'occupe pas de ça, s'il fait la modif, ton hébergeur le redémarrera très probablement.

Il ne te restera que la manip 3 à faire.

Share this post


Link to post
Share on other sites

Plus ça va, plus je pense réinstaller prestashop 1.7, je l'avais fait avant d'installer le 1.6 et je n'avais pas ce souci là. 

Je suis lasse , j'ai pris beaucoup de retard.

 

Qu'en penses-tu , la 1.7 est-elle bien?

Share this post


Link to post
Share on other sites

La 1.7 n'est absolument pas utilisable ne production.

 

Avez vous chargé le pack langue au moins ?

 

pour la max input c’est plus chiant si vous ne pouvez pas changer cela vous même c’est pour cela que le module que je vous ai présenté existe.

Share this post


Link to post
Share on other sites

De tous les avis que j'ai lus il vaut mieux rester sur 1.6.1.11.

De mon côté j'ai trouvé plein de bugs sur les 1.7 simplement en testant la compatibilité de mes modules.

 

As-tu posé la question à ton hébergeur ? Et tu ne nous a pas répondu sur le type d'hébergement que tu avais (mutualisé / dédié / virtuel )

Edited by SmartPlugs (see edit history)

Share this post


Link to post
Share on other sites

Ah il faut alors que je retélécharge le 1.6. Je n'ai pas appeler mon hébergeur du coup.

 

J'ai un contrat unlimited pro chez 1&1, je ne sais pas si c'est en dédié ou mutualisé, je ne comprends rien à tout ce vocabulaire.

 

Je n'ai pas trouvé le pack langue. 

 

Et Media com, j'ai bien vu ton module pour changer la langue, mais c'est payant, et si ça ne fonctionne toujours pas?

Share this post


Link to post
Share on other sites

Vous ne trouvez pas le pack langue ?????????

 

pourquoi le module proposé ne fonctionnerait pas ?

 

 

Vous ne savez pas comment est hébergé votre site parce que le vocabulaire n'est pas accessible au non initié, donc faites l'effort de l'apprendre c'est de votre commerce que nous parlons, si votre notaire ou votre avocat utilise des mots inconnus pour un commerce réel on fait l'effort de se former un minimum mais comme c'est de l'informatique et que c'est en ligne on s'en tape royalement.

Share this post


Link to post
Share on other sites

Bien sûr que je me suis renseigné sur le vocabulaire... mais je ne sais pas si le mien est dédié ou mutualisé, je crois que c'est mutualisé, mais je demanderai en même temps à mon hébergeur demain.

Sinon, j'utilise Filezilla comme serveur FTP. 

 

Je ne l'ai pas trouvé sur le prestashop 1.6, en Anglais du coup... Je vais le retélécharger, on va bien voir. Sur le 1.7 pas de souci. 

 

Merci de votre patience et de vos réponses ...

Share this post


Link to post
Share on other sites

J"ai eu mon hébergeur, il a modifié le paramètre. Donc plus de warning.

 

Lorsque je suis retourné sur "traductions", "modifier traductions", "type de traductions" = back office, "langue = français", plus de warning  :) , mais 5170 expressions à traduire .  :wacko:

 

Je suis remonté plus haut vers vos réponses pour trouver un plan B, et en voyant une de tes réponses SmartPlugs, celle du 22/03 à 11h09, j'ai fait l'étape 3 "modifier/mettre à jour une langue", c'était déjà en Français, donc je me suis dit "c'est mort  -_- ", mais je l'ai fait quand même et YOUPIIIIIII !!!! ça a marché!! Tout est en Français!! 

 

Je ne comprends pas, c'était déjà en Français, mais ça marché quand même. Bon je vais pas trop m'attarder (même si j'ai ce besoin de tout comprendre pour tout contrôler). C'était surement une question de mise à jour. Mais si je l'avais fait depuis le début, ça aurait peut-être marché du premier coup, au lieu de me prendre la tête comme ça et perdre un temps fou. 

 

Encore mille merci à vous 2!!

 

Dernière chose, comme j'ai dû réinstaller la version 1.6, mon hébergeur ma proposé de le réinstaller via 1&1, ils ont cette application. J'ai donc fait comme ça, ça posera pas trop de problème?

Edited by Idlook (see edit history)

Share this post


Link to post
Share on other sites

Salut,

 

Ah, au moins un problème de réglé !

Et je te rassure, il fallait bien faire les étapes 1,2 et 3 pour que cela marche.

Share this post


Link to post
Share on other sites

Oui rassurée!

 

J'ai quand même beaucoup d'expressions à traduire, je vais acheter le pack langue que media com m'a fournit

Share this post


Link to post
Share on other sites

Mais il n'y a rien à acheter il suffit de charger le pack langue français à par du backoffice comme expliqué et comme indiqué sur la capture d'écran déjà jointe.

 

Cela prends 5 secondes à faire.

Share this post


Link to post
Share on other sites

J'ai déjà fait ça, le pack langue, mettre à jour une langue. C'est ce qui a marché pour traduire tout l'intérieur de mon back office.

Mais j'ai des milliers d'expressions à traduire manuellement. 

 

J'ai acheté le module, je suis en train de le configurer pour modifier les traductions. Mais je ne sais pas si ça marche 

Share this post


Link to post
Share on other sites

Vous avez acheté le module, je suppose que vous parlez de celui que je vous ai conseillé.

 

si vous avez besoin de support vous pouvez nous contacter directement par le site d'achat.

Share this post


Link to post
Share on other sites

Oui celui que vous m'avez conseillé. Je l'ai pris sur prestashop addons, mais c'est exactement le même

Share this post


Link to post
Share on other sites

Bon, ben si vous ne l'avez pas acheté chez moi je vous laisse gérer avec son développeur directement.

Share this post


Link to post
Share on other sites

Ah d'accord. Mince, je croyais qu'il n'y avait pas de différence.

Share this post


Link to post
Share on other sites

Bon bah moi j'ai essayé de changer avec l'image que vous avez partagé

 

Je suis allée dans "Localization" --> "Translations" --> "Back office translations" puis je choisis français

 

Mais après avoir mis "modify" j'ai ce message :

 

Warning! Your PHP configuration limits the maximum number of fields allowed in a form: 5000 for max_input_vars.
Please ask your hosting provider to increase this limit to 5271 at least, or you will have to edit the translation files.

 

Que puis-je faire?

 

Je désespère depuis 3h de recherche lol

Share this post


Link to post
Share on other sites

Bonjour,

 

Vous avez le même problème que celui décrit au début de ce post et la solution est la même : il faut augmenter la valeur du paramètre max_input_vars dans le fichier php.ini.

Edited by SmartPlugs (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Du coup j'ai demandé à mon hébergeur ils m'ont augmenté à 10 000 mais maintenant j'ai un message* qui me met comme si je devais entrer la traduction de chaque terme spécifié...

 

*Some of these expressions use this special syntax: %d.
You MUST use this syntax in your translations. Here are several examples:

  • "There are %d products": "%d" will be replaced by a number.
  • "List of pages in %s": "%s" will be replaced by a string.
  • "Feature: %1$s (%2$d values)": The numbers enable you to reorder the variables when necessary.

 

 

J'ai vu que vous parliez d'importer quelque chose mais je n'ai pas tout compris et pas tout trouvé...

 

Merci pour votre réponse :)

Edited by plums-creations (see edit history)

Share this post


Link to post
Share on other sites

OK, il faut donc que tu cliques sur «add/update» à la place de «modify» pour mettre à jour toute les traduction en français.

Cela devrait fonctionner pour toutes les traductions du back-office (et par contre, ainsi qu'annoncé, «toutes les modifications de traduction que vous avez apportées au thème "default-bootstrap" pour cette langue seront perdues»).

  • Like 1

Share this post


Link to post
Share on other sites

MERCI BEAUCOUP ça a marché :D
Pff je cherchais cette fameuse case "mettre à jour" , vraiment pas très douée avec l'anglais !

 

Quand même ça fait 5 ans que le problème perdure d'après ce que j'ai lu, ça serait bien que Prestashop gère le problème définitivement.

 

Merci pour vos réponses rapides et claires :)

 

Tiffany

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More