Jump to content
cpied

Problème comment installer chez ovh les fichiers fournis par Prestashop ?

Recommended Posts

Bonjour,

 

J'ai un hébergement OVH et mon nom de domaine a été migré dessus.

J'ai reçu de la part de Prestashop un dossier database.sql et un dossier www.tgz

 

Avec FileZilla, j'ai installé une version vierge de prestashop dans laquelle j'ai ensuite transféré les dossiers reçu par Prestashop.

 

Pour le moment rien ne fonctionne.

J'ai une page en construction quand j'essaye d'aller sur mon site.

 

Comment installer tout cela correctement? Comment acceder au backoffice de la boutique?

 

Existe-t-il un tuto ou un guide plus explicite que celui fourni par Prestashop?

 

Merci

Christophe

Share this post


Link to post
Share on other sites

Bonjour

 

Je ne sais pas quel son les dossiers dans le www.tgz

1° installation vierge ok

2° vidé la base de donnée des tables de cette nouvelle installation

3° importer le database.sql SI tous les tables sont dedans.

4° si tous les tables ne sont pas dedans, supprimer l'équivalent des tables correspondant à ceux de la database.sql

c'est a dire exemple : ps_configuration de la nouvelle installation supprimer et mettre ps_configuration de la database.sql

 

5° Le dossier /img/ de la nouvelle installation supprimé et remplacer par le dossier /img/ qui est dans www.tgz

 

ainsi de suite avec les autres dossier est-ce assez clair ou flou :) ?

 

/config/setting.inc.php de www.tgz à mettre à la place du setting.ini.php de la nouvelle installation et modifier nom du serveur de la base de donnée

nom de la base de donnée, de l'utilisateur et le mot de passe avec les informations de la nouvelle base de donnée

Share this post


Link to post
Share on other sites

merci, c'est clair, je vous tiens au courant ;-)

Share this post


Link to post
Share on other sites

Bonjour,

 

je pense avoir tout installé correctement mais j'ai le message suivant quand j'essaye d'aller sur le site:

 

Link to database cannot be established: SQLSTATE[HY000] [2005] Unknown MySQL server host 'sql3.prestashopfr1.ha.ovh.net' (1)

 

Il me semble que c'est le fichier "settings.inc.php" qui pose problème.

 

Un avis?

 

Merci

Share this post


Link to post
Share on other sites

Bonjour

 

Dans le setting.inc.php vous devez mettre le nom du serveur chez ovh style mysql-51 pro mysql-5 perso etc.. cette information vous l'avez dans votre compte ovh

Puis le login  qui ne sera pas le même, le mot de passe là si vous avez mis le même c'est bon , sinon changer

 

Link to database cannot be established:  << ce message c'est toujours quand on ne peut pas accéder à la base de donnée, ça peut être pour différentes raisons

Share this post


Link to post
Share on other sites

Bonjour,

 

Je reviens vers vous car cela ne fonctionne toujours pas.

 

J'ai suivi le guide d'installation fourni par Prestashop (Migrerdepuislecloud.pdf)

 

1. J'ai installé la version vierge de Prestashop avec FileZilla dans le dossier .www

2. j'ai mis dans ce même dossier le fichier database.sql envoyé par prestashop

3. j'ai décompressé le fichier www.tgz envoyé par Prestashop et je l'ai mis dans le dossier .www avec FileZilla

4. j'ai mis le fichier settings.inc.php dans le dossier .www avec FileZilla. J'ai bien modifié les information dans le fichier comme demandé dans le guide... J'ai donc changé le DB_Server, name, user,et password.

 

Sur OVH, dans l'onglet multisite, le dossier racine est bien www

 

Cela ne fonctionne toujours pas. Je suis au bout de mes possibilités.

 

Si quelqu'un peut m'aider SVP?

ou prendre en charge cette installation (moyennant finance)

 

Cela fait un mois et demi que mon site est HS.

 

MERCI

 

 

Edited by cpied (see edit history)

Share this post


Link to post
Share on other sites

Bonjour,

 

Je reviens vers vous car cela ne fonctionne toujours pas.

 

J'ai suivi le guide d'installation fourni par Prestashop

Bonjour

 

Est-ce que vous avez modifier le nom du serveur de la base de donnée, le login, le mot de passe c'est bien celui que vous avez créer dans la gestion de votre hébergement

Ou modifier le en créant un nouveau mot de passe que vous aurez préalablement écris sur un papier.

Share this post


Link to post
Share on other sites

oui, j'ai bien changé tout cela.

 

le message sur la page d'accueil est:

 

Link to database cannot be established: SQLSTATE[HY000] [2005] Unknown MySQL server host 'sql3.prestashopfr1.ha.ovh.net' (1)

Share this post


Link to post
Share on other sites

'sql3.prestashopfr1.ha.ovh.net'  <<< ça c'est le serveur mysql de prestashop cloud et pas de votre compte privé chez ovh !!!

 

Vous devez mettre votre nom de serveur qui est dans le style

 

post-23611-0-12945800-1489506071_thumb.png

 

et la nouvelle interface c'est dans le style :

 

post-23611-0-24514600-1489506308_thumb.png

Share this post


Link to post
Share on other sites

Merci Oron pour votre retour.

Je n'ai pas la même fenêtre que vous.

 

dans le fichier "setting.inc.php", j'ai mis "define('_DB_SERVER_', '*******.mysql.db'); comme indiqué dans l'onglet "bases de données" sur mon compte OVH

 

C'est de cela que vous parlez?

Share this post


Link to post
Share on other sites

Ok, en fait, quand je remplis les fenêtres phpmyadmin avec les infos (que je sais exactes) ... il y a un message d'erreur.

Share this post


Link to post
Share on other sites

Ok, en fait, quand je remplis les fenêtres phpmyadmin avec les infos (que je sais exactes) ... il y a un message d'erreur.

quel erreur ?

Share this post


Link to post
Share on other sites

Écrivez votre mot de passe sur le bloc note comme cela vous verrez et serez sûr que c'est le bon

Puis copier coller dans la case des mots de passe, si ça ne fonctionne pas refaite un autre ou demander a OVH c'est de leur ressort.

Share this post


Link to post
Share on other sites

je vais réessayer, mais pouvez-vous me dire pourquoi il faut aller sur phpmyadmin?

 

Merci

Share this post


Link to post
Share on other sites

je vais réessayer, mais pouvez-vous me dire pourquoi il faut aller sur phpmyadmin?

 

Merci

Bonjour

 

Je n'ai pas dit qu'il "faut" mais en allant sur phpmyadmin vous verrez si votre login et mot de passe est correcte. C'est le même que vous mettez dans setting.inc.php

Share this post


Link to post
Share on other sites

Bonjour Oron,

 

J'ai tout recommencé à zéro...

Je confirme que je peux accéder a phpmyadmin.

 

Tout a été mis sur le FTP selon la procédure conseillée par Prestashop.

 

Maintenant je n'ai plus de message d'erreur lorsque j'ouvre le site.... mais la page reste blanche...

 

On progresse mais ce n'est pas encore ça ;-)

Share this post


Link to post
Share on other sites

Bon page blanche plusieurs cause possible :

 

problème d'interprétation d'un fichier :

 

La ligne sur une 1.5 / 1.6 dans config/defines.inc.php
define('_PS_MODE_DEV_', false); << mettez false à true >> define('_PS_MODE_DEV_', true);

Si c'est un problème d'interprétation d'un fichier vous verrez un message d'erreur. Copier Coller au moins la 1ere ligne.
Si le nom de votre dossier d'administration apparait remplacé le par des *****.

 

Si ce n'est pas cela qu'aucun message ne s'affiche la cause est ailleurs

 

Cela peut être un fichier mal transférer

ou voir ces explications : https://www.prestashop.com/forums/topic/232472-que-faire-en-cas-de-page-blanche-ou-partie-blanche-dans-le-shop/

 

Est-ce que vous avez tous les fichiers ? Sur filezilla ou autre quand vous sélectionnez un dossier vous avez en bas le nombre de dossier et le nombre de fichier

Sélectionner le www sur le ftp et regardez ce qui est écris

Puis vous regarder le dossier où vous avez votre prestashop dézipper sur votre PC, s'il en manque pas c'est bon tous y sont

Share this post


Link to post
Share on other sites

Je viens de lire le fichier migrationdepuislecloud.pdf c'est juste, c'est bien expliqué, peut-être logique a comprendre pour les habituer et moins logique pour ceux sans expérience de migration ou installation.

 

Le fichier setting.inc.php il est dans le wwww.tgz

 

Vous avez bien pris la même version et supprimer avant toute autre manipulation le dossier install ?

Share this post


Link to post
Share on other sites

oui j,ai bien supprimé le dossier install.

 

J'ai mis le fichier setting.inc.php dans le dossier config du www avec FileZilla

 

Il y plus de dossier dans le www de Fillezilla que sur mon PC car il y en avait plas dans la version vierge de Prestashop...

 

Merci pour le temps que vous prenez pour m'aider ;-)

Share this post


Link to post
Share on other sites

www de Fillezilla que sur mon PC car il y en avait plas dans la version vierge de Prestashop...

 

Oui ça c'est logique, mais je parle plus en intégrant en local les dossiers et fichiers reçus, c'est pour être certain que tous les fichiers ont bien été transférer qu'il n'y a pas d'oublie

 

Pour la page blanche vous avez fait ce que j'ai dit ?

Share this post


Link to post
Share on other sites

Je ne trouve pas le fichier

 

config/defines.inc.php

Share this post


Link to post
Share on other sites

J'ai trouvé et j'ai fait comme expliqué: true à la place de False.

 

Voici le message qui s'affiche sur la page:

 

Warning: require_once(/home/etikeasyox/www/classes/PrestaShopAutoload.php): failed to open stream: No such file or directory in /home/etikeasyox/www/config/autoload.php on line 29

Fatal error: require_once(): Failed opening required '/home/etikeasyox/www/classes/PrestaShopAutoload.php' (include_path='.:/usr/local/php5.6/lib/php') in /home/etikeasyox/www/config/autoload.php on line 29

Share this post


Link to post
Share on other sites

On avance...

 

Maintenant ma page d’accueil s'affiche (avec un problème au niveau d'un module de présentation des produits...)

Aucun liens ne fonctionne

Je n'arrive pas a accéder au back office.

 

L'adresse est: etikeasy.com

 

Merci de votre aide ;-)

Share this post


Link to post
Share on other sites

Bonjour

 

Là en mode maintenance je ne peux rien voir.

Share this post


Link to post
Share on other sites

Comment fait-on pour acceder au backoffice?

 

j'ai fait comme demandé:

Renommer le répertoire admin en un nom que vous seul connaîtrez. C’est par ce nom que vous accéderez à votre backoffice grace à l’URL
http://mon.domaine.com/<nouveau_nom>.

 

Mais la fenêtre affiche: Not found

Share this post


Link to post
Share on other sites

Le nom de dossier il est bien mis exactement comme il est écris ? ou vous avez des symbole dedans ou autre ?

A moins que ce soit le .htaccess, invalidez le .htaccess en l'appelant .htaccess.bak et tester si ça fonctionne vous mettez l'url rewriting à non enregistré puis vous pouvez réactivé t enregistrer cela recrée le .htaccess

Share this post


Link to post
Share on other sites

ou je trouve ce .htaccess ?

 

je ne comprends pas: vous mettez l'url rewriting à non enregistré puis vous pouvez réactivé t enregistrer

Share this post


Link to post
Share on other sites

Le fichier .htaccess est un fichier caché, pour le voir il faut cocher la case  Forcer l'affichage des fichiers cachés dans le logiciel FTP style filezilla

et là quand vous le verrez vous pouvez le renommer l'ouvrir éditer a volonté.

 

Et dans le back office en activant l'url rewriting le .htaccess se crée tout seul, en le désactivant et enregistrer le .htaccess n'est plus pris en compte pour les url's

et en le réactivant a Oui et enregistrer on recrée le fichier .htaccess

 

Donc en le renommant même au cas par erreur on le supprime on peut le recréer,

 

 

post-23611-0-65872100-1489767834_thumb.png

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More