Jump to content
persan70

Error a Conectarse a Addons Marketplace en Prestashop 1.7

Recommended Posts

   Instale la version 1.7.0.4 que se encuentra disponible en la pagina para evaluar. me dio 2 errores, la primera no abrian la seccion de los modulos pero se corrigio al copiar el archivo cacert.pem en su carpeta correspondiente. El siguente error es que no logra conectar el Addons Marketplace. Me indica el Error PrestaShop no pudo iniciar sesión en Addons. Por favor verifique sus datos de acceso y su conexión a Internet. En otros foros encontre agregar una linea en el archivo init.php que se encuentra en admin, allow_url_fopen = On; lo cual en la version 1.7.3 me funcionó pero en la 1.7.4 no. 

   Me gustaria de su apoyo para corregir este problema para ver en donde esta el error

 
  • Like 1

Share this post


Link to post
Share on other sites

Vendita tortura, me uno también estoy desesperado porque no se puede instalar nada sin estar conectado.

Share this post


Link to post
Share on other sites

buenas, yo tampoco podía acceder hasta que cambié la versión de php de la 5.6 a la 7.1. Espero que os sirva y comprobar que en el php teneis activo (on) la opción allow_url_fopen.

 

Un  saludo.

Share this post


Link to post
Share on other sites

Ésta es la solución para poder conectar con el Addons Marketplace en Prestashop 1.7

 

Para las versiones 1.7 y superiores de Prestashop, hay que forzar curl para que funcione en lugar de allow_url_fopen, modificando el código del fichero Tools.php que está dentro de la carpeta classes del directoria raiz de Prestashop.

 

/classes/Tools.php

 

Es IMPORTANTE realizar copia de seguridad antes de editarlo.

 

nos deplazamos sobre la linea 1970 y comentamos con almohadilla # o eliminamos las lineas que a continuación indico:

 

        if ($is_local_file) {
            $content = @file_get_contents($url, $use_include_path, $stream_context);
        } else {
#            if ($require_fopen) {
#                $content = Tools::file_get_contents_fopen($url, $use_include_path, $stream_context);
#            } else {
                $content = Tools::file_get_contents_curl($url, $curl_timeout, $opts);
#                if (empty($content) && $fallback) {
#                    $content = Tools::file_get_contents_fopen($url, $use_include_path, $stream_context);
#                }
#            }
        }
 
        return $content;
    }
 
A continuación guardamos el fichero y verificamos el acceso al Addons Marketplace desde Prestashop.

 

A mi ésta solución me ha funcionado perfectamente, y es básicamente forzando curl, porque activar la función allow_url_fopen en php es muy peligrosa.

 

Saludos.

Share this post


Link to post
Share on other sites

yo tengo el mismo problema, yo instale desde mi cpanel y no se de programacion , tengo un editor de php que me muestra esto:

; cPanel-generated php ini directives, do not edit
; Manual editing of this file may result in unexpected behavior.
; To make changes to this file, use the cPanel MultiPHP INI Editor (Home >> Software >> MultiPHP INI Editor)
; For more information, read our documentation (https://go.cpanel.net/EA4ModifyINI)

allow_url_fopen = Off
allow_url_include = Off
asp_tags = Off
display_errors = Off
enable_dl = Off
file_uploads = On
max_execution_time = 30
max_input_time = 60
max_input_vars = 1137
memory_limit = 256M
post_max_size = 8M
session.gc_maxlifetime = 1440
session.save_path = "/var/cpanel/php/sessions/ea-php56"
upload_max_filesize = 2M
zlib.output_compression = On
 

ya probe colocando 

allow_url_fopen = On
allow_url_include = On

eso es lo que e conseguido en los tutoriales y aun no me puedo conectar a marketplace, me da el siguiente error:

"If you want to be able to fully use the AdminModules panel and have free modules available, you should enable the following configuration on your server 
- Enable PHP's allow_url_fopen setting"

 

Share this post


Link to post
Share on other sites
On 8/15/2017 at 12:34 PM, GrupoItech said:

Ésta es la solución para poder conectar con el Addons Marketplace en Prestashop 1.7

 

Para las versiones 1.7 y superiores de Prestashop, hay que forzar curl para que funcione en lugar de allow_url_fopen, modificando el código del fichero Tools.php que está dentro de la carpeta classes del directoria raiz de Prestashop.

 

/classes/Tools.php

 

Es IMPORTANTE realizar copia de seguridad antes de editarlo.

 

nos deplazamos sobre la linea 1970 y comentamos con almohadilla # o eliminamos las lineas que a continuación indico:

 

        if ($is_local_file) {
            $content = @file_get_contents($url, $use_include_path, $stream_context);
        } else {
#            if ($require_fopen) {
#                $content = Tools::file_get_contents_fopen($url, $use_include_path, $stream_context);
#            } else {
                $content = Tools::file_get_contents_curl($url, $curl_timeout, $opts);
#                if (empty($content) && $fallback) {
#                    $content = Tools::file_get_contents_fopen($url, $use_include_path, $stream_context);
#                }
#            }
        }
 
        return $content;
    }
 
A continuación guardamos el fichero y verificamos el acceso al Addons Marketplace desde Prestashop.

 

A mi ésta solución me ha funcionado perfectamente, y es básicamente forzando curl, porque activar la función allow_url_fopen en php es muy peligrosa.

 

Saludos.

Hola  buenas.  He intentado modificar el archivo tools.php y creo que he hecho algo mal. En primer lugar no hacer copia de seguridad.  Me harías el favor de enviar uno ya modificado??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More