Jump to content

Mon site marche en local mais impossible de mettre en ligne


Recommended Posts

Salut à toi communauté Prestashop,
Voilà mon problème: mon site fonctionne très bien en local mais impossible de faire marcher sur mon hébergement OVH.
(même en recommençant avec un prestashop vierge)
Je suis les étapes du wiki, mais j'ai invariablement le même message lorsque j'essaie d'installer:


http://www.bienvenuechezjuju.com/install

Not Found
The requested URL /install/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.42 Server at www.bienvenuechezjuju.com Port 80

Quelqu'un pourrait-il m'aiguiller???

Share this post


Link to post
Share on other sites

Salut à vous, pour donner un peu plus de précision:
j'ai crée une BD à l'aide du cPaNEL d'OVH, mais lorsque je vais sur phpmyadmin, la BD est créee sur le serveur localhost.
Je dois avoué que je ne comprends pas ce que je fais quand je crée des BD: où sont-elles stockées, comment y accède-ton... tout cela est bien nébuleux pour moi... c'est peut-être ici que ca coince...
en attendant d'arriver à mettre mon prestashop en ligne j'ai mis une page brouillon (que je n'arrive plus à supprimer même en nettoyant le fichier www et en retéléchargeant de nouveau le dossier prestashop dessus avec filezilla...)
J'espère que j'ai donné suffisament de détails pour que vous puissiez m'aider...

Share this post


Link to post
Share on other sites

oui bien expliquer , apres la creation de ta base de données tu attend pour que la requete soit bien executer, tu recoit sur ton email les identifients de ta nouvelle base et apres ce les etapes normales si tu veux je peut t'aider pour finaliser tous salut.

Share this post


Link to post
Share on other sites

Voilà ou j'en suis:
-j'ai bien crée une BD (que je vois lorsque je vais sur PHPmyadmin)
-je connais les identifiants puisque je vient de les rentrer (cependant je n'ai reçu aucuns mail, et j'ai vérifier toutes mes adresses mails)
-je suis prêt à suivre toutes tes instructions car voilà 2 jours que je tente de mettre en ligne, en suivant des tas de tuto, de conseils... et rien...)
...

Share this post


Link to post
Share on other sites

ah, je crois que je viens de trouver quelque chose...j'ai télécharger le prestashop dans public html au lieu de www... et l'install s'ouvre... je regarde jusqu'où j'arrive et je te tiens au jus...

Share this post


Link to post
Share on other sites

bien, j'ai pu installer un prestashop vierge.
Petite question: comment je fais pour récupérer ma base de donnée du prestashop que j'avais en local? (j'ai peur de faire n'importe quoi et d'effacer des tables....)

Share this post


Link to post
Share on other sites

je ne comprends pas ce que je dois faire:
-je dois faire exporter lorsque je suis dans ma table vierge ou dans ma table pleine?
-faut-il cocher des options (transmettre,...)
-faut-il faire une sauvegarde des BD, si oui comment faire?
je suis désolé si mes questions te paraisse ridicules mais je n'ai aucunes connaissances sur les BD....

Share this post


Link to post
Share on other sites

j'ai fait exporter, exécuter: un page s'ouvre
je l'ai copié dans un fichier texte.
J'ai ensuite fait importer, exécuter ce fichier dans la nouvelle base: j'obtient une erreur:
Erreur

Il semble qu'il y ait une erreur dans votre requête SQL. Le message ci-bas peut vous aider à en trouver la cause.

ERROR: Identificateur invalide @ 154
STR: 5.1.
SQL: -- phpMyAdmin SQL Dump
-- version 3.2.0.1
-- http://www.phpmyadmin.net
--
-- Serveur: localhost
-- G�n�r� le : Mar 15 Juin 2010 � 09:50
-- Version du serveur: 5.1.36
-- Version de PHP: 5.3.0

SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";# MySQL n'a retourné aucun enregistrement.

Share this post


Link to post
Share on other sites

j'ai sauvegardé, puis vidé, puis importé: erreur suivante.
Erreur

requête SQL:

-- -- Contenu de la table `ps_search_word` -- INSERT INTO `ps_search_word` (`id_word`, `id_lang`, `word`) VALUES (1901, 1, 'bourgogne'), (2039, 2, 'font'), (2228, 2, 'four'), (2227, 2, 'brais�s'), (2226, 2, 'onctueuse'), (2225, 2, 'cuisine'), (2224, 2, 'permet'), (2223, 2, 'compagnie'), (2222, 2, 'aime'), (2221, 2, 'pr�sente'), (2220, 2, 'subtilit�s'), (2038, 2, 'faisaient'), (2219, 2, 'toutes'), (2218, 2, 'saisir'), (2217, 2, 'veut'), (2216, 2, 'normalement'), (2215, 2, 'd�guste'), (2214, 2, 'la�ques'), (2213, 2, 'trappistes'), (2212, 2, 'airs'), (2211, 2, 'robe'), (2210, 2, 'respect'), (2209, 2, 'certain'), (2208, 2, 'autour'), (1900, 2, 'bulles'), (1899, 2, 'pleins'), (2207, 2, 'titrant'), (2206, 2, 'leurs'), (2205, 2, 'communiquent'), (2204, 2, 'crystal'), (2037, 2, 'interlocuteurs'), (2135, 2, 'm�lange'), (2203, 2, 'caragold'), (1898, 2, 'l�gers'), (2202, 2, 'brasser'), (2201, 2, 'utilis�s'), (2036, 2, 'nos'), (1897, 2, 'ap�ritifs'), [...]

MySQL a répondu:Documentation
#1062 - Duplicate entry '2-cors' for key 2

Share this post


Link to post
Share on other sites

j'ai trouvé la solution pour ne pas avoir d'erreur...il faut supprimer toutes les tables de la base, la commande "vider n'est pas suffisante.
Merci pour l'aide et @+

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More