Jump to content
juweeltje5

Foutieve SQL query Unknown column 'image_shop.id_product' in 'on clause'

Recommended Posts

Hallo medeforumleden,

 

Omdat PS cloud binnekort stopt heb ik de keuze gemaakt, gezocht (en gevonden) naar een nieuwe host.

Ondertussen staat mijn webshop op de server en heeft hij alles netjes weer, alleen wanneer je naar de producten wil gaan, krijg je een error te zien.

 

Ook in de backoffice kan ik geen producten zien , noch toevoegen want ik krijg volgde foutmelding: 

 

  • Foutieve SQL query
    Unknown column 'image_shop.id_product' in 'on clause'

 

r1dizvjq2liml.jpg

  •  

 

ik heb nu even via een ander forum https://www.cms-systemy.cz/forum/prestashop/136-nefunkcni-produkty-v-prestashop-1-6-1-0-unknown-column-image-shop-id-product-in-on-clause (ik denk Russisch) proberen uit te voeren wat in #239 staat , maar daar krijg ik volgende foutmelding:

 

 

vieyhrh2dtjuo.jpg

 

Kan er mij iemand uitleggen wat ik moet doen....

Ik heb slechts een geringe kennis van webshops op een server te zetten, maar ik heb de laatste 36 uur al veel bijgeleerd.... :)

 

met dank

juweeltje

Edited by juweeltje5 (see edit history)

Share this post


Link to post
Share on other sites

Ondertussen heb ik al een klein deeltje kunnen oplossen.
Door #14 op deze topic te volgen https://www.prestashop.com/forums/topic/451419-mauvaise-requête-sql-unknown-column-image-shopid-product-in-on-clause/?p=2116716, kan ik nu in de backoffice (gelukkig) al mijn producten terug zien, MAAR....

 

ik kan geen nieuwe producten aanmaken, want durf ik op opslaan klikken, dan vlieg ik prompt uit backoffice.

Ook kan ik in de frontoffice niet op de producten klikken, want daar krijg ik ook nog steeds een error...... :(

Ook wanneer ik bv een categorie aanmaak en opsla, vlieg ik eruit , maar hij staat er dan wel op.....en voor het terug verwijderen idem. 

Edited by juweeltje5 (see edit history)

Share this post


Link to post
Share on other sites

ondertussen ben ik weer een stap verder.

 

ik kan dus ook producten aanmaken en aanpassen...

maar ik heb helaas nog wat problemen ontdekt...

Share this post


Link to post
Share on other sites

ondertussen zelf opgelost door:

 

een backup te nemen van mijn webshop

de module 1-click-update te installeren

mijn versie 1.6.0.14 updaten naar 1.6.1.10

 

:)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More