Jump to content

[RESOLU] Message erreur dans le Back Office


Recommended Posts

Bonjour

Je viens de metre a jour ma boutique en 1.3.1

Je remarque que dans la back office , j'ai 2 message d'erreur :


- ONGLET PAIEMENT -> Voir message1.jpg

*******************************
Restrictions des groupes

Merci de cocher pour chaque groupe le ou les modules de paiement à activer.

Warning: Invalid argument supplied for foreach() in /homepages/29/d330815028/htdocs/prestashop/admin007/tabs/AdminPayment.php on line 138
********************************

- ONGLET BON DE REDUCTION : -> Voir message2.jpg

Requête SQL invalide


Avez vous une idee sur ces message d'erreur et une solution ?

Merci

24989_6VR2BraIr9lxjMvSwi45_t

24990_mfYXdCBza3zAM8VpQ5Yb_t

Share this post


Link to post
Share on other sites

On a pas forcément la réponse, personnellement je ne l'ai pas comme ca, faudra analyser de plus prêt sur votre site pour trouver l'origine du problème.

Share this post


Link to post
Share on other sites

Bon pour le probleme de Requete SQL invalide , ca doit etre un bug , car je ne suis pas le seul

Sinon pour l'autre problème.

Warning: Invalid argument supplied for foreach() in /homepages/29/d330815028/htdocs/prestashop/admin007/tabs/AdminPayment.php on line 138 **

Avant ma boutique était en 1.3 herbeger sur un OVH Kimsufi

J'ai voulu tous transferer sur un herbergement 1an1

Voila comment j'ai proceder

1- j'ai dezipper la nouvelle version 1.3.1 sur le serveur 1an1
2 - j'ai installer mon ancien base de donnee
3 - j'ai remplacer ou place tous les fichiers img , module , mail , .htaccess comme sur la procedure.
4 - Puis j'ai lancer l'installation -> Mis a jour

Voila
est ce que j'ai louper quelque chose ou est ce que je devrai reinstaller la boutique ??

J'ai entendu parler de mis a jour de base de donnéé ! ca peut venir de la ?????

Share this post


Link to post
Share on other sites

j'ai fait de mise à jour de boutique 1.2.5 en 1.3.10 et pas rencontrer se genre de problème c'est étonnant ! contacter moi par MP pour me passer les accès et je regarderai ce week-end ce que je peux faire

Share this post


Link to post
Share on other sites

Pour essayer ! je viens de relancer une nouvelle installation

Idem

Warning: Invalid argument supplied for foreach() in /homepages/29/d330815028/htdocs/prestashop/admin007/tabs/AdminPayment.php on line 138 **

La ligne 138 correspond à ce code PHP : foreach ($items as $items)

Share this post


Link to post
Share on other sites

j'ai résolu le problème il fallais mettre à jours la base avec les requêtes sql des nouvelles versions
dans le dossier install/sql/upgrade tu trouvera différent fichier sql
ouvre les un à un (fait un ctrl + h pour remplacer le préfixe de la table remplace 'PREFIX_' par 'tonprefix_')
puis copie et colle le code dans la partie sql dans phpmyadmin
si à la base ta version était 1.3.0.1 répète la même chose avec tout les fichiers à partir du 1.3.0.2

Share this post


Link to post
Share on other sites
  • 2 months later...

Bonjour,

Vous avez pu résoudre votre problème ? car j'ai exactement le même problème, même message.
Warning: Invalid argument supplied for foreach() in /home/monsite/public_html/elibrairie/adminxxx/tabs/AdminPayment.php on line 138
ça serait bien d'avoir un retour sur ces problèmes visiblement récurrents.

Share this post


Link to post
Share on other sites
j'ai résolu le problème il fallais mettre à jours la base avec les requêtes sql des nouvelles versions
dans le dossier install/sql/upgrade tu trouvera différent fichier sql
ouvre les un à un (fait un ctrl + h pour remplacer le préfixe de la table remplace 'PREFIX_' par 'tonprefix_')
puis copie et colle le code dans la partie sql dans phpmyadmin
si à la base ta version était 1.3.0.1 répète la même chose avec tout les fichiers à partir du 1.3.0.2


Il faut essayer ceux ci
pour resoudre le probleme

:)

EDIT : J'ai mis RESOLU dans le premier post

Share this post


Link to post
Share on other sites

Rebonjour,

Si j'ai bien compris je dois reprendre ma valise Install de la version 1.3.1 ma version actuelle installée, ouvrir tous les sql de la valise upgrade et y substituer mon préfix ps_ à PREFIX dans le fichier ET dans tous les fichiers .sql de la valise?

Faut-il vraiment faire tout ça pour ce seul message aux restrictions de groupe ? N'y a-t-il pas d'autre solution?? Et lorsqu'il y aura une nouvelle version il faudra refaire cette manip? ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More