Jump to content
jecepede

Mail verzonden, maar toch ook weer niet...

Recommended Posts

Aloha !

 

Hier even een kleine vraag van een nieuwe PrestaShop eigenaar.

 

Ik tracht mijn webwinkeltje e-mail te laten verzenden.

In eerste instantie lijkt dat allemaal goed te gaan. Ik heb bij "Geavanceerde Instellingen" -) "Email" netjes mijn SMTP gegevens ingeven. Wanneer ik op het zelfde scherm een test bericht verzend naar bijvoorbeeld mijn Hotmail account komt dit aan.

 

Ga ik echter met mijn test account, Jantje Beton, een bestelling plaatsen, komt er niets aan mail aan in hetzelfde Hotmail account. Ga ik vervolgens naar de bestelling en ik klik daar op de knop [ Email opnieuw versturen ], krijg ik slechts een rode balk met de onderstaande melding :

 

Er is een fout opgetreden bij het verzenden van een e-mail naar de klant.

 

 

Ik heb geen idee wat ik daar nu weer mee aanmoet ?

 

 

Groetjesssssssssss

 

 

Jessy

 

 

Share this post


Link to post
Share on other sites

How many times did you tried? Sometime such problems are temporary because of server hang specially when it is shared server. Try again after sometime.

Share this post


Link to post
Share on other sites

Aloha !

 

Thank you  modprestashop for you prompt answer however, I already tried two different mail-servers in the last couple of days.

Currently I use my own mail server and I can't even see the mail getting received by postfix. So I guess that means the problem is in the PrestaShop...

 

 

 

Cheeeeeeeeeeeeeers mate,

 

Jessy

Share this post


Link to post
Share on other sites

Hallo Collega

 

Twee aspecten. 

 

1/ wellicht kun je even proberen of de PHP mail() functie een goed resultaat geeft.

2/ van de Hotmail, Live, Outlook accounts is het bekend dat Microsoft een redelijk streng beleid heeft wat betreft spam. Kijk daarom ook even online in je spambox. Als dit gebeurt zul je waarschijnlijk een spf record moeten plaatsen in de DNS. Dit heeft echter dan ook gevolgen voor het verzenden van e-mail van andere locaties, die niet via je eigen SMTP worden verzonden. 

 

Probeer eerst eens de mail() van PHP in plaats van SMT

Share this post


Link to post
Share on other sites

Aloha mede winkelier....

 

Standaard staat deze optie meen ik op mail(). 

Voor de zekerheid nog eens geprobeerd maar helaas. Weer het zelfde geneuzel.

 

Het test bericht komt aan (die zie ik ook in de logfiles van de mailserver voorbij lopen),

maar e mail via de knop [ Email opnieuw versturen ] komt niet aan en is ook niet te zien in de logfiles van de mail-bak...

 

 

Cheeeeeeeeeeers

 

Jessy

Share this post


Link to post
Share on other sites

Ik heb precies hetzelfde probleem, of ik nu PHP of de SMTP invul en ik stuur de testmail naar 3 willekeurige adressen werkt het prima. Zodra de webshop een bevestiging van een bestelling of iets stuurt komen ze niet aan. Enig idee hoe ik dit kan oplossen?

Share this post


Link to post
Share on other sites

@jessy, Kun je nakijken of het mail adres wat je gebruikt voor het account wel correct is. Bijvoorbeeld geen , of zo en de status voor de bestelling die je gebruikt, wel de juiste documenten maakt? zie onder <Bestellingen>statussen. Heb je een site online staan zodat ik een test account en test aankoop kan doen?

 

@kevinkl, 1/ heb je aangeven dat de klant een mail moet ontvangen <Bestellingen>statussen

2/ voor je eigen beheerders email staat de module mail aan? zie onder <modules>email notificaties

Share this post


Link to post
Share on other sites

@jessy, je kunt ook even kijken of vor de juiste taal de e-mail bestanden wel aanwezig zijn. <Locaties><vertalingen>Optie vertalingsoort-e-mail template vertalingen,kies het juiste thema,kies de juiste taal en go

 

Kijk of je een foutmelding ziet, de kern e-mails moeten er 66 zijn, althans voor voor versie 1.6.0.9

Share this post


Link to post
Share on other sites

@Deoorbel,

 

Dank voor je reactie, beide zijn ingeschakeld. Als ik een status van een bestelling verander of ik kies voor e-mail opnieuw sturen krijg ik vervolgens deze foutmelding:

"Er is een fout opgetreden bij het verzenden van een e-mail naar de klant."

 

Enig idee wat het zou kunnen zijn? Verder draait alles prima.

Share this post


Link to post
Share on other sites

@kevinkl kijk ook even of je voor de taal wel de juiste e-mail templates hebt. zie voorgaande post.

Share this post


Link to post
Share on other sites

Tnx, als ik daar kijk krijg ik onderstaande foutmelding, hij heeft wel de 66 kernmails gevonden, 0 vertalingen ontbreken.

Vertaalbestand van e-mailonderwerp niet gevonden in "/mnt/web017/e1/40/57616940/htdocs/prestashop/themes/default-bootstrap/mails/nl/".

Share this post


Link to post
Share on other sites

Kijk even in de directory met ftp. als je 66 kern e-mails hebt dan moeten er 67 bestanden in die /nl directory staan.

Share this post


Link to post
Share on other sites

@ kevinkl

 

Ik vermoed dat het bestand lang.php niet aanwezig is in de directory? Hierin staan de onderwerpen van de mails

Share this post


Link to post
Share on other sites

Helder, was net zelf ook al wat meldingen tegengekomen. Lijkt inderdaad een bug te zijn. Bedankt zover!

  • Like 1

Share this post


Link to post
Share on other sites

Hoi hoi iedereen !

 

@jessy, Kun je nakijken of het mail adres wat je gebruikt voor het account wel correct is. Bijvoorbeeld geen , of zo en de status voor de bestelling die je gebruikt, wel de juiste documenten maakt? zie onder <Bestellingen>statussen. Heb je een site online staan zodat ik een test account en test aankoop kan doen?

 

 

Het email adres is correct. Voor de zekerheid nog een aantal verschillende geprobeerd. Mocht niet baten

 

 

@jessy, je kunt ook even kijken of vor de juiste taal de e-mail bestanden wel aanwezig zijn. <Locaties><vertalingen>Optie vertalingsoort-e-mail template vertalingen,kies het juiste thema,kies de juiste taal en go

 

Kijk of je een foutmelding ziet, de kern e-mails moeten er 66 zijn, althans voor voor versie 1.6.0.9

 

Ik kan eigenlijk in de mappen structuur de taal EN vinden ?

 

Vermoed dat het inderdaad deze bug is : http://forge.prestas...owse/PSCSX-8398

 

 

Alleen, hoe kom ik nu vervolgens aan de ontbrekende bestanden ? 

Kan ik die uit een oudere versie proberen of is daar het formaat anders van ?

 

 

Cheeeeeeeeeers

 

Jessy

Share this post


Link to post
Share on other sites

Hallo Jessy,

 

Kun je met ftp bij de site. Dan staat er in ieder geval een Engelse versie in de map Mails/en/ hij heet lang.php. Deze kun je kopiëren en plaatsen op de locatie <theme>mails/nl/

 

Dan heb je weliswaar de Engelse versie. Maar werkt volgens mij wel.

 

Je kunt altijd met een text editor de Engelse tekst vervangen.

 

Ik weet niet of een oude versie ook werkt. 

 

Groeten Henk Wouda

Share this post


Link to post
Share on other sites

Hoi Henk,

 

 

In de map ./htdocs/themes/default-bootstrap/lang staat wel een bestandje eng.php

maar als ik deze copieer naar nl.php werkt dit niet.

 

Toch heb ik het werkend gekregen.

Ik heb in de map ./htdocs/mails een map ./en zien staan.

Deze heb ik in zijn totaliteit gekopieerd naar ./nl en dat was voldoende.

 

Voor de nieuwsgierige onder ons, onder andere deze bestanden staan er in :

 

 .
 .
 .
 order_merchant_comment.html
 order_merchant_comment.txt
 order_return_state.html
 order_return_state.txt
 outofstock.html
 outofstock.txt
 password.html
 password_query.html
 password_query.txt
 password.txt
 payment_error.html
 payment_error.txt
 payment.html
 payment.txt
 preparation.html
 .
 .
 .
 
 

Elk bestandje is een mail die verzonden kan worden. De inhoud is aan te passen naar believen.

 

 

Cheeeeeeeeeeeers,

 

Jessy

Share this post


Link to post
Share on other sites

Hallo Jessy,

 

Het was denk ik voldoende geweest om het bestand lang.php te kopiëren.

 

Je kunt dit bestand vinden op.  <domein>/mails/en of op <domein>/mails/nl

 

Je moet dit vervolgens kopieren naar:

 

<domein>/<thema>/mails/nl of <domein>/<thema>/mails/<welke taal dan ook>

 

Met vriendelijke groeten,

Henk

Edited by Deoorbel (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More