Jump to content
Sign in to follow this  
Bastia

[RESOLU] Impossible d'écrire dans la BDD depuis le back-office

Recommended Posts

Bonjour à tous,

Je viens d'installer Prestashop (que je commence à connaitre un petit peu) sur un nouvel hébergement (Icodia en l'occurence).

Installation de base, avec les produits par défaut et tout ça. Tout s'est bien passé pendant l'installation, pourtant, une fois dans le back office, impossible d'ajouter quoi que ce soit: ni produits, ni catégories, ni utilisateurs... Rien.

Il semblerait qu'il soit impossible d'écrire dans la BDD depuis le back-office, alors que c'est possible depuis le front-office (passage de commande, ajout à la newsletter, panier enregistré...).

Bizarre, n'est-ce pas ?

J'ai envoyé un ticket à mon hébergeur, desfois que le problème vienne de là (MySQL 4 pose t'il un problème, d'ailleurs ?), mais si quelqu'un a une idée, je prends !

En vous remerciant !

Share this post


Link to post
Share on other sites

Bonjour,

Sur la page de téléchargement de Prestashop vous pourrez lire :

- MySQL 5** ou supérieur

** PrestaShop fonctionne avec MySQL 4.1.15 à 5.0 mais quelques fonctionnalités sont bloquées ou ont des comportements étranges

Share this post


Link to post
Share on other sites

Bonsoir,
penche sur ton .htaccess surtout il faut configurer ton environnement la dans si ce php4 ou php5 et desactive ton registre global.

Share this post


Link to post
Share on other sites

???
rien compris. parlez-vous français ?
merci d'être plus clair dans vos posts.

Share this post


Link to post
Share on other sites

Bonsoir,
le tour de moderateurs donc ce la 3eme fois.. mon niveau en francais pas tros elevé merci de ton remarque.

Share this post


Link to post
Share on other sites

Merci ould.abeidy,

En effet c'était une histoire de .htaccess, j'avais une version de osCommerce qui tournait à la racine de mon site, et dans son fichier htaccess, on pouvait trouver les lignes suivantes:

RewriteEngine On
RewriteCond %{THE_REQUEST} ^(GET|POST|HEAD)\ (/.*)?/index.(htm|html|php|asp|shtml)
RewriteRule ^(.*)index.(htm|html|php|asp|shtml)$ /$1 [R=301,L]



qui posaient problème (merci le service client d'Icodia pour me l'avoir fait remarqué, franchement réponse très rapide, c'est rare).

J'ai donc mis ces lignes en commentaire en attendant, et ça marche impec :)

Share this post


Link to post
Share on other sites
Bonsoir,
le tour de moderateurs donc ce la 3eme fois.. mon niveau en francais pas tros elevé merci de ton remarque.


hello ! aucun problème ! je m'en doutais.. ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More