Jump to content

Variation specific name "Colour" used for pictures does not exist in variation specific set. "Colour


Recommended Posts

'Variation specific name "Colour" used for pictures does not exist in variation specific set.

"Colour"'

 

 

Please can anyone help explain what this means. I list some items they work fine and then this error comes up and the free ebay module will not update and I have to edit all the quantities on both shops manually.

 

I have tried to google the answer but nothing makes any sense.

 

thank-you

Edited by Sarahbirdsboutique (see edit history)

Share this post


Link to post
Share on other sites

OK I managed to get it to list items with combinations by ensuring that each combination had a Reference code. This then published to Ebay, but the listing does not show Colour as the option, it show MPN as the label for the drop down list and the Reference code  as the values. - Not what I expected.

 

So in order to get colour I need to add colour as the Reference Code - seems something has been referenced wrong in the code - is this a bug?

Share this post


Link to post
Share on other sites

OK I managed to get it to list items with combinations by ensuring that each combination had a Reference code. This then published to Ebay, but the listing does not show Colour as the option, it show MPN as the label for the drop down list and the Reference code  as the values. - Not what I expected.

 

So in order to get colour I need to add colour as the Reference Code - seems something has been referenced wrong in the code - is this a bug?

 

I just tried this but it's not working for me. I've just added a new dress and cannot get it to onto ebay at all with the same error as before

Share this post


Link to post
Share on other sites

well I don't know, but for me recently yes that's exactly what happens. W'eve been trying to use prestashop for about a year and this is the first time I've had this particular problem

 

Unfortunately I still have two products with the same error but no out of stock combinations that won't sync... so it can't just be the quantity

Share this post


Link to post
Share on other sites

The saga continues - I think this is more to do with changes in Ebay than problems with the module.

 

Now here is what I have discovered. Create the product with no base price set and no EAN or Reference code, instead set all prices and EAN etc in the combinations; then all works as expected and updates are sent perfectly. Zero quantity in one or more of the variations is not an issue. If you have zero in all variations then of course the product is deleted from Ebay.

 

Also worth noting that if you don't set a combination image then on eBay you also get MPN, so for example if you have colour as your variation then Ebay sets this MPN variation too. So to get rid of this make sure you set a variation image and make sure that in the module advance setting the Do not send variations images is unchecked.  

 

I hope this helps and I will continue to monitor and report back.

Edited by grumbley (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More