Jump to content
magicJu

[PS 1.6] API Update Customer : Error password

Recommended Posts

Bonsoir,

 

J'essai actuellement de mettre à jour les clients depuis un outil que je développe. J'ai un souci sur l'envoi du XML qui me retourne cette erreur :

<?xml version="1.0" encoding="UTF-8"?>
<prestashop xmlns:xlink="http://www.w3.org/1999/xlink">
<errors>
<error>
<code><![CDATA[85]]></code>
<message><![CDATA[Validation error: "Property Customer->passwd length (50) must be between 0 and 32"]]></message>
</error>
</errors>
</prestashop>

Effectivement, lorsque je récupère le client, j'ai un passwd comme ceci : 

<passwd><![CDATA[6dcf9270acf07808b9cb754705ba58ff2e51a0fc:131095121]]></passwd>

Visiblement, PS veut le password en clair. Le problème est que je ne le connais pas et que je ne veux surtout pas le changer !

Si je fais un unset() de la ligne passwd du XML que je reçois, j'ai ce message : 

<?xml version="1.0" encoding="UTF-8"?>
<prestashop xmlns:xlink="http://www.w3.org/1999/xlink">
<errors>
<error>
<code><![CDATA[41]]></code>
<message><![CDATA[parameter "passwd" required]]></message>
</error>
</errors>
</prestashop>

Ma question est donc : y-a-t-il une solution pour éviter d'avoir à fournir le password du client dans le XML que j'envoie à PS ?

 

Je n'ai pas trouvé de documentation à ce sujet.

 

Merci d'avance,

 

 

Share this post


Link to post
Share on other sites

Bonjour, 

Avez-vous trouvé une solution ? Je suis dans le même cas pour ajouter un client via le Webservice prestashop.

Merci

Enzo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More