Jump to content

BUG: Input data for tag is invalid or missing: Item.PictureDetails.PictureURL


Recommended Posts

I have 8 products in a category. They are all very similar. For 3 of those products I get this error message and the products are not listed on ebay.

 

I've googled this error message and tried out everything I could think of: using other images, rebuilding images, deleting the images of those products and adding new images.

 

I turned on logging of the ebay module and see this:

...
<Country>DE</Country>
<AutoPay>0</AutoPay>
<ConditionID>1000</ConditionID>
<PictureDetails>
	<GalleryType>Gallery</GalleryType>
	<PictureURL></PictureURL>
</PictureDetails>
<SKU>prestashop-2424</SKU>
<ListingDuration>GTC</ListingDuration>
<Quantity>20</Quantity>
...
PictureURL is empty. Edited by oh_prestashop (see edit history)

Share this post


Link to post
Share on other sites

In the meatime I found a workaround for this problem. The error seems to occur, when a product does not have enough images attached.

Let's all praise the developer of this plugin for this ingenious piece of code. Amen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More