Jump to content
djtof

Erreur avec module Alerte Emails et Librairie Swift

Recommended Posts

Bonjour,

 

Je viens de faire la mise a jour de ma boutique, plutot ancienne, 1.2.4 en 1.6.1.5

 

J'ai suivi les étapes une à une afin de passer sur la dernière version, en passant en premier lieu par une 1.4.

 

Jusque là tout va bien. Des commandes sont passées sans soucis.

 

A ce jour, j'ai un soucis.

Lorsque j'active le module Mail Alert (natif), je me retrouve avec des erreurs dont je ne trouve pas la solution.

La première est celle ci:

 

Lorsque je modifie diminue la quantité d'un de mes produits, qui en gestion avancé, j'ai cette erreur, par contre le stock ce met bien a jour.

Si je fait un ajout, il y a aucun soucis.

 

http://prntscr.com/bbfwpt

 

Si je désactive le module Mail Alert je n'ai plus cette erreur.

 

Et j'ai aussi une autre erreur, j'ai un module GLS qui me permet de mettre à jour grace a un fichier csv, les numéros de suivi de mes commandes.

Lorsque j'essaye d'importer mon fichier csv, j'ai cette erreur:

 

Catchable fatal error: Argument 1 passed to Swift_Mime_SimpleMessage::__construct() must be an instance of Swift_Mime_HeaderSet, none given in /var/www/vhosts/tout-le-niva.com/httpdocs/www/tools/swift/classes/Swift/Mime/SimpleMessage.php on line 27

 

 

si quelqu'un pourrait me donner un coup de main sur ces erreurs, cela m'arrangerais bien.

 

Merci

Share this post


Link to post
Share on other sites

Je viens de désactiver le mod DEV, et je ne vois plus le message forcément.

Mais je recoi le mail de rupture de stock concernant la mise a jour du stock.

 

Pour le suivi de GLS je ne trouve pas.

Share this post


Link to post
Share on other sites

Bonjour,

J'ai le même message d'erreur avec un autre module. Vous avez trouvé comment résoudre le problème ?

Merci :)

Share this post


Link to post
Share on other sites

J'ai fait la mise a jour de prestashop en 1.6.1.6 et plus rien.

Share this post


Link to post
Share on other sites

Certaines classes de swift ont changé lors de la version 1.6.1.5. Il faut donc trouver quelles anciennes classes étaient appelées et les remplacer par les nouvelles...C'est ne tout cas comme ça que j'ai "réparé" mon module qui ne fonctionnait plus.

Share this post


Link to post
Share on other sites

Certaines classes de swift ont changé lors de la version 1.6.1.5. Il faut donc trouver quelles anciennes classes étaient appelées et les remplacer par les nouvelles...C'est ne tout cas comme ça que j'ai "réparé" mon module qui ne fonctionnait plus.

 

Mon problème apparaît sur une nouvelle installation de PrestaShop 1.6.1.6. :(

Share this post


Link to post
Share on other sites

Peut être que le module n'est lui pas à jour et donc pas compatible avec 1.6.1.5 et 1.6.1.6. 

J'ai peur qu'il faille aller vérifier le code du module, ou trouver quelqu'un qui sache, moi je ne suis qu'un bidouilleur :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More