Jump to content
kyotokitsune

Problème Avec Google Analytics

Recommended Posts

Bonjour,


 


Comme beaucoup de personnes ici j'ai le problème de reconnaissance de google Analytics sur mon site prestashop 1.6.


 


J'ai installé le module Google Analytics API que j'ai bien configuré en suivant la procédure mais j'ai eu le message suivant : Cannot retrieve test results


 


J'ai attendu 2 jours mais rien n'a changé


 


J'ai ensuite essayé de mettre le code de suivi dans le fichier header comme indiqué par google mais lorsque j'insère le code mon site affiche une page blanche.


 


Ensuite j'ai essayé de désactiver le module et insérer seulement le code dans le header mais même problème.


 


J'ai donc finalement tout retirer pour le moment mais j'aimerai bien trouve une solution.


 


J'ai aussi soumis mon problème au forum de google mais personne n'a de solution.


 


Quelqu'un pourrait-il m'aider ?


 


Mon site est www.kyotokitsune.com


Share this post


Link to post
Share on other sites

Bonjour,

 

D'abord, il faut séparer :

  • "Google Analytics v2.3.4"
    • Suivre les visite de son site sur GA
    • Pour la configuration on a juste besoin de la clé genre UA-xxxxx-x
  • "API Google Analytics v1.2.1"
    • Utiliser les API de google pour afficher les résultat de GA dans son back office prestashop
    • Pour la config, on a besoin de 3 paramètre : ID client / Secret client / Profil

 

Si j'ai bien compris, le besoin est plus le premier point, donc essaye juste de mettre la bonne clé. Si c'est le second, c'est plus compliqué mais je te ferai un tuto lundi si besoin.

 

Puis l'origine de la page blanche quand tu as essayé de mettre le code de google directement dans ton header, bien que inutile car le module le fait pour toi, c'est que pour insérer un script JS dans du template smarty, il faut l'entourer de {literal} ... {/literal} : exemple :

<script language="JavaScript" type="text/javascript">
 {literal}
 function myJsFunction(name, ip){
 alert("Le nom du serveur\n" + name + "\n" + ip);
 }
 {/literal}
</script>

A+

Share this post


Link to post
Share on other sites

Bonjour,

 

Merci pour ta réponse, je n'avais pas vu qu'il y avait 2 modules Google Analytics

 

Celui que je tente d'installer concerne API Google analytics.

J'ai bien essayé d'insérer le code avec {literal} , j'avais vu cette astuce dans un autre post mais cela ne fonctionne pas.

D'autre part j'ai vu d'autres personnes dire que le module insère le script lui-même mais rien n'apparaît dans mon header lorsque le module est activé.

Je précise que j'ai bien renseigné les 3 paramètres (ID client / Secret client /Profil).

 

Mais maintenant je me dis que le problème est peut être tout simlement que je dois d'abord installer Goole Analytics avant API

Je vais essayer à nouveau et je te dis si ça fonctionne

 

@+

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai installé le module Google Analytics ce qui a résolu le problème concernant la propriété.

 

J'ai ensuite installé de nouveau API Google Analytics qui au début m'affichait toujours le message d'erreur mais le lendemain tout était correct.

 

Maintenant les statistiques ne s'affichent plus sur mon tableau de bord, ni sur Google Analytics. Par contre lorsque je vais dans le module API google analytics pour vérifier que tout va bien je vois une ligne qui m'indique le nombre de personnes et le nombre de pages vu.

D'autre part dans mon header  le code de google analytics n'est toujours pas inséré.

 

Une idée sur ce que je dois faire maintenant ?

 

Merci

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai regardé ton site, le code google analytics est bien présent juste avant la balise </body> et comme le montre le résultat du module API google analytics, c'est ok.

Après, 

 

 

les statistiques ne s'affichent plus sur mon tableau de bord, ni sur Google Analytics

 

Là, faut regarder dans les doc des  modules, ou essaye de désactiver :

  • API google analytics et voit le résultat sur https://www.google.com/analytics/web/
  • Si ça fonctionne, je te recommande de ne pas utiliser API google analytics. A moins que ton besoin est juste de connaitre le nombre de personnes et le nombre de pages vu.

Share this post


Link to post
Share on other sites

Bonjour,

 

Ok je pensais que le code se trouvait toujours au niveau du header

Merci pour ton aide

 

@+

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More